Update to 0.26.1
This commit is contained in:
parent
9e547e2ee3
commit
d0cc3537de
1
.gitignore
vendored
1
.gitignore
vendored
@ -40,3 +40,4 @@ dconf-0.5.tar.bz2
|
|||||||
/dconf-0.24.0.tar.xz
|
/dconf-0.24.0.tar.xz
|
||||||
/dconf-0.25.1.tar.xz
|
/dconf-0.25.1.tar.xz
|
||||||
/dconf-0.26.0.tar.xz
|
/dconf-0.26.0.tar.xz
|
||||||
|
/dconf-0.26.1.tar.xz
|
||||||
|
12
dconf.spec
12
dconf.spec
@ -2,8 +2,8 @@
|
|||||||
%define vala_version 0.18.0
|
%define vala_version 0.18.0
|
||||||
|
|
||||||
Name: dconf
|
Name: dconf
|
||||||
Version: 0.26.0
|
Version: 0.26.1
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A configuration system
|
Summary: A configuration system
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -12,9 +12,6 @@ URL: http://live.gnome.org/dconf
|
|||||||
#VCS: git:git://git.gnome.org/dconf
|
#VCS: git:git://git.gnome.org/dconf
|
||||||
Source0: http://download.gnome.org/sources/dconf/0.26/dconf-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/dconf/0.26/dconf-%{version}.tar.xz
|
||||||
|
|
||||||
Patch0: gtype-threads.patch
|
|
||||||
|
|
||||||
BuildRequires: git
|
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
BuildRequires: vala-devel >= %{vala_version}
|
BuildRequires: vala-devel >= %{vala_version}
|
||||||
BuildRequires: gtk-doc
|
BuildRequires: gtk-doc
|
||||||
@ -37,7 +34,7 @@ development using dconf.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -Sgit -n %{name}-%{version}
|
%autosetup -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -88,6 +85,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%{_datadir}/vala
|
%{_datadir}/vala
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 09 2017 Kalev Lember <klember@redhat.com> - 0.26.1-1
|
||||||
|
- Update to 0.26.1
|
||||||
|
|
||||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.26.0-5
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.26.0-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
@ -1,30 +0,0 @@
|
|||||||
From 701d19d12d4e0599340c9bd1eb2b3e25a40d780b Mon Sep 17 00:00:00 2001
|
|
||||||
From: Colin Walters <walters@verbum.org>
|
|
||||||
Date: Fri, 18 Nov 2016 16:40:23 -0500
|
|
||||||
Subject: gdbus: Work around threading deadlock in glib
|
|
||||||
|
|
||||||
See https://bugzilla.gnome.org/show_bug.cgi?id=674885
|
|
||||||
for more details. What dconf is doing right now provokes
|
|
||||||
this more easily by involving *another* thread in the mix.
|
|
||||||
---
|
|
||||||
gdbus/dconf-gdbus-thread.c | 4 ++++
|
|
||||||
1 file changed, 4 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/gdbus/dconf-gdbus-thread.c b/gdbus/dconf-gdbus-thread.c
|
|
||||||
index e397e3a..8ed28b5 100644
|
|
||||||
--- a/gdbus/dconf-gdbus-thread.c
|
|
||||||
+++ b/gdbus/dconf-gdbus-thread.c
|
|
||||||
@@ -94,6 +94,10 @@ dconf_gdbus_get_worker_context (void)
|
|
||||||
{
|
|
||||||
GMainContext *context;
|
|
||||||
|
|
||||||
+ /* Work around https://bugzilla.gnome.org/show_bug.cgi?id=674885 */
|
|
||||||
+ g_type_ensure (G_TYPE_DBUS_CONNECTION);
|
|
||||||
+ g_type_ensure (G_TYPE_DBUS_PROXY);
|
|
||||||
+
|
|
||||||
context = g_main_context_new ();
|
|
||||||
g_thread_new ("dconf worker", dconf_gdbus_worker_thread, context);
|
|
||||||
g_once_init_leave (&worker_context, context);
|
|
||||||
--
|
|
||||||
cgit v0.12
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user