0.7
This commit is contained in:
parent
44f11fa799
commit
c0eb1109c2
14
dconf-bus-get.patch
Normal file
14
dconf-bus-get.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up dconf-0.7/tests/dbus1.c.bus_get dconf-0.7/tests/dbus1.c
|
||||||
|
--- dconf-0.7/tests/dbus1.c.bus_get 2011-01-17 14:35:51.234171003 -0500
|
||||||
|
+++ dconf-0.7/tests/dbus1.c 2011-01-17 14:36:01.364171019 -0500
|
||||||
|
@@ -184,9 +184,7 @@ setup (void)
|
||||||
|
|
||||||
|
g_setenv ("DCONF_PROFILE", "test", false);
|
||||||
|
|
||||||
|
- backend = dconf_dbus_client_new ("test",
|
||||||
|
- dbus_bus_get (DBUS_BUS_SYSTEM, 0),
|
||||||
|
- dbus_bus_get (DBUS_BUS_SESSION, 0));
|
||||||
|
+ backend = dconf_dbus_client_new ("test", NULL, NULL);
|
||||||
|
dconf_dbus_client_subscribe (backend, "/", watch_func, NULL);
|
||||||
|
|
||||||
|
implicit = g_hash_table_new_full (g_str_hash, g_str_equal,
|
13
dconf.spec
13
dconf.spec
@ -10,6 +10,7 @@ License: LGPLv2+
|
|||||||
URL: http://live.gnome.org/dconf
|
URL: http://live.gnome.org/dconf
|
||||||
#VCS: git:git://git.gnome.org/dconf
|
#VCS: git:git://git.gnome.org/dconf
|
||||||
Source0: http://download.gnome.org/sources/dconf/0.7/dconf-%{version}.tar.bz2
|
Source0: http://download.gnome.org/sources/dconf/0.7/dconf-%{version}.tar.bz2
|
||||||
|
Patch0: dconf-bus-get.patch
|
||||||
|
|
||||||
BuildRequires: glib2-devel >= %{glib2_version}
|
BuildRequires: glib2-devel >= %{glib2_version}
|
||||||
Requires: dbus
|
Requires: dbus
|
||||||
@ -50,6 +51,7 @@ docnf-editor allows you to browse and modify dconf databases.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .bus-get
|
||||||
|
|
||||||
%build
|
%build
|
||||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
||||||
@ -79,21 +81,28 @@ gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules
|
|||||||
%{_datadir}/dbus-1/system-services/ca.desrt.dconf.service
|
%{_datadir}/dbus-1/system-services/ca.desrt.dconf.service
|
||||||
%{_bindir}/dconf
|
%{_bindir}/dconf
|
||||||
%{_libdir}/libdconf.so.*
|
%{_libdir}/libdconf.so.*
|
||||||
|
%{_libdir}/libdconf-dbus-1.so.*
|
||||||
|
#%{_libdir}/girepository-1.0/dconf-1.0.typelib
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_includedir}/dconf
|
%{_includedir}/dconf
|
||||||
%{_libdir}/libdconf.so
|
%{_libdir}/libdconf.so
|
||||||
%{_libdir}/pkgconfig/dconf.pc
|
%{_libdir}/pkgconfig/dconf.pc
|
||||||
|
%{_includedir}/dconf-dbus-1
|
||||||
|
%{_libdir}/libdconf-dbus-1.so
|
||||||
|
%{_libdir}/pkgconfig/dconf-dbus-1.pc
|
||||||
# temporarily disable introspection until we have a new-enough goi
|
# temporarily disable introspection until we have a new-enough goi
|
||||||
%{_libdir}/girepository-1.0/dconf-1.0.typelib
|
#%{_datadir}/gir-1.0/dconf-1.0.gir
|
||||||
%{_datadir}/gir-1.0/dconf-1.0.gir
|
|
||||||
%{_datadir}/gtk-doc/html/dconf
|
%{_datadir}/gtk-doc/html/dconf
|
||||||
%{_datadir}/vala
|
%{_datadir}/vala
|
||||||
|
|
||||||
%files editor
|
%files editor
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_bindir}/dconf-editor
|
%{_bindir}/dconf-editor
|
||||||
|
%{_datadir}/applications/dconf-editor.desktop
|
||||||
|
%dir %{_datadir}/dconf-editor
|
||||||
|
%{_datadir}/dconf-editor/dconf-editor.ui
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Jan 17 2011 Matthias Clasen <mclasen@redhat.com> - 0.7-1
|
* Mon Jan 17 2011 Matthias Clasen <mclasen@redhat.com> - 0.7-1
|
||||||
|
Loading…
Reference in New Issue
Block a user