Update to 0.15.0
Remove upstreamed patch
This commit is contained in:
parent
38d8a9c256
commit
3a8df5edbe
1
.gitignore
vendored
1
.gitignore
vendored
@ -20,3 +20,4 @@ dconf-0.5.tar.bz2
|
||||
/dconf-0.13.0.tar.xz
|
||||
/dconf-0.13.4.tar.xz
|
||||
/dconf-0.14.0.tar.xz
|
||||
/dconf-0.15.0.tar.xz
|
||||
|
@ -1,27 +0,0 @@
|
||||
From f732fba794d380a6c70ce7f82c3326a484909fba Mon Sep 17 00:00:00 2001
|
||||
From: Matthias Clasen <mclasen@redhat.com>
|
||||
Date: Sun, 21 Oct 2012 12:50:19 -0400
|
||||
Subject: [PATCH] dconf_rebuilder_get_parent: don't leak parent_name
|
||||
|
||||
Leak introduced in facae6ffcd5b2935f9b708eecb1fd5aa7c8ddf86.
|
||||
Tracked down by Fabien Tassin in
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=686573
|
||||
---
|
||||
service/dconf-rebuilder.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/service/dconf-rebuilder.c b/service/dconf-rebuilder.c
|
||||
index 3f170d6..2b79e18 100644
|
||||
--- a/service/dconf-rebuilder.c
|
||||
+++ b/service/dconf-rebuilder.c
|
||||
@@ -57,6 +57,7 @@ dconf_rebuilder_get_parent (GHashTable *table,
|
||||
if (grandparent != NULL)
|
||||
gvdb_item_set_parent (parent, grandparent);
|
||||
}
|
||||
+ g_free (parent_name);
|
||||
|
||||
return parent;
|
||||
}
|
||||
--
|
||||
1.7.12.1
|
||||
|
15
dconf.spec
15
dconf.spec
@ -2,15 +2,15 @@
|
||||
%define vala_version 0.11.7
|
||||
|
||||
Name: dconf
|
||||
Version: 0.14.0
|
||||
Release: 4%{?dist}
|
||||
Version: 0.15.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A configuration system
|
||||
|
||||
Group: System Environment/Base
|
||||
License: LGPLv2+ and GPLv2+ and GPLv3+
|
||||
URL: http://live.gnome.org/dconf
|
||||
#VCS: git:git://git.gnome.org/dconf
|
||||
Source0: http://download.gnome.org/sources/dconf/0.14/dconf-%{version}.tar.xz
|
||||
Source0: http://download.gnome.org/sources/dconf/0.15/dconf-%{version}.tar.xz
|
||||
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: gtk3-devel
|
||||
@ -22,10 +22,6 @@ BuildRequires: intltool
|
||||
|
||||
Requires: dbus
|
||||
|
||||
# upstream fix
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=686573
|
||||
Patch0: 0001-dconf_rebuilder_get_parent-don-t-leak-parent_name.patch
|
||||
|
||||
%description
|
||||
dconf is a low-level configuration system. Its main purpose is to provide a
|
||||
backend to the GSettings API in GLib.
|
||||
@ -51,7 +47,6 @@ dconf-editor allows you to browse and modify dconf databases.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure --disable-static
|
||||
@ -114,6 +109,10 @@ fi
|
||||
%{_datadir}/icons/hicolor/*/apps/dconf-editor.png
|
||||
|
||||
%changelog
|
||||
* Wed Nov 7 2012 Marek Kasik <mkasik@redhat.com> - 0.15.0-1
|
||||
- Update to 0.15.0
|
||||
- Remove upstreamed patch
|
||||
|
||||
* Wed Nov 7 2012 Marek Kasik <mkasik@redhat.com> - 0.14.0-4
|
||||
- Move %%posttrans commands to %%post (rpmlint related)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user