0.7.2
and drop patches that are no longer needed
This commit is contained in:
parent
18d80c10eb
commit
14230cc3f4
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ dconf-0.5.tar.bz2
|
||||
/dconf-0.5.1.tar.bz2
|
||||
/dconf-0.7.tar.bz2
|
||||
/dconf-0.7.1.tar.bz2
|
||||
/dconf-0.7.2.tar.bz2
|
||||
|
@ -1,14 +0,0 @@
|
||||
diff -up dconf-0.7/tests/dbus1.c.bus_get dconf-0.7/tests/dbus1.c
|
||||
--- dconf-0.7/tests/dbus1.c.bus_get 2011-01-17 14:35:51.234171003 -0500
|
||||
+++ dconf-0.7/tests/dbus1.c 2011-01-17 14:36:01.364171019 -0500
|
||||
@@ -184,9 +184,7 @@ setup (void)
|
||||
|
||||
g_setenv ("DCONF_PROFILE", "test", false);
|
||||
|
||||
- backend = dconf_dbus_client_new ("test",
|
||||
- dbus_bus_get (DBUS_BUS_SYSTEM, 0),
|
||||
- dbus_bus_get (DBUS_BUS_SESSION, 0));
|
||||
+ backend = dconf_dbus_client_new ("test", NULL, NULL);
|
||||
dconf_dbus_client_subscribe (backend, "/", watch_func, NULL);
|
||||
|
||||
implicit = g_hash_table_new_full (g_str_hash, g_str_equal,
|
@ -1,9 +0,0 @@
|
||||
diff -up dconf-0.3.1/bin/Makefile.am.pedantic-linker dconf-0.3.1/bin/Makefile.am
|
||||
--- dconf-0.3.1/bin/Makefile.am.pedantic-linker 2010-05-25 00:22:12.837474369 -0400
|
||||
+++ dconf-0.3.1/bin/Makefile.am 2010-05-25 00:22:25.043736206 -0400
|
||||
@@ -3,4 +3,4 @@ INCLUDES = -I$(top_srcdir)/{common,engin
|
||||
|
||||
bin_PROGRAMS = dconf
|
||||
|
||||
-dconf_LDADD = ../client/libdconf.la
|
||||
+dconf_LDADD = ../client/libdconf.la $(gio_LIBS)
|
@ -1,12 +0,0 @@
|
||||
diff -up dconf-0.7.1/gsettings/Makefile.am.libtool dconf-0.7.1/gsettings/Makefile.am
|
||||
--- dconf-0.7.1/gsettings/Makefile.am.libtool 2011-02-02 16:22:02.188286083 -0500
|
||||
+++ dconf-0.7.1/gsettings/Makefile.am 2011-02-02 16:22:14.612130764 -0500
|
||||
@@ -4,7 +4,7 @@ INCLUDES = -I$(top_srcdir)/common -I$(to
|
||||
giomodules_PROGRAMS = libdconfsettings.so
|
||||
|
||||
libdconfsettings_so_LDADD = $(gio_LIBS)
|
||||
-libdconfsettings_so_LDFLAGS = -module -avoid-version -shared
|
||||
+libdconfsettings_so_LDFLAGS = -shared
|
||||
libdconfsettings_so_SOURCES = \
|
||||
../engine/dconf-engine.c \
|
||||
../common/dconf-shmdir.c \
|
@ -1,24 +0,0 @@
|
||||
diff -up dconf-0.3/gsettings/dconfdatabase.c.multi-write dconf-0.3/gsettings/dconfdatabase.c
|
||||
--- dconf-0.3/gsettings/dconfdatabase.c.multi-write 2010-05-21 18:06:25.447432741 -0400
|
||||
+++ dconf-0.3/gsettings/dconfdatabase.c 2010-05-21 18:06:39.905682921 -0400
|
||||
@@ -364,7 +364,7 @@ dconf_database_write_tree (DConfDatabase
|
||||
|
||||
message =
|
||||
g_dbus_message_new_method_call ("ca.desrt.dconf", "/",
|
||||
- "ca.desrt.dconf.Writer", "Write");
|
||||
+ "ca.desrt.dconf.Writer", "Merge");
|
||||
|
||||
g_variant_builder_init (&args, G_VARIANT_TYPE ("(sa(sav))"));
|
||||
g_variant_builder_add (&args, "s", path);
|
||||
diff -up dconf-0.3/service/service.c.multi-write dconf-0.3/service/service.c
|
||||
--- dconf-0.3/service/service.c.multi-write 2010-05-19 10:42:03.000000000 -0400
|
||||
+++ dconf-0.3/service/service.c 2010-05-21 17:52:04.416434906 -0400
|
||||
@@ -204,7 +204,7 @@ method_call (GDBusConnection *conn
|
||||
serial, key, none),
|
||||
NULL);
|
||||
}
|
||||
- else if (strcmp (method_name, "Merge"))
|
||||
+ else if (strcmp (method_name, "Merge") == 0)
|
||||
{
|
||||
GError *error = NULL;
|
||||
const gchar *prefix;
|
@ -1,10 +0,0 @@
|
||||
diff -up dconf-0.3/gsettings/dconfsettingsbackend.c.query dconf-0.3/gsettings/dconfsettingsbackend.c
|
||||
--- dconf-0.3/gsettings/dconfsettingsbackend.c.query 2010-05-20 08:50:59.598535660 -0400
|
||||
+++ dconf-0.3/gsettings/dconfsettingsbackend.c 2010-05-20 08:51:56.331309861 -0400
|
||||
@@ -164,5 +164,5 @@ g_io_module_unload (GIOModule *module)
|
||||
gchar **
|
||||
g_io_module_query (void)
|
||||
{
|
||||
- return g_strsplit (",", G_SETTINGS_BACKEND_EXTENSION_POINT_NAME, 0);
|
||||
+ return g_strsplit (G_SETTINGS_BACKEND_EXTENSION_POINT_NAME, ",", 0);
|
||||
}
|
@ -1,7 +1,7 @@
|
||||
%define glib2_version 2.25.12
|
||||
|
||||
Name: dconf
|
||||
Version: 0.7.1
|
||||
Version: 0.7.2
|
||||
Release: 1
|
||||
Summary: A configuration system
|
||||
|
||||
@ -10,8 +10,6 @@ License: LGPLv2+
|
||||
URL: http://live.gnome.org/dconf
|
||||
#VCS: git:git://git.gnome.org/dconf
|
||||
Source0: http://download.gnome.org/sources/dconf/0.7/dconf-%{version}.tar.bz2
|
||||
# upstream fix
|
||||
Patch0: dconf-libtool.patch
|
||||
|
||||
BuildRequires: glib2-devel >= %{glib2_version}
|
||||
BuildRequires: dbus-devel
|
||||
@ -53,11 +51,6 @@ docnf-editor allows you to browse and modify dconf databases.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .libtool
|
||||
|
||||
aclocal
|
||||
autoconf
|
||||
automake --foreign
|
||||
|
||||
%build
|
||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
||||
|
Loading…
Reference in New Issue
Block a user