import dbus-1.12.20-5.el9
This commit is contained in:
commit
e92cefb921
2
.dbus.metadata
Normal file
2
.dbus.metadata
Normal file
@ -0,0 +1,2 @@
|
||||
f7fe130511aeeac40270af38d6892ed63392c7f6 SOURCES/dbus-1.12.20.tar.gz
|
||||
dfffbf214650cd4600454f930c1ebd9919327a11 SOURCES/gpgkey-36EC5A6448A4F5EF79BEFE98E05AE1478F814C4F.gpg
|
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
||||
SOURCES/dbus-1.12.20.tar.gz
|
||||
SOURCES/gpgkey-36EC5A6448A4F5EF79BEFE98E05AE1478F814C4F.gpg
|
14
SOURCES/00-start-message-bus.sh
Executable file
14
SOURCES/00-start-message-bus.sh
Executable file
@ -0,0 +1,14 @@
|
||||
#!/bin/sh
|
||||
# Copyright (C) 2008 Red Hat, Inc.
|
||||
#
|
||||
# All rights reserved. This copyrighted material is made available to anyone
|
||||
# wishing to use, modify, copy, or redistribute it subject to the terms and
|
||||
# conditions of the GNU General Public License version 2.
|
||||
#
|
||||
# You should have received a copy of the GNU General Public License
|
||||
# along with this program; if not, write to the Free Software
|
||||
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
|
||||
#
|
||||
if [ -z "$DBUS_SESSION_BUS_ADDRESS" ]; then
|
||||
eval `dbus-launch --sh-syntax --exit-with-session`
|
||||
fi
|
22
SOURCES/0001-tools-Use-Python3-for-GetAllMatchRules.patch
Normal file
22
SOURCES/0001-tools-Use-Python3-for-GetAllMatchRules.patch
Normal file
@ -0,0 +1,22 @@
|
||||
From 59ddde9e1ed5de03b060ff3ce27e35509707dff2 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Tue, 31 Jul 2018 12:33:59 -0400
|
||||
Subject: [PATCH] tools: Use Python3 for GetAllMatchRules
|
||||
|
||||
---
|
||||
tools/GetAllMatchRules.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tools/GetAllMatchRules.py b/tools/GetAllMatchRules.py
|
||||
index 6a7e4cd9..f7e340d6 100755
|
||||
--- a/tools/GetAllMatchRules.py
|
||||
+++ b/tools/GetAllMatchRules.py
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python3
|
||||
|
||||
import sys
|
||||
import argparse
|
||||
--
|
||||
2.17.1
|
||||
|
16
SOURCES/dbus-1.12.20.tar.gz.asc
Normal file
16
SOURCES/dbus-1.12.20.tar.gz.asc
Normal file
@ -0,0 +1,16 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQIzBAABCAAdFiEENuxaZEik9e95vv6Y4FrhR4+BTE8FAl793S8ACgkQ4FrhR4+B
|
||||
TE8Cfg//Ysb9qT9xLUvCCHdmg+efz1DCks9W21MnZ9EN7qIx/mJPZhqpy9nbaHGy
|
||||
xQl2hnYagPZXWy7ly8HpakvzYfjtyRMCd7570n/cMmVXTF5bnfOr1feScrNEEJPc
|
||||
R6LreRPVDPdiKak1bF8VeVLpil89WrtU4xRzcpWxhZLlPiN1ebOSjEKtzaW4sDYB
|
||||
KdLXLRqcVgdm44NZrTB/xic0hJrO6fhTqiJVx6Lc/CoE9FNO+/60/H2PYIWRedSm
|
||||
bEx76RmUJEn1c/+wCyixmiTE0aEWGbKIsTR5mZmnw5BFI9SegQk7cD67kLvqMgpz
|
||||
c+SMl0ivihTgcaH9jPKeg6fEvTTMkuxHQyMgYV5Rwoq0ukTgQ+b+/MjYa5OX0QqY
|
||||
4YLDqNdgVfdNabxAeGvtNoDLwIHuveB151W9/ANTd420uqkWlCjzriEAjyYv8AJt
|
||||
O53dQn6KGos8QmAKyF3dmKKZb7d2XfJLa0byHt84DeM0kAabq7P9ypf4YkbmqLCC
|
||||
Eb8kiP8FbNYaQs9i1L2D4RXK8fnZA88aQVf7yBcILJBsQDI/plZuxmSzZLMBF3dw
|
||||
SxhcGN3ArsoOqqqWnJt65Sxtt95vO9mpOvrHMB9iQWM3X2zVXh+Et8P2QY9HVhCp
|
||||
Xmj3TH9Oc6OjBipqdR8OzdTtc7lnBwjuzMhw6g2S08ZQJovniOE=
|
||||
=cwnZ
|
||||
-----END PGP SIGNATURE-----
|
15
SOURCES/dbus-daemon.service
Normal file
15
SOURCES/dbus-daemon.service
Normal file
@ -0,0 +1,15 @@
|
||||
[Unit]
|
||||
Description=D-Bus System Message Bus
|
||||
Documentation=man:dbus-daemon(1)
|
||||
Requires=dbus.socket
|
||||
|
||||
[Service]
|
||||
ExecStart=/usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation --syslog-only
|
||||
ExecReload=/usr/bin/dbus-send --print-reply --system --type=method_call --dest=org.freedesktop.DBus / org.freedesktop.DBus.ReloadConfig
|
||||
OOMScoreAdjust=-900
|
||||
|
||||
[Install]
|
||||
# Make sure that services can still refer to this under the name of the
|
||||
# old SysV script (messagebus).
|
||||
Alias=dbus.service messagebus.service
|
||||
WantedBy=multi-user.target
|
11
SOURCES/dbus-daemon.user.service
Normal file
11
SOURCES/dbus-daemon.user.service
Normal file
@ -0,0 +1,11 @@
|
||||
[Unit]
|
||||
Description=D-Bus User Message Bus
|
||||
Documentation=man:dbus-daemon(1)
|
||||
Requires=dbus.socket
|
||||
|
||||
[Service]
|
||||
ExecStart=/usr/bin/dbus-daemon --session --address=systemd: --nofork --nopidfile --systemd-activation --syslog-only
|
||||
ExecReload=/usr/bin/dbus-send --print-reply --session --type=method_call --dest=org.freedesktop.DBus / org.freedesktop.DBus.ReloadConfig
|
||||
|
||||
[Install]
|
||||
Alias=dbus.service
|
8
SOURCES/dbus.socket
Normal file
8
SOURCES/dbus.socket
Normal file
@ -0,0 +1,8 @@
|
||||
[Unit]
|
||||
Description=D-Bus System Message Bus Socket
|
||||
|
||||
[Socket]
|
||||
ListenStream=/run/dbus/system_bus_socket
|
||||
|
||||
[Install]
|
||||
WantedBy=sockets.target
|
9
SOURCES/dbus.user.socket
Normal file
9
SOURCES/dbus.user.socket
Normal file
@ -0,0 +1,9 @@
|
||||
[Unit]
|
||||
Description=D-Bus User Message Bus Socket
|
||||
|
||||
[Socket]
|
||||
ListenStream=%t/bus
|
||||
ExecStartPost=-/usr/bin/systemctl --user set-environment DBUS_SESSION_BUS_ADDRESS=unix:path=%t/bus
|
||||
|
||||
[Install]
|
||||
WantedBy=sockets.target
|
1553
SPECS/dbus.spec
Normal file
1553
SPECS/dbus.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user