kill unused patches
This commit is contained in:
parent
05d1adf825
commit
adaaccf0d6
@ -1,12 +0,0 @@
|
||||
diff -up dbus-1.1.4/tools/dbus-launch.c.babysitter-x dbus-1.1.4/tools/dbus-launch.c
|
||||
--- dbus-1.1.4/tools/dbus-launch.c.babysitter-x 2008-02-05 10:09:06.000000000 -0500
|
||||
+++ dbus-1.1.4/tools/dbus-launch.c 2008-02-05 10:09:36.000000000 -0500
|
||||
@@ -966,6 +966,8 @@ main (int argc, char **argv)
|
||||
char write_pid_fd_as_string[MAX_FD_LEN];
|
||||
char write_address_fd_as_string[MAX_FD_LEN];
|
||||
|
||||
+ xdisplay = NULL;
|
||||
+
|
||||
if (close_stderr)
|
||||
do_close_stderr ();
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff -pur 0.61-osso23/bus/signals.c 0.61-osso23.new/bus/signals.c
|
||||
--- 0.61-osso23/bus/signals.c 2006-11-23 16:46:52.589602192 +0200
|
||||
+++ 0.61-osso23.new/bus/signals.c 2006-11-23 16:49:28.873843376 +0200
|
||||
@@ -1067,6 +1067,9 @@ match_rule_equal (BusMatchRule *a,
|
||||
if (a->flags != b->flags)
|
||||
return FALSE;
|
||||
|
||||
+ if (a->matches_go_to != b->matches_go_to)
|
||||
+ return FALSE;
|
||||
+
|
||||
if ((a->flags & BUS_MATCH_MESSAGE_TYPE) &&
|
||||
a->message_type != b->message_type)
|
||||
return FALSE;
|
@ -1,20 +0,0 @@
|
||||
--- dbus-0.60/bus/messagebus.in.start-early 2005-01-18 17:20:38.000000000 -0500
|
||||
+++ dbus-0.60/bus/messagebus.in 2006-01-20 18:03:33.000000000 -0500
|
||||
@@ -2,7 +2,7 @@
|
||||
#
|
||||
# messagebus: The D-BUS systemwide message bus
|
||||
#
|
||||
-# chkconfig: 345 97 03
|
||||
+# chkconfig: 345 22 85
|
||||
# description: This is a daemon which broadcasts notifications of system events \
|
||||
# and other messages. See http://www.freedesktop.org/software/dbus/
|
||||
#
|
||||
@@ -11,7 +11,7 @@
|
||||
#
|
||||
|
||||
# Sanity checks.
|
||||
-[ -x @EXPANDED_BINDIR@/dbus-daemon ] || exit 0
|
||||
+[ -x /bin/dbus-daemon ] || exit 0
|
||||
|
||||
# Source function library.
|
||||
. @EXPANDED_SYSCONFDIR@/rc.d/init.d/functions
|
@ -1,32 +0,0 @@
|
||||
--- dbus-1.0.1/dbus/dbus-sysdeps-pthread.c 28 Oct 2006 01:41:37 -0000 1.5
|
||||
+++ dbus-1.0.1/dbus/dbus-sysdeps-pthread.c 19 Nov 2006 12:40:47 -0000
|
||||
@@ -153,6 +153,7 @@ _dbus_pthread_mutex_lock (DBusMutex *mut
|
||||
{
|
||||
/* Wait for the lock */
|
||||
PTHREAD_CHECK ("pthread_mutex_lock", pthread_mutex_lock (&pmutex->lock));
|
||||
+ pmutex->holder = self;
|
||||
_dbus_assert (pmutex->count == 0);
|
||||
}
|
||||
|
||||
@@ -222,10 +223,11 @@ _dbus_pthread_condvar_wait (DBusCondVar
|
||||
_dbus_assert (pthread_equal (pmutex->holder, pthread_self ()));
|
||||
|
||||
old_count = pmutex->count;
|
||||
- pmutex->count = 0;
|
||||
+ pmutex->count = 0; /* allow other threads to lock */
|
||||
PTHREAD_CHECK ("pthread_cond_wait", pthread_cond_wait (&pcond->cond, &pmutex->lock));
|
||||
_dbus_assert (pmutex->count == 0);
|
||||
pmutex->count = old_count;
|
||||
+ pmutex->holder = pthread_self(); /* other threads may have locked the mutex in the meantime */
|
||||
}
|
||||
|
||||
static dbus_bool_t
|
||||
@@ -264,6 +266,7 @@ _dbus_pthread_condvar_wait_timeout (DBus
|
||||
|
||||
_dbus_assert (pmutex->count == 0);
|
||||
pmutex->count = old_count;
|
||||
+ pmutex->holder = pthread_self(); /* other threads may have locked the mutex in the meantime */
|
||||
|
||||
/* return true if we did not time out */
|
||||
return result != ETIMEDOUT;
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -up dbus-1.0.2/bus/messagebus.in.lsb dbus-1.0.2/bus/messagebus.in
|
||||
--- dbus-1.0.2/bus/messagebus.in.lsb 2007-07-06 22:13:15.000000000 -0400
|
||||
+++ dbus-1.0.2/bus/messagebus.in 2007-07-06 22:15:54.000000000 -0400
|
||||
@@ -9,6 +9,17 @@
|
||||
# processname: dbus-daemon
|
||||
# pidfile: @DBUS_SYSTEM_PID_FILE@
|
||||
#
|
||||
+### BEGIN INIT INFO
|
||||
+# Provides: messagebus
|
||||
+# Required-Start: $syslog $local_fs
|
||||
+# Required-Stop: $syslog $local_fs
|
||||
+# Default-Start: 2 3 4 5
|
||||
+# Default-Stop: 0 1 6
|
||||
+# Short-Description: The D-Bus systemwide message bus
|
||||
+# Description: This is a daemon which broadcasts notifications of system
|
||||
+# events and other messages. See http://www.freedesktop.org/software/dbus
|
||||
+### END INIT INFO
|
||||
+
|
||||
|
||||
# Sanity checks.
|
||||
[ -x /bin/dbus-daemon ] || exit 0
|
@ -1,55 +0,0 @@
|
||||
diff -up dbus-1.1.2/dbus/dbus-sysdeps-util-unix.c.audit-user dbus-1.1.2/dbus/dbus-sysdeps-util-unix.c
|
||||
--- dbus-1.1.2/dbus/dbus-sysdeps-util-unix.c.audit-user 2007-07-24 11:39:09.000000000 -0400
|
||||
+++ dbus-1.1.2/dbus/dbus-sysdeps-util-unix.c 2007-09-14 09:00:24.000000000 -0400
|
||||
@@ -300,7 +300,7 @@ _dbus_change_to_daemon_user (const char
|
||||
* run as ... doesn't really help. But keeps people happy.
|
||||
*/
|
||||
|
||||
- if (!we_were_root)
|
||||
+ if (we_were_root)
|
||||
{
|
||||
cap_value_t new_cap_list[] = { CAP_AUDIT_WRITE };
|
||||
cap_value_t tmp_cap_list[] = { CAP_AUDIT_WRITE, CAP_SETUID, CAP_SETGID };
|
||||
@@ -376,7 +376,7 @@ _dbus_change_to_daemon_user (const char
|
||||
}
|
||||
|
||||
#ifdef HAVE_LIBAUDIT
|
||||
- if (!we_were_root)
|
||||
+ if (we_were_root)
|
||||
{
|
||||
if (cap_set_proc (new_caps))
|
||||
{
|
||||
@@ -395,6 +395,7 @@ _dbus_change_to_daemon_user (const char
|
||||
_dbus_strerror (errno));
|
||||
return FALSE;
|
||||
}
|
||||
+ audit_init();
|
||||
}
|
||||
#endif
|
||||
|
||||
diff -up dbus-1.1.2/bus/selinux.c.audit-user dbus-1.1.2/bus/selinux.c
|
||||
--- dbus-1.1.2/bus/selinux.c.audit-user 2007-07-24 11:39:08.000000000 -0400
|
||||
+++ dbus-1.1.2/bus/selinux.c 2007-09-14 08:31:14.000000000 -0400
|
||||
@@ -113,7 +113,7 @@ static const struct avc_lock_callback lo
|
||||
static int audit_fd = -1;
|
||||
#endif
|
||||
|
||||
-static void
|
||||
+void
|
||||
audit_init(void)
|
||||
{
|
||||
#ifdef HAVE_LIBAUDIT
|
||||
@@ -350,12 +350,8 @@ bus_selinux_full_init (void)
|
||||
|
||||
freecon (bus_context);
|
||||
|
||||
- audit_init ();
|
||||
-
|
||||
- return TRUE;
|
||||
-#else
|
||||
- return TRUE;
|
||||
#endif /* HAVE_SELINUX */
|
||||
+ return TRUE;
|
||||
}
|
||||
|
||||
/**
|
@ -1,12 +0,0 @@
|
||||
diff -up dbus-1.1.2/bus/bus.c.foo dbus-1.1.2/bus/bus.c
|
||||
--- dbus-1.1.2/bus/bus.c.foo 2007-09-14 15:26:08.000000000 -0400
|
||||
+++ dbus-1.1.2/bus/bus.c 2007-09-14 15:26:08.000000000 -0400
|
||||
@@ -1206,7 +1206,7 @@ bus_context_check_security_policy (BusCo
|
||||
dest ? dest : DBUS_SERVICE_DBUS, error))
|
||||
{
|
||||
|
||||
- if (dbus_error_is_set (error) &&
|
||||
+ if (error != NULL && dbus_error_is_set (error) &&
|
||||
dbus_error_has_name (error, DBUS_ERROR_NO_MEMORY))
|
||||
{
|
||||
return FALSE;
|
@ -1,87 +0,0 @@
|
||||
From: John (J5) Palmieri <johnp@redhat.com>
|
||||
Date: Wed, 3 Oct 2007 19:21:57 +0000 (-0400)
|
||||
Subject: Correctly implement -fPIC and -fPIE
|
||||
X-Git-Url: http://gitweb.freedesktop.org/?p=dbus/dbus.git;a=commitdiff;h=8a92100bbed2ba5cb16a1ede36214fa7d2f43e43
|
||||
|
||||
Correctly implement -fPIC and -fPIE
|
||||
|
||||
* For security reasons we want possition independent code for libraries
|
||||
and possition independent executable for executables
|
||||
* before we were just enabling -fPIC
|
||||
* now we correctly enable -fPIC and -PIE for libdbus and the bus respectively
|
||||
* propper LD_FLAGS are set for each also
|
||||
---
|
||||
|
||||
--- a/bus/Makefile.am
|
||||
+++ b/bus/Makefile.am
|
||||
@@ -1,7 +1,7 @@
|
||||
|
||||
configdir=$(sysconfdir)/dbus-1
|
||||
|
||||
-INCLUDES=-I$(top_srcdir) $(DBUS_BUS_CFLAGS) \
|
||||
+INCLUDES=-I$(top_srcdir) $(DBUS_BUS_CFLAGS) @PIE_CFLAGS@ \
|
||||
-DDBUS_SYSTEM_CONFIG_FILE=\""$(configdir)/system.conf"\" \
|
||||
-DDAEMON_NAME=\"dbus-daemon\" -DDBUS_COMPILATION
|
||||
|
||||
@@ -77,7 +77,7 @@ dbus_daemon_LDADD= \
|
||||
$(DBUS_BUS_LIBS) \
|
||||
$(top_builddir)/dbus/libdbus-convenience.la
|
||||
|
||||
-dbus_daemon_LDFLAGS=@R_DYNAMIC_LDFLAG@ @SECTION_LDFLAGS@
|
||||
+dbus_daemon_LDFLAGS=@R_DYNAMIC_LDFLAG@ @SECTION_LDFLAGS@ @PIE_LDFLAGS@
|
||||
|
||||
LAUNCH_HELPER_SOURCES= \
|
||||
$(XML_SOURCES) \
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -211,7 +211,17 @@ if test "x$GCC" = "xyes"; then
|
||||
case " $CFLAGS " in
|
||||
*[\ \ ]-fPIC[\ \ ]*) ;;
|
||||
*) if cc_supports_flag -fPIC; then
|
||||
- CFLAGS="$CFLAGS -fPIC"
|
||||
+ PIC_CFLAGS="-fPIC"
|
||||
+ PIC_LDFLAGS="-Wl,-z,relro"
|
||||
+ fi
|
||||
+ ;;
|
||||
+ esac
|
||||
+
|
||||
+ case " $CFLAGS " in
|
||||
+ *[\ \ ]-fPIE[\ \ ]*) ;;
|
||||
+ *) if cc_supports_flag -fPIE; then
|
||||
+ PIE_CFLAGS="-fPIE"
|
||||
+ PIE_LDFLAGS="-pie -Wl,-z,relro"
|
||||
fi
|
||||
;;
|
||||
esac
|
||||
@@ -257,6 +267,11 @@ else
|
||||
fi
|
||||
fi
|
||||
|
||||
+AC_SUBST(PIC_CFLAGS)
|
||||
+AC_SUBST(PIC_LDFLAGS)
|
||||
+AC_SUBST(PIE_CFLAGS)
|
||||
+AC_SUBST(PIE_LDFLAGS)
|
||||
+
|
||||
# Check for -Wl,--gc-sections
|
||||
AC_MSG_CHECKING([for ld that supports "-Wl,--gc-sections"])
|
||||
AC_TRY_LINK([
|
||||
--- a/dbus/Makefile.am
|
||||
+++ b/dbus/Makefile.am
|
||||
@@ -1,7 +1,7 @@
|
||||
|
||||
configdir=$(sysconfdir)/dbus-1
|
||||
|
||||
-INCLUDES=-I$(top_builddir) -I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) -DDBUS_COMPILATION \
|
||||
+INCLUDES=-I$(top_builddir) -I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) @PIC_CFLAGS@ -DDBUS_COMPILATION \
|
||||
-DDBUS_MACHINE_UUID_FILE=\""$(localstatedir)/lib/dbus/machine-id"\" \
|
||||
-DDBUS_SYSTEM_CONFIG_FILE=\""$(configdir)/system.conf"\" \
|
||||
-DDBUS_SESSION_CONFIG_FILE=\""$(configdir)/session.conf"\"
|
||||
@@ -173,7 +173,7 @@ noinst_LTLIBRARIES=libdbus-convenience.l
|
||||
libdbus_1_la_LIBADD= $(DBUS_CLIENT_LIBS)
|
||||
## don't export symbols that start with "_" (we use this
|
||||
## convention for internal symbols)
|
||||
-libdbus_1_la_LDFLAGS= -export-symbols-regex "^[^_].*" -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -no-undefined @R_DYNAMIC_LDFLAG@
|
||||
+libdbus_1_la_LDFLAGS= -export-symbols-regex "^[^_].*" -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -no-undefined @R_DYNAMIC_LDFLAG@ @PIC_LDFLAGS@
|
||||
|
||||
libdbus_convenience_la_LDFLAGS=@R_DYNAMIC_LDFLAG@
|
||||
|
@ -1,23 +0,0 @@
|
||||
diff -up dbus-1.1.4/dbus/dbus-sysdeps-unix.c.ucred dbus-1.1.4/dbus/dbus-sysdeps-unix.c
|
||||
--- dbus-1.1.4/dbus/dbus-sysdeps-unix.c.ucred 2008-01-15 14:33:48.000000000 -0500
|
||||
+++ dbus-1.1.4/dbus/dbus-sysdeps-unix.c 2008-02-04 12:02:57.000000000 -0500
|
||||
@@ -22,6 +22,8 @@
|
||||
*
|
||||
*/
|
||||
|
||||
+#define _GNU_SOURCE
|
||||
+
|
||||
#include "dbus-internals.h"
|
||||
#include "dbus-sysdeps.h"
|
||||
#include "dbus-sysdeps-unix.h"
|
||||
diff -up dbus-1.1.4/bus/selinux.c.ucred dbus-1.1.4/bus/selinux.c
|
||||
--- dbus-1.1.4/bus/selinux.c.ucred 2008-02-04 12:08:31.000000000 -0500
|
||||
+++ dbus-1.1.4/bus/selinux.c 2008-02-04 12:07:37.000000000 -0500
|
||||
@@ -34,6 +34,7 @@
|
||||
#ifdef HAVE_ERRNO_H
|
||||
#include <errno.h>
|
||||
#endif
|
||||
+#include <limits.h>
|
||||
#include <pthread.h>
|
||||
#include <syslog.h>
|
||||
#include <selinux/selinux.h>
|
Loading…
Reference in New Issue
Block a user