dbus-python/SOURCES/0001-Move-python-modules-to...

54 lines
1.4 KiB
Diff

From 380ae714f641a73a30f86ae8f5a2e05ac063b37f Mon Sep 17 00:00:00 2001
From: leigh123linux <leigh123linux@googlemail.com>
Date: Tue, 23 Feb 2016 07:32:08 +0000
Subject: [PATCH] Move python modules to architecture-specific directory
This is because dbus-python gets dragged in as a dependency of other
things people want to be multilib-compatible. As is the Python
modules conflict.
---
Makefile.am | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index 3a821fa..dcf4320 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -146,7 +146,8 @@ dbus_py_test_la_SOURCES = \
# === dbus package ===
-nobase_python_PYTHON = \
+dbuspydir = $(pyexecdir)
+nobase_dbuspy_DATA = \
dbus/bus.py \
dbus/connection.py \
dbus/_compat.py \
@@ -167,12 +168,12 @@ nobase_python_PYTHON = \
dbus/types.py
if !HAVE_PYTHON_3
-nobase_python_PYTHON += \
+nobase_dbuspy_DATA += \
dbus/gobject_service.py \
$(NULL)
endif
-check_py_sources = $(nobase_python_PYTHON)
+check_py_sources = $(nobase_dbuspy_DATA)
include $(top_srcdir)/tools/check-coding-style.mk
# === Devel stuff ===
@@ -415,7 +416,7 @@ clean-local:
APIDOC_PYTHONPATH = $(abs_top_srcdir):$(abs_top_builddir)/.libs
-api api/index.html: $(nobase_python_PYTHON) \
+api api/index.html: $(nobase_dbuspy_DATA) \
_dbus_bindings.la \
_dbus_glib_bindings.la
rm -rf api
--
2.5.0