Update to 1.2.8
This commit is contained in:
parent
777b14d119
commit
dfdd604372
2
.gitignore
vendored
2
.gitignore
vendored
@ -6,3 +6,5 @@
|
|||||||
/dbus-python-1.2.2.tar.gz.asc
|
/dbus-python-1.2.2.tar.gz.asc
|
||||||
/dbus-python-1.2.4.tar.gz
|
/dbus-python-1.2.4.tar.gz
|
||||||
/dbus-python-1.2.4.tar.gz.asc
|
/dbus-python-1.2.4.tar.gz.asc
|
||||||
|
/dbus-python-1.2.8.tar.gz
|
||||||
|
/dbus-python-1.2.8.tar.gz.asc
|
||||||
|
@ -11,10 +11,10 @@ modules conflict.
|
|||||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
diff --git a/Makefile.am b/Makefile.am
|
||||||
index 3a821fa..dcf4320 100644
|
index fd480d4..0859994 100644
|
||||||
--- a/Makefile.am
|
--- a/Makefile.am
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -146,7 +146,8 @@ dbus_py_test_la_SOURCES = \
|
@@ -155,7 +155,8 @@ test_dbus_py_test_la_SOURCES = \
|
||||||
|
|
||||||
# === dbus package ===
|
# === dbus package ===
|
||||||
|
|
||||||
@ -24,7 +24,7 @@ index 3a821fa..dcf4320 100644
|
|||||||
dbus/bus.py \
|
dbus/bus.py \
|
||||||
dbus/connection.py \
|
dbus/connection.py \
|
||||||
dbus/_compat.py \
|
dbus/_compat.py \
|
||||||
@@ -167,12 +168,12 @@ nobase_python_PYTHON = \
|
@@ -175,12 +176,12 @@ nobase_python_PYTHON = \
|
||||||
dbus/types.py
|
dbus/types.py
|
||||||
|
|
||||||
if !HAVE_PYTHON_3
|
if !HAVE_PYTHON_3
|
||||||
@ -39,15 +39,14 @@ index 3a821fa..dcf4320 100644
|
|||||||
include $(top_srcdir)/tools/check-coding-style.mk
|
include $(top_srcdir)/tools/check-coding-style.mk
|
||||||
|
|
||||||
# === Devel stuff ===
|
# === Devel stuff ===
|
||||||
@@ -415,7 +416,7 @@ clean-local:
|
@@ -416,7 +417,7 @@ uninstall-local: uninstall-local-sphinx
|
||||||
|
if ENABLE_DOCUMENTATION
|
||||||
|
all: doc/_build/.stamp
|
||||||
|
|
||||||
APIDOC_PYTHONPATH = $(abs_top_srcdir):$(abs_top_builddir)/.libs
|
-doc/_build/.stamp: $(nobase_python_PYTHON) \
|
||||||
|
+doc/_build/.stamp: $(nobase_dbuspy_DATA) \
|
||||||
-api api/index.html: $(nobase_python_PYTHON) \
|
|
||||||
+api api/index.html: $(nobase_dbuspy_DATA) \
|
|
||||||
_dbus_bindings.la \
|
_dbus_bindings.la \
|
||||||
_dbus_glib_bindings.la
|
_dbus_glib_bindings.la \
|
||||||
rm -rf api
|
$(sphinx_sources) \
|
||||||
--
|
--
|
||||||
2.5.0
|
2.17.0
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: D-Bus Python Bindings
|
Summary: D-Bus Python Bindings
|
||||||
Name: dbus-python
|
Name: dbus-python
|
||||||
Version: 1.2.4
|
Version: 1.2.8
|
||||||
Release: 13%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://www.freedesktop.org/wiki/Software/DBusBindings/
|
URL: http://www.freedesktop.org/wiki/Software/DBusBindings/
|
||||||
@ -80,8 +80,8 @@ rm -fv $RPM_BUILD_ROOT%{python3_sitearch}/*.la
|
|||||||
rm -rfv $RPM_BUILD_ROOT%{_datadir}/doc/dbus-python/
|
rm -rfv $RPM_BUILD_ROOT%{_datadir}/doc/dbus-python/
|
||||||
|
|
||||||
%check
|
%check
|
||||||
make check -k -C python2-build
|
make check -k -C python2-build || (cat python2-build/test-suite.log && false)
|
||||||
make check -k -C python3-build
|
make check -k -C python3-build || (cat python3-build/test-suite.log && false)
|
||||||
|
|
||||||
%files -n python2-dbus
|
%files -n python2-dbus
|
||||||
%doc NEWS
|
%doc NEWS
|
||||||
@ -101,6 +101,10 @@ make check -k -C python3-build
|
|||||||
%{_libdir}/pkgconfig/dbus-python.pc
|
%{_libdir}/pkgconfig/dbus-python.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 23 2018 Miro Hrončok <mhroncok@redhat.com> - 1.2.8-1
|
||||||
|
- Update to 1.2.8 (#1539950) (#1578726)
|
||||||
|
- Cat the logs if tests failed
|
||||||
|
|
||||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.4-13
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.4-13
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
7372a588c83a7232b4e08159bfd48fe5 dbus-python-1.2.4.tar.gz
|
SHA512 (dbus-python-1.2.8.tar.gz) = 6e486fd560944fc1461a27e6798e2c348c7fdf351602c082a0614c0a6822ff147875212bdcb1f818c0ab12470cffc613c0ffbd292cd9d445d3429bee65765905
|
||||||
fabb8146a01d036ef798089f7c3465f5 dbus-python-1.2.4.tar.gz.asc
|
SHA512 (dbus-python-1.2.8.tar.gz.asc) = 41bc2cdd756f9354833f2ddbeed6b6ae89b5d478759bfd3233224c2dfde341db2420dbe5115d2507f54147031d47df49b9b53fb41a002418263ff720e6714506
|
||||||
|
Loading…
Reference in New Issue
Block a user