Update to 1.3.2 (#2124688)
This commit is contained in:
parent
eb581b0912
commit
7c050c20a1
2
.gitignore
vendored
2
.gitignore
vendored
@ -12,3 +12,5 @@
|
||||
/dbus-python-1.2.16.tar.gz.asc
|
||||
/dbus-python-1.2.18.tar.gz
|
||||
/dbus-python-1.2.18.tar.gz.asc
|
||||
/dbus-python-1.3.2.tar.gz
|
||||
/dbus-python-1.3.2.tar.gz.asc
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 380ae714f641a73a30f86ae8f5a2e05ac063b37f Mon Sep 17 00:00:00 2001
|
||||
From 86741aa93aaaf388899d1fa0c25d0d67729b7a5c Mon Sep 17 00:00:00 2001
|
||||
From: leigh123linux <leigh123linux@googlemail.com>
|
||||
Date: Tue, 23 Feb 2016 07:32:08 +0000
|
||||
Subject: [PATCH] Move python modules to architecture-specific directory
|
||||
@ -7,14 +7,14 @@ This is because dbus-python gets dragged in as a dependency of other
|
||||
things people want to be multilib-compatible. As is the Python
|
||||
modules conflict.
|
||||
---
|
||||
Makefile.am | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
Makefile.am | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index fd480d4..0859994 100644
|
||||
index 8738d57..b6d30c0 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -155,7 +155,8 @@ test_dbus_py_test_la_SOURCES = \
|
||||
@@ -176,7 +176,8 @@ test_dbus_py_test_la_SOURCES = \
|
||||
|
||||
# === dbus package ===
|
||||
|
||||
@ -24,29 +24,24 @@ index fd480d4..0859994 100644
|
||||
dbus/bus.py \
|
||||
dbus/connection.py \
|
||||
dbus/_compat.py \
|
||||
@@ -175,12 +176,12 @@ nobase_python_PYTHON = \
|
||||
@@ -195,7 +196,7 @@ nobase_python_PYTHON = \
|
||||
dbus/service.py \
|
||||
dbus/types.py
|
||||
|
||||
if !HAVE_PYTHON_3
|
||||
-nobase_python_PYTHON += \
|
||||
+nobase_dbuspy_DATA += \
|
||||
dbus/gobject_service.py \
|
||||
$(NULL)
|
||||
endif
|
||||
|
||||
-check_py_sources = $(nobase_python_PYTHON)
|
||||
+check_py_sources = $(nobase_dbuspy_DATA)
|
||||
include $(top_srcdir)/tools/check-coding-style.mk
|
||||
|
||||
# === Devel stuff ===
|
||||
@@ -416,7 +417,7 @@ uninstall-local: uninstall-local-sphinx
|
||||
@@ -434,7 +435,7 @@ uninstall-local-pycache:
|
||||
if ENABLE_DOCUMENTATION
|
||||
all: doc/_build/.stamp
|
||||
all: doc/html/.stamp
|
||||
|
||||
-doc/_build/.stamp: $(nobase_python_PYTHON) \
|
||||
+doc/_build/.stamp: $(nobase_dbuspy_DATA) \
|
||||
-doc/html/.stamp: $(nobase_python_PYTHON) \
|
||||
+doc/html/.stamp: $(nobase_dbuspy_DATA) \
|
||||
_dbus_bindings.la \
|
||||
_dbus_glib_bindings.la \
|
||||
$(sphinx_sources) \
|
||||
--
|
||||
2.17.0
|
||||
2.37.3
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: dbus-python
|
||||
Version: 1.2.18
|
||||
Release: 5%{?dist}
|
||||
Version: 1.3.2
|
||||
Release: 1%{?dist}
|
||||
Summary: D-Bus Python Bindings
|
||||
|
||||
License: MIT
|
||||
@ -34,6 +34,8 @@ Summary: D-Bus bindings for python3
|
||||
BuildRequires: python%{python3_pkgversion}-devel
|
||||
# for py3_build
|
||||
BuildRequires: python3dist(setuptools)
|
||||
BuildRequires: python3dist(setuptools-scm)
|
||||
BuildRequires: python3dist(wheel)
|
||||
BuildRequires: make
|
||||
|
||||
%description -n python%{python3_pkgversion}-dbus
|
||||
@ -54,12 +56,14 @@ bindings.
|
||||
autoreconf -vif
|
||||
|
||||
%build
|
||||
export DBUS_PYTHON_USE_AUTOTOOLS=1
|
||||
%set_build_flags
|
||||
%py3_build
|
||||
%configure PYTHON="%{__python3}"
|
||||
%make_build
|
||||
|
||||
%install
|
||||
export DBUS_PYTHON_USE_AUTOTOOLS=1
|
||||
%py3_install
|
||||
%make_install
|
||||
|
||||
@ -83,6 +87,9 @@ make check -k || (cat test-suite.log && false)
|
||||
%{_libdir}/pkgconfig/dbus-python.pc
|
||||
|
||||
%changelog
|
||||
* Thu Sep 29 2022 Vojtech Trefny <vtrefny@redhat.com> - 1.3.2-1
|
||||
- Update to 1.3.2 (#2124688)
|
||||
|
||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.18-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (dbus-python-1.2.18.tar.gz) = 72f422c59637392bd78b741b66dff2afadcc706452c3e82fdc14b1dc052a0c5cb8a85e2758d18c5cbdc08004419a0b3c16b67b99688d96307084403e72585900
|
||||
SHA512 (dbus-python-1.2.18.tar.gz.asc) = 5f8b0c8c1771f4e8ace9168c02f04d0e065cfa8dfdaf7e7d991232e42e0f77bef9d72c565a053ed0cee1ac75b5ab7b929fcdb88d34b21f1489107ea4847ada0a
|
||||
SHA512 (dbus-python-1.3.2.tar.gz) = 9b2885c9c2914142c72487f766b1cdd28a255d9f5a87eaf8f4eb420c6e096a77f210ac5a4fac9843c6531974872880cc28b7e45940e198856e984dcc0715519a
|
||||
SHA512 (dbus-python-1.3.2.tar.gz.asc) = d8bdd6eefcd9aef029d6de5dd604f2ef8dc19bfc4a0504ad4fc33a9e8a4c3791f6ba24f3f65e2e2b5c3f1de96a5e61d500f946d7dc55771e4e85975bb94c7ce1
|
||||
|
Loading…
Reference in New Issue
Block a user