0.82.4
This commit is contained in:
parent
2755655f82
commit
463291f4bc
@ -1 +1 @@
|
|||||||
dbus-python-0.82.0.tar.gz
|
dbus-python-0.82.4.tar.gz
|
||||||
|
@ -1,17 +0,0 @@
|
|||||||
--- dbus-python-0.70/setup.py.fix-binary-modules-dir 2006-07-17 20:30:07.000000000 -0400
|
|
||||||
+++ dbus-python-0.70/setup.py 2006-07-17 20:30:22.000000000 -0400
|
|
||||||
@@ -92,12 +92,12 @@
|
|
||||||
"dbus/_util",
|
|
||||||
],
|
|
||||||
ext_modules=[
|
|
||||||
- Extension("dbus_bindings", ["dbus/dbus_bindings.pyx"],
|
|
||||||
+ Extension("dbus/dbus_bindings", ["dbus/dbus_bindings.pyx"],
|
|
||||||
include_dirs=dbus_includes,
|
|
||||||
libraries=["dbus-1"],
|
|
||||||
|
|
||||||
),
|
|
||||||
- Extension("dbus_glib_bindings", ["dbus/dbus_glib_bindings.pyx"],
|
|
||||||
+ Extension("dbus/dbus_glib_bindings", ["dbus/dbus_glib_bindings.pyx"],
|
|
||||||
include_dirs=dbus_glib_includes,
|
|
||||||
libraries=["dbus-glib-1", "dbus-1", "glib-2.0"],
|
|
||||||
define_macros=[
|
|
@ -1,54 +0,0 @@
|
|||||||
From: Simon McVittie <simon.mcvittie@collabora.co.uk>
|
|
||||||
Date: Wed, 21 Feb 2007 12:31:15 +0000 (+0000)
|
|
||||||
Subject: Don't examine args for functions declared METH_NOARGS.
|
|
||||||
X-Git-Url: http://gitweb.freedesktop.org/?p=dbus/dbus-python.git;a=commitdiff;h=8dce2df1ceacffb2aa6e2cc8b1d4b58ee95ac5b1
|
|
||||||
|
|
||||||
Don't examine args for functions declared METH_NOARGS.
|
|
||||||
It's not guaranteed to be non-NULL, and Python checks there are no arguments
|
|
||||||
so we don't have to.
|
|
||||||
---
|
|
||||||
|
|
||||||
--- a/_dbus_bindings/conn-methods.c
|
|
||||||
+++ b/_dbus_bindings/conn-methods.c
|
|
||||||
@@ -226,10 +226,9 @@ PyDoc_STRVAR(Connection_close__doc__,
|
|
||||||
"close()\n\n"
|
|
||||||
"Close the connection.");
|
|
||||||
static PyObject *
|
|
||||||
-Connection_close (Connection *self, PyObject *args)
|
|
||||||
+Connection_close (Connection *self, PyObject *args UNUSED)
|
|
||||||
{
|
|
||||||
TRACE(self);
|
|
||||||
- if (!PyArg_ParseTuple(args, ":close")) return NULL;
|
|
||||||
/* Because the user explicitly asked to close the connection, we'll even
|
|
||||||
let them close shared connections. */
|
|
||||||
if (self->conn) {
|
|
||||||
@@ -244,13 +243,12 @@ PyDoc_STRVAR(Connection_get_is_connected
|
|
||||||
"get_is_connected() -> bool\n\n"
|
|
||||||
"Return true if this Connection is connected.\n");
|
|
||||||
static PyObject *
|
|
||||||
-Connection_get_is_connected (Connection *self, PyObject *args)
|
|
||||||
+Connection_get_is_connected (Connection *self, PyObject *args UNUSED)
|
|
||||||
{
|
|
||||||
dbus_bool_t ret;
|
|
||||||
|
|
||||||
TRACE(self);
|
|
||||||
DBUS_PY_RAISE_VIA_NULL_IF_FAIL(self->conn);
|
|
||||||
- if (!PyArg_ParseTuple(args, ":get_is_connected")) return NULL;
|
|
||||||
Py_BEGIN_ALLOW_THREADS
|
|
||||||
ret = dbus_connection_get_is_connected(self->conn);
|
|
||||||
Py_END_ALLOW_THREADS
|
|
||||||
@@ -261,13 +259,12 @@ PyDoc_STRVAR(Connection_get_is_authentic
|
|
||||||
"get_is_authenticated() -> bool\n\n"
|
|
||||||
"Return true if this Connection was ever authenticated.\n");
|
|
||||||
static PyObject *
|
|
||||||
-Connection_get_is_authenticated (Connection *self, PyObject *args)
|
|
||||||
+Connection_get_is_authenticated (Connection *self, PyObject *args UNUSED)
|
|
||||||
{
|
|
||||||
dbus_bool_t ret;
|
|
||||||
|
|
||||||
TRACE(self);
|
|
||||||
DBUS_PY_RAISE_VIA_NULL_IF_FAIL(self->conn);
|
|
||||||
- if (!PyArg_ParseTuple(args, ":get_is_authenticated")) return NULL;
|
|
||||||
Py_BEGIN_ALLOW_THREADS
|
|
||||||
ret = dbus_connection_get_is_authenticated(self->conn);
|
|
||||||
Py_END_ALLOW_THREADS
|
|
@ -6,8 +6,8 @@
|
|||||||
|
|
||||||
Summary: D-Bus Python Bindings
|
Summary: D-Bus Python Bindings
|
||||||
Name: dbus-python
|
Name: dbus-python
|
||||||
Version: 0.82.0
|
Version: 0.82.4
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://www.freedesktop.org/software/dbus/
|
URL: http://www.freedesktop.org/software/dbus/
|
||||||
Source0: http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
|
Source0: http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
@ -75,6 +75,9 @@ rm -rf %{buildroot}
|
|||||||
%{_libdir}/pkgconfig/dbus-python.pc
|
%{_libdir}/pkgconfig/dbus-python.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jan 20 2008 Matthias Clasen <mclasen@redhat.com> - 0.82.4-1
|
||||||
|
- Update to 0.82.4
|
||||||
|
|
||||||
* Mon Oct 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.82.0-3
|
* Mon Oct 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.82.0-3
|
||||||
- Rebuild against new dbus-glib
|
- Rebuild against new dbus-glib
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user