dbus-python-1.1.1 (#800487)
This commit is contained in:
parent
b6ee5459cc
commit
271d3aebf3
3
.gitignore
vendored
3
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
dbus-python-0.83.0.tar.gz
|
/dbus-python-0.83.0.tar.gz
|
||||||
|
/dbus-python-1.1.1.tar.gz
|
||||||
|
@ -1,19 +0,0 @@
|
|||||||
--- dbus/connection.py.orig 2008-09-13 14:54:49.000000000 +0200
|
|
||||||
+++ dbus/connection.py 2008-09-13 14:55:01.000000000 +0200
|
|
||||||
@@ -484,7 +484,15 @@
|
|
||||||
deletions.append(match)
|
|
||||||
else:
|
|
||||||
new.append(match)
|
|
||||||
- by_member[signal_name] = new
|
|
||||||
+
|
|
||||||
+ if new:
|
|
||||||
+ by_member[signal_name] = new
|
|
||||||
+ else:
|
|
||||||
+ del by_member[signal_name]
|
|
||||||
+ if not by_member:
|
|
||||||
+ del by_interface[dbus_interface]
|
|
||||||
+ if not by_interface:
|
|
||||||
+ del self._signal_recipients_by_object_path[path]
|
|
||||||
finally:
|
|
||||||
self._signals_lock.release()
|
|
||||||
|
|
@ -1,84 +1,73 @@
|
|||||||
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||||
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
%{!?python_inc:%global python_inc %(%{__python} -c "from distutils.sysconfig import get_python_inc; print get_python_inc(1)")}
|
||||||
|
|
||||||
%define dbus_glib_version 0.70
|
%define dbus_glib_version 0.70
|
||||||
%define dbus_version 0.90
|
%define dbus_version 0.90
|
||||||
|
|
||||||
Summary: D-Bus Python Bindings
|
Summary: D-Bus Python Bindings
|
||||||
Name: dbus-python
|
Name: dbus-python
|
||||||
Version: 0.83.0
|
Version: 1.1.1
|
||||||
Release: 10%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
|
License: MIT
|
||||||
URL: http://www.freedesktop.org/software/dbus/
|
URL: http://www.freedesktop.org/software/dbus/
|
||||||
Source0: http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
|
Source0: http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
License: MIT
|
|
||||||
Group: System Environment/Libraries
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
||||||
BuildRequires: dbus-devel >= %{dbus_version}
|
BuildRequires: dbus-devel >= %{dbus_version}
|
||||||
BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
|
BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
|
||||||
BuildRequires: python-devel
|
BuildRequires: python-devel
|
||||||
|
# for %%check
|
||||||
Patch0: dbus-python-0.83.0-memleak.patch
|
BuildRequires: dbus-x11 pygobject3
|
||||||
|
|
||||||
%description
|
%description
|
||||||
|
|
||||||
D-Bus python bindings for use with python programs.
|
D-Bus python bindings for use with python programs.
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Libraries and headers for dbus-python
|
Summary: Libraries and headers for dbus-python
|
||||||
Group: Development/Libraries
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
Requires: %name = %{version}-%{release}
|
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
|
|
||||||
Headers and static libraries for hooking up custom mainloops to the dbus python
|
Headers and static libraries for hooking up custom mainloops to the dbus python
|
||||||
bindings.
|
bindings.
|
||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0 -p0 -b .memleak
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
|
|
||||||
make
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
#CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf %{buildroot}
|
|
||||||
|
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
|
||||||
#PKG_CONFIG_PATH=%{_libdir}/pkgconfig %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
|
# unpackaged files
|
||||||
|
rm -fv $RPM_BUILD_ROOT%{python_sitearch}/*.la
|
||||||
|
rm -rfv $RPM_BUILD_ROOT%{_datadir}/doc/dbus-python/
|
||||||
|
|
||||||
rm -f $RPM_BUILD_ROOT/%{python_sitearch}/*.la
|
|
||||||
|
|
||||||
%clean
|
%check
|
||||||
rm -rf %{buildroot}
|
make check
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%doc COPYING ChangeLog README NEWS
|
||||||
|
|
||||||
%doc COPYING ChangeLog README NEWS TODO
|
|
||||||
%doc doc/API_CHANGES.txt doc/HACKING.txt doc/tutorial.txt
|
|
||||||
%exclude %{_datadir}/doc/dbus-python
|
|
||||||
|
|
||||||
%dir %{python_sitelib}/dbus
|
|
||||||
%dir %{python_sitelib}/dbus/mainloop
|
|
||||||
%{python_sitearch}/*.so
|
%{python_sitearch}/*.so
|
||||||
%{python_sitelib}/*.py*
|
%{python_sitelib}/dbus/
|
||||||
%{python_sitelib}/dbus/*.py*
|
|
||||||
%{python_sitelib}/dbus/mainloop/*.py*
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%doc doc/API_CHANGES.txt doc/HACKING.txt doc/tutorial.txt
|
||||||
|
|
||||||
%{_includedir}/dbus-1.0/dbus/dbus-python.h
|
%{_includedir}/dbus-1.0/dbus/dbus-python.h
|
||||||
%{_libdir}/pkgconfig/dbus-python.pc
|
%{_libdir}/pkgconfig/dbus-python.pc
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 07 2012 Rex Dieter <rdieter@fedoraproject.org> 1.1.1-1
|
||||||
|
- dbus-python-1.1.1 (#800487)
|
||||||
|
|
||||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.83.0-10
|
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.83.0-10
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user