- Update to 0.3
- Cleanup spec: drop some unnecessary conditionals for old releases (< F-11)
This commit is contained in:
parent
cf83032be6
commit
d49b5cba27
@ -1 +1 @@
|
|||||||
dblatex-0.2.10.tar.bz2
|
dblatex-0.3.tar.bz2
|
||||||
|
@ -1,100 +0,0 @@
|
|||||||
Index: setup.py
|
|
||||||
===================================================================
|
|
||||||
RCS file: /usr/local/cvsroot/docbook/db2tex/dblatex/setup.py,v
|
|
||||||
retrieving revision 1.13
|
|
||||||
diff -u -r1.13 setup.py
|
|
||||||
--- setup.py 6 Nov 2007 22:28:57 -0000 1.13
|
|
||||||
+++ setup.py 4 Jun 2008 22:35:50 -0000
|
|
||||||
@@ -259,7 +259,7 @@
|
|
||||||
used_stys.sort()
|
|
||||||
|
|
||||||
# Dirty...
|
|
||||||
- for f in ("truncate", "elfonts", "CJKutf8", "pinyin"):
|
|
||||||
+ for f in ("truncate", "elfonts", "CJKutf8", "pinyin", "ifxetex"):
|
|
||||||
try:
|
|
||||||
used_stys.remove(f)
|
|
||||||
except:
|
|
||||||
Index: latex/style/dbk_fonts.sty
|
|
||||||
===================================================================
|
|
||||||
RCS file: /usr/local/cvsroot/docbook/db2tex/dblatex/latex/style/dbk_fonts.sty,v
|
|
||||||
retrieving revision 1.3
|
|
||||||
diff -u -r1.3 dbk_fonts.sty
|
|
||||||
--- latex/style/dbk_fonts.sty 18 Apr 2008 23:11:22 -0000 1.3
|
|
||||||
+++ latex/style/dbk_fonts.sty 4 Jun 2008 22:50:36 -0000
|
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-\usepackage{ifxetex}
|
|
||||||
+
|
|
||||||
\ifxetex
|
|
||||||
% to have the \text macro
|
|
||||||
\usepackage{amstext}
|
|
||||||
Index: latex/style/docbook.sty
|
|
||||||
===================================================================
|
|
||||||
RCS file: /usr/local/cvsroot/docbook/db2tex/dblatex/latex/style/docbook.sty,v
|
|
||||||
retrieving revision 1.23
|
|
||||||
diff -u -r1.23 docbook.sty
|
|
||||||
--- latex/style/docbook.sty 3 Sep 2007 18:47:53 -0000 1.23
|
|
||||||
+++ latex/style/docbook.sty 31 May 2008 12:16:35 -0000
|
|
||||||
@@ -8,12 +8,6 @@
|
|
||||||
\DeclareOption{hyperlink}{ \def\DBKhyperlink{yes} }
|
|
||||||
\DeclareOption{nohyperlink}{ \def\DBKhyperlink{no} }
|
|
||||||
|
|
||||||
-\ifx\undefined\chapter
|
|
||||||
- \def\DBKisarticle{1}
|
|
||||||
-\else
|
|
||||||
- \def\DBKisarticle{0}
|
|
||||||
-\fi
|
|
||||||
-
|
|
||||||
% Default values
|
|
||||||
\ExecuteOptions{nohyperlink}
|
|
||||||
|
|
||||||
@@ -140,7 +134,7 @@
|
|
||||||
%% Inclusion of float package after hyperref to have its definitions!
|
|
||||||
\usepackage{float}
|
|
||||||
|
|
||||||
-\if1\DBKisarticle
|
|
||||||
+\@ifundefined{chapter}{
|
|
||||||
|
|
||||||
\floatstyle{ruled}
|
|
||||||
\newfloat{example}{htb}{loe}[section]
|
|
||||||
@@ -153,8 +147,7 @@
|
|
||||||
% Redefinition of tableofcontent, to have it in separate pages
|
|
||||||
\let\stdtoc=\tableofcontents
|
|
||||||
\def\tableofcontents{ \newpage \stdtoc{} \newpage}
|
|
||||||
-
|
|
||||||
-\else
|
|
||||||
+}{
|
|
||||||
|
|
||||||
\floatstyle{ruled}
|
|
||||||
\newfloat{example}{htb}{loe}[chapter]
|
|
||||||
@@ -163,8 +156,8 @@
|
|
||||||
\floatstyle{plain}
|
|
||||||
\newfloat{dbequation}{htb}{loe}[chapter]
|
|
||||||
\floatname{dbequation}{{\scshape Equation }}
|
|
||||||
+}
|
|
||||||
|
|
||||||
-\fi
|
|
||||||
% Sidebar is a boxed minipage that can contain verbatim
|
|
||||||
\newenvironment{sidebar}[1][0.95\textwidth]{
|
|
||||||
\hspace{0mm}\newline%
|
|
||||||
Index: xsl/lang.xsl
|
|
||||||
===================================================================
|
|
||||||
RCS file: /usr/local/cvsroot/docbook/db2tex/dblatex/xsl/lang.xsl,v
|
|
||||||
retrieving revision 1.6
|
|
||||||
diff -u -r1.6 lang.xsl
|
|
||||||
--- xsl/lang.xsl 18 Apr 2008 23:11:31 -0000 1.6
|
|
||||||
+++ xsl/lang.xsl 4 Jun 2008 22:55:24 -0000
|
|
||||||
@@ -192,7 +192,13 @@
|
|
||||||
</xsl:variable>
|
|
||||||
|
|
||||||
<!-- XeTeX preamble to handle fonts -->
|
|
||||||
- <xsl:text>\usepackage{ifxetex} </xsl:text>
|
|
||||||
+ <xsl:text>\IfFileExists{ifxetex.sty}{%
|
|
||||||
+ \usepackage{ifxetex}%
|
|
||||||
+ }{%
|
|
||||||
+ \newif\ifxetex
|
|
||||||
+ \xetexfalse
|
|
||||||
+ }
|
|
||||||
+ </xsl:text>
|
|
||||||
<xsl:text>\ifxetex </xsl:text>
|
|
||||||
<xsl:text>\usepackage{fontspec} </xsl:text>
|
|
||||||
<xsl:text>\usepackage{xltxtra} </xsl:text>
|
|
24
dblatex.spec
24
dblatex.spec
@ -1,8 +1,8 @@
|
|||||||
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||||
|
|
||||||
Name: dblatex
|
Name: dblatex
|
||||||
Version: 0.2.10
|
Version: 0.3
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: DocBook to LaTeX/ConTeXt Publishing
|
Summary: DocBook to LaTeX/ConTeXt Publishing
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
@ -18,25 +18,11 @@ BuildRequires: python-devel
|
|||||||
BuildRequires: python-which
|
BuildRequires: python-which
|
||||||
BuildRequires: libxslt
|
BuildRequires: libxslt
|
||||||
BuildRequires: ImageMagick
|
BuildRequires: ImageMagick
|
||||||
%if 0%{?fedora} < 9
|
|
||||||
BuildRequires: tetex-latex
|
|
||||||
%else
|
|
||||||
BuildRequires: tex(latex)
|
BuildRequires: tex(latex)
|
||||||
%endif
|
|
||||||
%if 0%{?fedora} < 10
|
|
||||||
BuildRequires: texlive-xetex
|
|
||||||
Requires: texlive-xetex
|
|
||||||
%else
|
|
||||||
BuildRequires: tex(xetex)
|
BuildRequires: tex(xetex)
|
||||||
Requires: tex(xetex)
|
Requires: tex(xetex)
|
||||||
%endif
|
|
||||||
|
|
||||||
Requires: libxslt docbook-dtds passivetex ImageMagick transfig
|
Requires: libxslt docbook-dtds passivetex ImageMagick transfig
|
||||||
|
|
||||||
%if 0%{?fedora} < 8
|
|
||||||
Conflicts: tetex-tex4ht
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
dblatex is a program that transforms your SGML/XMLDocBook
|
dblatex is a program that transforms your SGML/XMLDocBook
|
||||||
documents to DVI, PostScript or PDF by translating them
|
documents to DVI, PostScript or PDF by translating them
|
||||||
@ -97,9 +83,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/dblatex.1*
|
%{_mandir}/man1/dblatex.1*
|
||||||
%doc COPYRIGHT docs/manual.pdf COPYING-docbook-xsl README-xsltml
|
%doc COPYRIGHT docs/manual.pdf COPYING-docbook-xsl README-xsltml
|
||||||
%{python_sitelib}/dbtexmf/
|
%{python_sitelib}/dbtexmf/
|
||||||
%if 0%{?fedora} >= 9
|
|
||||||
%{python_sitelib}/dblatex-*.egg-info
|
%{python_sitelib}/dblatex-*.egg-info
|
||||||
%endif
|
|
||||||
%{_bindir}/dblatex
|
%{_bindir}/dblatex
|
||||||
%{_datadir}/dblatex/
|
%{_datadir}/dblatex/
|
||||||
%{_datadir}/texmf/tex/latex/dblatex/
|
%{_datadir}/texmf/tex/latex/dblatex/
|
||||||
@ -110,6 +94,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%postun -p /usr/bin/texhash
|
%postun -p /usr/bin/texhash
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 12 2010 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.3-1
|
||||||
|
- Update to 0.3
|
||||||
|
- Cleanup spec: drop some unnecessary conditionals for old releases (< F-11)
|
||||||
|
|
||||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.10-3
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.10-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user