parent
1e786a46ab
commit
740bedade2
@ -1,12 +0,0 @@
|
||||
diff -up dblatex-0.2.7/setup.py.external_which dblatex-0.2.7/setup.py
|
||||
--- dblatex-0.2.7/setup.py.external_which 2007-04-26 21:08:56.000000000 +0200
|
||||
+++ dblatex-0.2.7/setup.py 2007-07-22 19:35:05.000000000 +0200
|
||||
@@ -147,7 +147,7 @@ os.environ["SGML_CATALOG_FILES"] = cat
|
||||
|
||||
def find_programs(utils):
|
||||
sys.path.append("lib")
|
||||
- from contrib.which import which
|
||||
+ import which
|
||||
util_paths = {}
|
||||
missed = []
|
||||
for util in utils:
|
44
dblatex-0.3.11-disable-debian.patch
Normal file
44
dblatex-0.3.11-disable-debian.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From 0d8a7080f7fdc158a635e939e06bc7884a034ab1 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <0d8a7080f7fdc158a635e939e06bc7884a034ab1.1569226914.git.github@grubix.eu>
|
||||
In-Reply-To: <49b85799a8f0674ac5eb6f2dfc37b23208d9754a.1569226914.git.github@grubix.eu>
|
||||
References: <49b85799a8f0674ac5eb6f2dfc37b23208d9754a.1569226914.git.github@grubix.eu>
|
||||
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
|
||||
Date: Tue, 26 Jun 2018 17:38:43 +0200
|
||||
Subject: [PATCH 12/13] Disable Debian
|
||||
|
||||
Signed-off-by: Michael J Gruber <github@grubix.eu>
|
||||
---
|
||||
setup.py | 10 +++++-----
|
||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 379323b..86619ec 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -26,7 +26,7 @@ from distutils.command.sdist import sdist
|
||||
from distutils import log
|
||||
from subprocess import Popen, PIPE
|
||||
sys.path.append("lib")
|
||||
-from contrib.debian.installer import DebianInstaller
|
||||
+#from contrib.debian.installer import DebianInstaller
|
||||
|
||||
#
|
||||
# Build the command line script
|
||||
@@ -373,10 +373,10 @@ class Install(install):
|
||||
raise OSError("not found: %s" % ", ".join(mis_stys))
|
||||
|
||||
def run(self):
|
||||
- if self.install_layout == "deb":
|
||||
- db = DebianInstaller(self)
|
||||
- else:
|
||||
- db = None
|
||||
+# if self.install_layout == "deb":
|
||||
+# db = DebianInstaller(self)
|
||||
+# else:
|
||||
+ db = None
|
||||
|
||||
if not(db) and not(self.nodeps):
|
||||
try:
|
||||
--
|
||||
2.23.0.369.g5d0cb2d495
|
||||
|
2874
dblatex-0.3.11-python3.patch
Normal file
2874
dblatex-0.3.11-python3.patch
Normal file
File diff suppressed because it is too large
Load Diff
42
dblatex-0.3.11-which-shutil.patch
Normal file
42
dblatex-0.3.11-which-shutil.patch
Normal file
@ -0,0 +1,42 @@
|
||||
From af5dc6ec530b107a4a0bd6ac9b2e80b0e7d36077 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <af5dc6ec530b107a4a0bd6ac9b2e80b0e7d36077.1569226914.git.github@grubix.eu>
|
||||
In-Reply-To: <49b85799a8f0674ac5eb6f2dfc37b23208d9754a.1569226914.git.github@grubix.eu>
|
||||
References: <49b85799a8f0674ac5eb6f2dfc37b23208d9754a.1569226914.git.github@grubix.eu>
|
||||
From: =?UTF-8?q?Nikola=20Forr=C3=B3?= <nforro@redhat.com>
|
||||
Date: Tue, 26 Jun 2018 17:41:19 +0200
|
||||
Subject: [PATCH 13/13] Use which from shutil
|
||||
|
||||
Signed-off-by: Michael J Gruber <github@grubix.eu>
|
||||
---
|
||||
setup.py | 10 ++++------
|
||||
1 file changed, 4 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 86619ec..799c1d2 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -208,17 +208,15 @@ class Build(build):
|
||||
|
||||
|
||||
def find_programs(utils):
|
||||
- sys.path.append("lib")
|
||||
- from contrib.which import which
|
||||
+ import shutil
|
||||
util_paths = {}
|
||||
missed = []
|
||||
for util in utils:
|
||||
- try:
|
||||
- path = which.which(util)
|
||||
+ path = shutil.which(util)
|
||||
+ if path:
|
||||
util_paths[util] = path
|
||||
- except which.WhichError:
|
||||
+ else:
|
||||
missed.append(util)
|
||||
- sys.path.remove("lib")
|
||||
return (util_paths, missed)
|
||||
|
||||
def kpsewhich(tex_file):
|
||||
--
|
||||
2.23.0.369.g5d0cb2d495
|
||||
|
@ -1,26 +0,0 @@
|
||||
--- dblatex-0.3.4/setup.py 2012-06-02 16:43:42.000000000 -0700
|
||||
+++ dblatex-0.3.4/setup.py_disable_debian 2012-12-03 21:30:30.843851029 -0800
|
||||
@@ -23,7 +23,7 @@ from distutils.command.sdist import sdis
|
||||
from distutils import log
|
||||
from subprocess import Popen, PIPE
|
||||
sys.path.append("lib")
|
||||
-from contrib.debian.installer import DebianInstaller
|
||||
+#from contrib.debian.installer import DebianInstaller
|
||||
|
||||
#
|
||||
# Build the command line script
|
||||
@@ -365,10 +365,10 @@ class Install(install):
|
||||
raise OSError("not found: %s" % ", ".join(mis_stys))
|
||||
|
||||
def run(self):
|
||||
- if self.install_layout == "deb":
|
||||
- db = DebianInstaller(self)
|
||||
- else:
|
||||
- db = None
|
||||
+# if self.install_layout == "deb":
|
||||
+# db = DebianInstaller(self)
|
||||
+# else:
|
||||
+ db = None
|
||||
|
||||
if not(db) and not(self.nodeps):
|
||||
try:
|
31
dblatex.spec
31
dblatex.spec
@ -1,6 +1,6 @@
|
||||
Name: dblatex
|
||||
Version: 0.3.11
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: DocBook to LaTeX/ConTeXt Publishing
|
||||
BuildArch: noarch
|
||||
# Most of package is GPLv2+, except:
|
||||
@ -14,10 +14,11 @@ URL: http://dblatex.sourceforge.net/
|
||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
|
||||
# Source1 is from http://docbook.sourceforge.net/release/xsl/current/COPYING
|
||||
Source1: COPYING-docbook-xsl
|
||||
Patch0: dblatex-disable-debian.patch
|
||||
Patch0: dblatex-0.3.11-python3.patch
|
||||
Patch1: dblatex-0.3.11-disable-debian.patch
|
||||
Patch2: dblatex-0.3.11-which-shutil.patch
|
||||
|
||||
Provides: bundled(python2-which) = 1.1.0
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: libxslt
|
||||
BuildRequires: texlive-base
|
||||
BuildRequires: texlive-collection-latex
|
||||
@ -78,17 +79,20 @@ Authors:
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .disable-debian
|
||||
pathfix.py -pni "%{__python2} %{py2_shbang_opts}" .
|
||||
%patch0 -p1 -b .python3
|
||||
%patch1 -p1 -b .disable-debian
|
||||
%patch2 -p1 -b .which-shutil
|
||||
|
||||
rm -rf lib/contrib
|
||||
pathfix.py -pni "%{__python3} %{py3_shbang_opts}" .
|
||||
|
||||
%build
|
||||
%{__python2} setup.py build
|
||||
%{__python3} setup.py build
|
||||
|
||||
|
||||
%install
|
||||
#%{__python2} setup.py install --skip-build --root $RPM_BUILD_ROOT
|
||||
%{__python2} setup.py install --root $RPM_BUILD_ROOT
|
||||
pathfix.py -pni "%{__python2} %{py2_shbang_opts}" $RPM_BUILD_ROOT%{_bindir}/dblatex
|
||||
%{__python3} setup.py install --root $RPM_BUILD_ROOT
|
||||
pathfix.py -pni "%{__python3} %{py3_shbang_opts}" $RPM_BUILD_ROOT%{_bindir}/dblatex
|
||||
|
||||
# these are already in tetex-latex:
|
||||
for file in bibtopic.sty enumitem.sty ragged2e.sty passivetex/ xelatex/; do
|
||||
@ -119,8 +123,8 @@ cp -p %{SOURCE1} COPYING-docbook-xsl
|
||||
%files
|
||||
%{_mandir}/man1/dblatex.1*
|
||||
%doc COPYRIGHT docs/manual.pdf COPYING-docbook-xsl README-xsltml
|
||||
%{python2_sitelib}/dbtexmf/
|
||||
%{python2_sitelib}/dblatex-*.egg-info
|
||||
%{python3_sitelib}/dbtexmf/
|
||||
%{python3_sitelib}/dblatex-*.egg-info
|
||||
%{_bindir}/dblatex
|
||||
%{_datadir}/dblatex/
|
||||
%{_datadir}/texlive/texmf-dist/tex/latex/dblatex/
|
||||
@ -131,6 +135,9 @@ cp -p %{SOURCE1} COPYING-docbook-xsl
|
||||
%postun -p /usr/bin/texhash
|
||||
|
||||
%changelog
|
||||
* Mon Sep 23 2019 Michael J Gruber <mjg@fedoraproject.org> - 0.3.11-2
|
||||
- port to python3 (bz #1737967)
|
||||
|
||||
* Sun Sep 22 2019 Michael J Gruber <mjg@fedoraproject.org> - 0.3.11-1
|
||||
- bugfix release (bz #1753399)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user