parent
df7f2d1b72
commit
11ffed7e6b
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
dblatex-0.3.tar.bz2
|
/dblatex-0.3.4.tar.bz2
|
||||||
|
26
dblatex-disable-debian.patch
Normal file
26
dblatex-disable-debian.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
--- dblatex-0.3.4/setup.py 2012-06-02 16:43:42.000000000 -0700
|
||||||
|
+++ dblatex-0.3.4/setup.py_disable_debian 2012-12-03 21:30:30.843851029 -0800
|
||||||
|
@@ -23,7 +23,7 @@ from distutils.command.sdist import sdis
|
||||||
|
from distutils import log
|
||||||
|
from subprocess import Popen, PIPE
|
||||||
|
sys.path.append("lib")
|
||||||
|
-from contrib.debian.installer import DebianInstaller
|
||||||
|
+#from contrib.debian.installer import DebianInstaller
|
||||||
|
|
||||||
|
#
|
||||||
|
# Build the command line script
|
||||||
|
@@ -365,10 +365,10 @@ class Install(install):
|
||||||
|
raise OSError("not found: %s" % ", ".join(mis_stys))
|
||||||
|
|
||||||
|
def run(self):
|
||||||
|
- if self.install_layout == "deb":
|
||||||
|
- db = DebianInstaller(self)
|
||||||
|
- else:
|
||||||
|
- db = None
|
||||||
|
+# if self.install_layout == "deb":
|
||||||
|
+# db = DebianInstaller(self)
|
||||||
|
+# else:
|
||||||
|
+ db = None
|
||||||
|
|
||||||
|
if not(db) and not(self.nodeps):
|
||||||
|
try:
|
63
dblatex.spec
63
dblatex.spec
@ -1,8 +1,8 @@
|
|||||||
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||||
|
|
||||||
Name: dblatex
|
Name: dblatex
|
||||||
Version: 0.3
|
Version: 0.3.4
|
||||||
Release: 5%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: DocBook to LaTeX/ConTeXt Publishing
|
Summary: DocBook to LaTeX/ConTeXt Publishing
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
@ -12,16 +12,52 @@ Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
|
|||||||
#Source1: http://docbook.sourceforge.net/release/xsl/current/COPYING
|
#Source1: http://docbook.sourceforge.net/release/xsl/current/COPYING
|
||||||
Source1: COPYING-docbook-xsl
|
Source1: COPYING-docbook-xsl
|
||||||
Patch0: dblatex-0.2.7-external-which.patch
|
Patch0: dblatex-0.2.7-external-which.patch
|
||||||
|
Patch1: dblatex-disable-debian.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: python-devel
|
BuildRequires: python-devel
|
||||||
BuildRequires: python-which
|
BuildRequires: python-which
|
||||||
BuildRequires: libxslt
|
BuildRequires: libxslt
|
||||||
BuildRequires: ImageMagick
|
BuildRequires: ImageMagick
|
||||||
BuildRequires: tex(latex)
|
BuildRequires: texlive-base
|
||||||
BuildRequires: tex(xetex)
|
BuildRequires: texlive-collection-latex
|
||||||
Requires: tex(xetex)
|
BuildRequires: texlive-collection-xetex
|
||||||
Requires: libxslt docbook-dtds passivetex ImageMagick transfig
|
BuildRequires: texlive-collection-htmlxml
|
||||||
|
BuildRequires: transfig
|
||||||
|
BuildRequires: texlive-epstopdf-bin
|
||||||
|
BuildRequires: texlive-xmltex-bin
|
||||||
|
BuildRequires: texlive-anysize
|
||||||
|
BuildRequires: texlive-appendix
|
||||||
|
BuildRequires: texlive-changebar
|
||||||
|
BuildRequires: texlive-jknapltx
|
||||||
|
BuildRequires: texlive-multirow
|
||||||
|
BuildRequires: texlive-overpic
|
||||||
|
BuildRequires: texlive-pdfpages
|
||||||
|
BuildRequires: texlive-subfigure
|
||||||
|
BuildRequires: texlive-stmaryrd
|
||||||
|
Requires: texlive-base
|
||||||
|
Requires: texlive-collection-latex
|
||||||
|
Requires: texlive-collection-xetex
|
||||||
|
Requires: texlive-collection-htmlxml
|
||||||
|
Requires: texlive-collection-fontsrecommended
|
||||||
|
Requires: texlive-epstopdf-bin
|
||||||
|
Requires: texlive-passivetex
|
||||||
|
Requires: texlive-xmltex texlive-xmltex-bin
|
||||||
|
Requires: texlive-anysize
|
||||||
|
Requires: texlive-appendix
|
||||||
|
Requires: texlive-bibtopic
|
||||||
|
Requires: texlive-changebar
|
||||||
|
Requires: texlive-ec
|
||||||
|
Requires: texlive-jknapltx
|
||||||
|
Requires: texlive-overpic
|
||||||
|
Requires: texlive-passivetex
|
||||||
|
Requires: texlive-pdfpages
|
||||||
|
Requires: texlive-subfigure
|
||||||
|
Requires: texlive-stmaryrd
|
||||||
|
Requires: texlive-xmltex-bin
|
||||||
|
Requires: libxslt docbook-dtds
|
||||||
|
Requires: transfig
|
||||||
|
Requires: ImageMagick
|
||||||
|
|
||||||
%description
|
%description
|
||||||
dblatex is a program that transforms your SGML/XMLDocBook
|
dblatex is a program that transforms your SGML/XMLDocBook
|
||||||
@ -38,10 +74,11 @@ Authors:
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .external-which
|
%patch0 -p1 -b .external-which
|
||||||
|
%patch1 -p1 -b .disable-debian
|
||||||
rm -rf lib/contrib
|
rm -rf lib/contrib
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{__python } setup.py build
|
%{__python} setup.py build
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -53,14 +90,14 @@ for file in bibtopic.sty enumitem.sty ragged2e.sty passivetex/ xelatex/; do
|
|||||||
rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/misc/$file
|
rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/misc/$file
|
||||||
done
|
done
|
||||||
|
|
||||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex
|
mkdir -p $RPM_BUILD_ROOT%{_datadir}/texlive/texmf-dist/tex/latex/dblatex
|
||||||
for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.sty' ` ; do
|
for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.sty' ` ; do
|
||||||
mv $file $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex/`basename $file`;
|
mv $file $RPM_BUILD_ROOT%{_datadir}/texlive/texmf-dist/tex/latex/dblatex/`basename $file`;
|
||||||
done
|
done
|
||||||
|
|
||||||
## also move .xetex files
|
## also move .xetex files
|
||||||
for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.xetex' ` ; do
|
for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.xetex' ` ; do
|
||||||
mv $file $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex/`basename $file`;
|
mv $file $RPM_BUILD_ROOT%{_datadir}/texlive/texmf-dist/tex/latex/dblatex/`basename $file`;
|
||||||
done
|
done
|
||||||
|
|
||||||
rmdir $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/{misc,contrib/example,style}
|
rmdir $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/{misc,contrib/example,style}
|
||||||
@ -86,7 +123,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{python_sitelib}/dblatex-*.egg-info
|
%{python_sitelib}/dblatex-*.egg-info
|
||||||
%{_bindir}/dblatex
|
%{_bindir}/dblatex
|
||||||
%{_datadir}/dblatex/
|
%{_datadir}/dblatex/
|
||||||
%{_datadir}/texmf/tex/latex/dblatex/
|
%{_datadir}/texlive/texmf-dist/tex/latex/dblatex/
|
||||||
%dir %{_sysconfdir}/dblatex
|
%dir %{_sysconfdir}/dblatex
|
||||||
|
|
||||||
%post -p /usr/bin/texhash
|
%post -p /usr/bin/texhash
|
||||||
@ -94,6 +131,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%postun -p /usr/bin/texhash
|
%postun -p /usr/bin/texhash
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 02 2013 Benjamin De Kosnik <bkoz@redhat.com> - 0.3.4-1
|
||||||
|
- Update to 0.3.4.
|
||||||
|
- Adjust for texlive rebase.
|
||||||
|
|
||||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-5
|
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user