cyrus-sasl/cyrus-sasl-2.1.26-md5global...

50 lines
1.9 KiB
Diff

diff -up cyrus-sasl-2.1.27/include/Makefile.am.md5global.h cyrus-sasl-2.1.27/include/Makefile.am
--- cyrus-sasl-2.1.27/include/Makefile.am.md5global.h 2015-10-15 15:44:43.000000000 +0200
+++ cyrus-sasl-2.1.27/include/Makefile.am 2015-11-20 15:28:25.930263088 +0100
@@ -47,16 +47,7 @@ noinst_HEADERS = gai.h exits.h
saslincludedir = $(includedir)/sasl
saslinclude_HEADERS = hmac-md5.h md5.h md5global.h sasl.h saslplug.h saslutil.h prop.h
-noinst_PROGRAMS = makemd5
-
-makemd5_SOURCES = makemd5.c
-
-md5global.h: makemd5
- -rm -f md5global.h
- ./makemd5 md5global.h
-
EXTRA_DIST = NTMakefile
-DISTCLEANFILES = md5global.h
if MACOSX
framedir = /Library/Frameworks/SASL2.framework
diff -up cyrus-sasl-2.1.27/include/md5global.h.md5global.h cyrus-sasl-2.1.27/include/md5global.h
--- cyrus-sasl-2.1.27/include/md5global.h.md5global.h 2015-11-20 15:28:25.932263083 +0100
+++ cyrus-sasl-2.1.27/include/md5global.h 2015-11-20 15:36:16.380184280 +0100
@@ -15,14 +15,17 @@ The following makes PROTOTYPES default t
/* POINTER defines a generic pointer type */
typedef unsigned char *POINTER;
-typedef signed char INT1; /* 8 bits */
-typedef short INT2; /* 16 bits */
-typedef int INT4; /* 32 bits */
-typedef long INT8; /* 64 bits */
-typedef unsigned char UINT1; /* 8 bits */
-typedef unsigned short UINT2; /* 16 bits */
-typedef unsigned int UINT4; /* 32 bits */
-typedef unsigned long UINT8; /* 64 bits */
+/* We try to define integer types for our use */
+#include <inttypes.h>
+
+typedef int8_t INT1; /* 8 bits */
+typedef int16_t INT2; /* 16 bits */
+typedef int32_t INT4; /* 32 bits */
+typedef int64_t INT8; /* 64 bits */
+typedef uint8_t UINT1; /* 8 bits */
+typedef uint16_t UINT2; /* 16 bits */
+typedef uint32_t UINT4; /* 32 bits */
+typedef uint64_t UINT8; /* 64 bits */
/* PROTO_LIST is defined depending on how PROTOTYPES is defined above.
If using PROTOTYPES, then PROTO_LIST returns the list, otherwise it