6bd250bfdc
Related to:
<https://fedoraproject.org/wiki/Changes/PortingToModernC>
<https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
Upstream commit:
266f0acf7f
54 lines
2.5 KiB
Diff
54 lines
2.5 KiB
Diff
From 266f0acf7f5e029afbb3e263437039e50cd6c262 Mon Sep 17 00:00:00 2001
|
||
From: Sam James <sam@gentoo.org>
|
||
Date: Wed, 23 Feb 2022 00:45:15 +0000
|
||
Subject: Fix <time.h> check
|
||
MIME-Version: 1.0
|
||
Content-Type: text/plain; charset=UTF-8
|
||
Content-Transfer-Encoding: 8bit
|
||
|
||
We're conditionally including based on HAVE_TIME_H in a bunch of places,
|
||
but we're not actually checking for time.h, so that's never going to be defined.
|
||
|
||
While at it, add in a missing include in the cram plugin.
|
||
|
||
This fixes a bunch of implicit declaration warnings:
|
||
```
|
||
* cyrus-sasl-2.1.28/lib/saslutil.c:280:3: warning: implicit declaration of function ‘time’ [-Wimplicit-function-declaration]
|
||
* cyrus-sasl-2.1.28/lib/saslutil.c:364:41: warning: implicit declaration of function ‘clock’ [-Wimplicit-function-declaration]
|
||
* cyrus-sasl-2.1.28/plugins/cram.c:132:7: warning: implicit declaration of function ‘time’ [-Wimplicit-function-declaration]
|
||
* cyrus-sasl-2.1.28/lib/saslutil.c:280:3: warning: implicit declaration of function ‘time’ [-Wimplicit-function-declaration]
|
||
* cyrus-sasl-2.1.28/lib/saslutil.c:364:41: warning: implicit declaration of function ‘clock’ [-Wimplicit-function-declaration]
|
||
* cyrus-sasl-2.1.28/plugins/cram.c:132:7: warning: implicit declaration of function ‘time’ [-Wimplicit-function-declaration]
|
||
```
|
||
|
||
Signed-off-by: Sam James <sam@gentoo.org>
|
||
|
||
[Edited to apply to Fedora - DJ]
|
||
diff -rup a/configure.ac b/configure.ac
|
||
--- a/configure.ac 2023-04-20 00:31:33.578596460 -0400
|
||
+++ b/configure.ac 2023-04-20 01:17:40.877579628 -0400
|
||
@@ -1239,6 +1239,7 @@ AC_CHECK_HEADERS_ONCE([sys/time.h])
|
||
AC_HEADER_DIRENT
|
||
AC_HEADER_SYS_WAIT
|
||
AC_CHECK_HEADERS(crypt.h des.h dlfcn.h fcntl.h limits.h malloc.h paths.h strings.h sys/file.h sys/time.h syslog.h unistd.h inttypes.h sys/uio.h sys/param.h sysexits.h stdarg.h varargs.h krb5.h)
|
||
+AC_CHECK_HEADERS(crypt.h des.h dlfcn.h fcntl.h limits.h malloc.h paths.h strings.h sys/file.h sys/time.h syslog.h time.h unistd.h inttypes.h sys/uio.h sys/param.h sysexits.h stdarg.h varargs.h krb5.h)
|
||
AC_CHECK_TYPES([long long, int8_t, uint8_t, int16_t, uint16_t, int32_t, uint32_t, int64_t, uint64_t],,,[
|
||
#ifdef HAVE_INTTYPES_H
|
||
#include <inttypes.h>
|
||
Only in b: configure.ac.orig
|
||
Only in b: configure.ac.rej
|
||
diff -rup a/plugins/cram.c b/plugins/cram.c
|
||
--- a/plugins/cram.c 2022-02-18 16:50:42.000000000 -0500
|
||
+++ b/plugins/cram.c 2023-04-20 01:20:12.228312652 -0400
|
||
@@ -53,6 +53,10 @@
|
||
#endif
|
||
#include <fcntl.h>
|
||
|
||
+#ifdef HAVE_TIME_H
|
||
+#include <time.h>
|
||
+#endif
|
||
+
|
||
#include <sasl.h>
|
||
#include <saslplug.h>
|
||
#include <saslutil.h>
|