36 lines
1.8 KiB
Diff
36 lines
1.8 KiB
Diff
diff -up cyrus-sasl-2.1.26/lib/Makefile.am.relro cyrus-sasl-2.1.26/lib/Makefile.am
|
|
--- cyrus-sasl-2.1.26/lib/Makefile.am.relro 2012-10-12 16:05:48.000000000 +0200
|
|
+++ cyrus-sasl-2.1.26/lib/Makefile.am 2013-02-11 14:18:01.749053772 +0100
|
|
@@ -64,7 +64,7 @@ LIB_DOOR= @LIB_DOOR@
|
|
lib_LTLIBRARIES = libsasl2.la
|
|
|
|
libsasl2_la_SOURCES = $(common_sources) $(common_headers)
|
|
-libsasl2_la_LDFLAGS = -version-info $(sasl_version)
|
|
+libsasl2_la_LDFLAGS = -Wl,-z,relro -version-info $(sasl_version)
|
|
libsasl2_la_DEPENDENCIES = $(LTLIBOBJS)
|
|
libsasl2_la_LIBADD = $(LTLIBOBJS) $(SASL_DL_LIB) $(LIB_SOCKET) $(LIB_DOOR)
|
|
|
|
diff -up cyrus-sasl-2.1.26/plugins/Makefile.am.relro cyrus-sasl-2.1.26/plugins/Makefile.am
|
|
--- cyrus-sasl-2.1.26/plugins/Makefile.am.relro 2012-10-12 16:05:48.000000000 +0200
|
|
+++ cyrus-sasl-2.1.26/plugins/Makefile.am 2013-02-11 14:18:01.749053772 +0100
|
|
@@ -50,7 +50,7 @@
|
|
plugin_version = 3:0:0
|
|
|
|
INCLUDES=-I$(top_srcdir)/include -I$(top_srcdir)/lib -I$(top_srcdir)/sasldb -I$(top_builddir)/include
|
|
-AM_LDFLAGS = -module -export-dynamic -rpath $(plugindir) -version-info $(plugin_version)
|
|
+AM_LDFLAGS = -Wl,-z,relro -module -export-dynamic -rpath $(plugindir) -version-info $(plugin_version)
|
|
|
|
COMPAT_OBJS = @LTGETADDRINFOOBJS@ @LTGETNAMEINFOOBJS@ @LTSNPRINTFOBJS@
|
|
|
|
diff -up cyrus-sasl-2.1.26/saslauthd/Makefile.am.relro cyrus-sasl-2.1.26/saslauthd/Makefile.am
|
|
--- cyrus-sasl-2.1.26/saslauthd/Makefile.am.relro 2013-02-11 14:18:36.910900647 +0100
|
|
+++ cyrus-sasl-2.1.26/saslauthd/Makefile.am 2013-02-11 14:20:17.336463915 +0100
|
|
@@ -17,6 +17,7 @@ saslauthd_DEPENDENCIES = saslauthd-main.
|
|
saslauthd_LDADD = @SASL_KRB_LIB@ \
|
|
@GSSAPIBASE_LIBS@ @GSSAPI_LIBS@ @LIB_CRYPT@ @LIB_SIA@ \
|
|
@LIB_SOCKET@ @SASL_DB_LIB@ @LIB_PAM@ @LDAP_LIBS@ @LTLIBOBJS@
|
|
+saslauthd_LDFLAGS = -pie -Wl,-z,now
|
|
|
|
testsaslauthd_SOURCES = testsaslauthd.c utils.c
|
|
testsaslauthd_LDADD = @LIB_SOCKET@
|