- always link against the internal db4 (#459163)
- rediff patches for no fuzz
This commit is contained in:
parent
b0f2ba80b8
commit
da64ac9b23
@ -1,9 +1,10 @@
|
||||
Use TRY_LINK instead of CHECK_LIB and try linking with plain old -ldb to
|
||||
properly pick up uniq'ified single-use DB.
|
||||
|
||||
--- cyrus-sasl-2.1.22/cmulocal/berkdb.m4 2005-04-26 15:14:07.000000000 -0400
|
||||
+++ cyrus-sasl-2.1.22/cmulocal/berkdb.m4 2006-05-19 16:33:52.000000000 -0400
|
||||
@@ -31,41 +31,22 @@
|
||||
diff -up cyrus-sasl-2.1.22/cmulocal/berkdb.m4.db_bundle cyrus-sasl-2.1.22/cmulocal/berkdb.m4
|
||||
--- cyrus-sasl-2.1.22/cmulocal/berkdb.m4.db_bundle 2005-04-26 21:14:07.000000000 +0200
|
||||
+++ cyrus-sasl-2.1.22/cmulocal/berkdb.m4 2008-08-29 11:58:37.000000000 +0200
|
||||
@@ -31,41 +31,22 @@ AC_DEFUN([CMU_DB_INC_WHERE], [
|
||||
# Test for lib files
|
||||
#
|
||||
|
||||
@ -50,14 +51,15 @@ properly pick up uniq'ified single-use DB.
|
||||
if test "$ac_cv_found_db_lib" = "yes" ; then
|
||||
ac_cv_db_where_lib=$i
|
||||
AC_MSG_RESULT(found)
|
||||
--- cyrus-sasl-2.1.22/utils/Makefile.am 2006-05-19 16:33:52.000000000 -0400
|
||||
+++ cyrus-sasl-2.1.22/utils/Makefile.am 2006-05-19 16:34:20.000000000 -0400
|
||||
@@ -58,7 +58,7 @@
|
||||
diff -up cyrus-sasl-2.1.22/utils/Makefile.am.db_bundle cyrus-sasl-2.1.22/utils/Makefile.am
|
||||
--- cyrus-sasl-2.1.22/utils/Makefile.am.db_bundle 2006-05-18 20:34:26.000000000 +0200
|
||||
+++ cyrus-sasl-2.1.22/utils/Makefile.am 2008-08-29 11:58:37.000000000 +0200
|
||||
@@ -58,7 +58,7 @@ endif
|
||||
|
||||
saslpasswd2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
|
||||
saslpasswd2_SOURCES = saslpasswd.c
|
||||
-sasldblistusers2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
|
||||
+sasldblistusers2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs) @SASL_DB_LIB@
|
||||
sasldblistusers2_SOURCES = sasldblistusers.c
|
||||
dbconverter_2_CFLAGS = -DSASL_GDBM
|
||||
dbconverter_2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs) -lgdbm
|
||||
dbconverter_2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
|
||||
pluginviewer_LDADD = $(all_sasl_libs)
|
||||
|
@ -1,5 +1,17 @@
|
||||
--- cyrus-sasl-2.1.22/plugins/kerberos4.c~ 2005-01-10 02:08:53.000000000 -0500
|
||||
+++ cyrus-sasl-2.1.22/plugins/kerberos4.c 2007-05-14 13:02:16.000000000 -0400
|
||||
diff -up cyrus-sasl-2.1.22/config/kerberos_v4.m4.krb4 cyrus-sasl-2.1.22/config/kerberos_v4.m4
|
||||
--- cyrus-sasl-2.1.22/config/kerberos_v4.m4.krb4 2005-05-07 06:14:55.000000000 +0200
|
||||
+++ cyrus-sasl-2.1.22/config/kerberos_v4.m4 2008-08-14 23:41:26.000000000 +0200
|
||||
@@ -102,7 +102,6 @@ AC_DEFUN([SASL_KERBEROS_V4_CHK], [
|
||||
if test -n "${cyrus_krbinclude}"; then
|
||||
CPPFLAGS="$CPPFLAGS -I${cyrus_krbinclude}"
|
||||
fi
|
||||
- LDFLAGS="$LDFLAGS -L$krb4/lib"
|
||||
fi
|
||||
|
||||
if test "$with_des" != no; then
|
||||
diff -up cyrus-sasl-2.1.22/plugins/kerberos4.c.krb4 cyrus-sasl-2.1.22/plugins/kerberos4.c
|
||||
--- cyrus-sasl-2.1.22/plugins/kerberos4.c.krb4 2005-01-10 08:08:53.000000000 +0100
|
||||
+++ cyrus-sasl-2.1.22/plugins/kerberos4.c 2008-08-14 23:36:33.000000000 +0200
|
||||
@@ -49,11 +49,7 @@
|
||||
#include <krb.h>
|
||||
|
||||
|
@ -5,7 +5,7 @@
|
||||
Summary: The Cyrus SASL library
|
||||
Name: cyrus-sasl
|
||||
Version: 2.1.22
|
||||
Release: 16%{?dist}
|
||||
Release: 17%{?dist}
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
# Source0 originally comes from ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/;
|
||||
@ -393,6 +393,10 @@ fi
|
||||
%{_sbindir}/sasl2-shared-mechlist
|
||||
|
||||
%changelog
|
||||
* Fri Aug 29 2008 Tomas Mraz <tmraz@redhat.com> - 2.1.22-17
|
||||
- always link against the internal db4 (#459163)
|
||||
- rediff patches for no fuzz
|
||||
|
||||
* Wed Jul 9 2008 Tomas Mraz <tmraz@redhat.com> - 2.1.22-16
|
||||
- update internal db4 (#449737)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user