- update to 2.1.22, adding pluginviewer to %%{_sbindir}
This commit is contained in:
parent
1fe49c53b0
commit
6760712500
63
cyrus-sasl-2.1.22-db_bundle.patch
Normal file
63
cyrus-sasl-2.1.22-db_bundle.patch
Normal file
@ -0,0 +1,63 @@
|
|||||||
|
Use TRY_LINK instead of CHECK_LIB and try linking with plain old -ldb to
|
||||||
|
properly pick up uniq'ified single-use DB.
|
||||||
|
|
||||||
|
--- cyrus-sasl-2.1.22/cmulocal/berkdb.m4 2005-04-26 15:14:07.000000000 -0400
|
||||||
|
+++ cyrus-sasl-2.1.22/cmulocal/berkdb.m4 2006-05-19 16:33:52.000000000 -0400
|
||||||
|
@@ -31,41 +31,22 @@
|
||||||
|
# Test for lib files
|
||||||
|
#
|
||||||
|
|
||||||
|
-AC_DEFUN([CMU_DB3_LIB_WHERE1], [
|
||||||
|
+AC_DEFUN([CMU_DB_LIB_WHERE1], [
|
||||||
|
AC_REQUIRE([CMU_AFS])
|
||||||
|
AC_REQUIRE([CMU_KRB4])
|
||||||
|
saved_LIBS=$LIBS
|
||||||
|
- LIBS="$saved_LIBS -L$1 -ldb-3"
|
||||||
|
+LIBS="$saved_LIBS -L$1 -ldb"
|
||||||
|
AC_TRY_LINK([#include <db.h>],
|
||||||
|
[db_env_create(NULL, 0);],
|
||||||
|
-[ac_cv_found_db_3_lib=yes],
|
||||||
|
-ac_cv_found_db_3_lib=no)
|
||||||
|
-LIBS=$saved_LIBS
|
||||||
|
-])
|
||||||
|
-AC_DEFUN([CMU_DB4_LIB_WHERE1], [
|
||||||
|
-AC_REQUIRE([CMU_AFS])
|
||||||
|
-AC_REQUIRE([CMU_KRB4])
|
||||||
|
-saved_LIBS=$LIBS
|
||||||
|
-LIBS="$saved_LIBS -L$1 -ldb-4"
|
||||||
|
-AC_TRY_LINK([#include <db.h>],
|
||||||
|
-[db_env_create(NULL, 0);],
|
||||||
|
-[ac_cv_found_db_4_lib=yes],
|
||||||
|
-ac_cv_found_db_4_lib=no)
|
||||||
|
+[ac_cv_found_db_lib=yes],
|
||||||
|
+ac_cv_found_db_lib=no)
|
||||||
|
LIBS=$saved_LIBS
|
||||||
|
])
|
||||||
|
|
||||||
|
AC_DEFUN([CMU_DB_LIB_WHERE], [
|
||||||
|
for i in $1; do
|
||||||
|
AC_MSG_CHECKING(for db libraries in $i)
|
||||||
|
-if test "$enable_db4" = "yes"; then
|
||||||
|
- CMU_DB4_LIB_WHERE1($i)
|
||||||
|
- CMU_TEST_LIBPATH($i, [db-4])
|
||||||
|
- ac_cv_found_db_lib=$ac_cv_found_db_4_lib
|
||||||
|
-else
|
||||||
|
- CMU_DB3_LIB_WHERE1($i)
|
||||||
|
- CMU_TEST_LIBPATH($i, [db-3])
|
||||||
|
- ac_cv_found_db_lib=$ac_cv_found_db_3_lib
|
||||||
|
-fi
|
||||||
|
+ CMU_DB_LIB_WHERE1($i)
|
||||||
|
if test "$ac_cv_found_db_lib" = "yes" ; then
|
||||||
|
ac_cv_db_where_lib=$i
|
||||||
|
AC_MSG_RESULT(found)
|
||||||
|
--- cyrus-sasl-2.1.22/utils/Makefile.am 2006-05-19 16:33:52.000000000 -0400
|
||||||
|
+++ cyrus-sasl-2.1.22/utils/Makefile.am 2006-05-19 16:34:20.000000000 -0400
|
||||||
|
@@ -58,7 +58,7 @@
|
||||||
|
|
||||||
|
saslpasswd2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
|
||||||
|
saslpasswd2_SOURCES = saslpasswd.c
|
||||||
|
-sasldblistusers2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs)
|
||||||
|
+sasldblistusers2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs) @SASL_DB_LIB@
|
||||||
|
sasldblistusers2_SOURCES = sasldblistusers.c
|
||||||
|
dbconverter_2_CFLAGS = -DSASL_GDBM
|
||||||
|
dbconverter_2_LDADD = ../sasldb/libsasldb.la $(all_sasl_libs) -lgdbm
|
@ -5,8 +5,8 @@
|
|||||||
|
|
||||||
Summary: The Cyrus SASL library.
|
Summary: The Cyrus SASL library.
|
||||||
Name: cyrus-sasl
|
Name: cyrus-sasl
|
||||||
Version: 2.1.21
|
Version: 2.1.22
|
||||||
Release: 12
|
Release: 1
|
||||||
License: Freely Distributable
|
License: Freely Distributable
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source0: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz
|
Source0: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz
|
||||||
@ -18,20 +18,18 @@ Source8: sasl-checkpass.c
|
|||||||
Source9: saslauthd.sysconfig
|
Source9: saslauthd.sysconfig
|
||||||
URL: http://asg.web.cmu.edu/sasl/sasl-library.html
|
URL: http://asg.web.cmu.edu/sasl/sasl-library.html
|
||||||
Requires: %{name}-lib = %{version}-%{release}
|
Requires: %{name}-lib = %{version}-%{release}
|
||||||
Patch5: cyrus-sasl-2.1.7-gdbm.patch
|
Patch5: cyrus-sasl-2.1.22-gdbm.patch
|
||||||
Patch6: cyrus-sasl-2.1.10-des.patch
|
Patch6: cyrus-sasl-2.1.10-des.patch
|
||||||
Patch7: cyrus-sasl-2.1.20-gssapi-dynamic.patch
|
Patch7: cyrus-sasl-2.1.20-gssapi-dynamic.patch
|
||||||
Patch9: cyrus-sasl-2.1.17-saslauthd1.patch
|
Patch9: cyrus-sasl-2.1.17-saslauthd1.patch
|
||||||
Patch10: cyrus-sasl-2.1.21-db_bundle.patch
|
Patch10: cyrus-sasl-2.1.22-db_bundle.patch
|
||||||
Patch11: cyrus-sasl-2.1.18-no_rpath.patch
|
Patch11: cyrus-sasl-2.1.18-no_rpath.patch
|
||||||
Patch13: cyrus-sasl-2.1.20-notgnu.patch
|
Patch13: cyrus-sasl-2.1.20-notgnu.patch
|
||||||
Patch14: cyrus-sasl-2.1.20-conflict.patch
|
Patch14: cyrus-sasl-2.1.20-conflict.patch
|
||||||
Patch15: cyrus-sasl-2.1.20-saslauthd.conf-path.patch
|
Patch15: cyrus-sasl-2.1.20-saslauthd.conf-path.patch
|
||||||
Patch17: cyrus-sasl-2.1.21-builddir.patch
|
Patch16: cyrus-sasl-2.1.22-builddir.patch
|
||||||
Patch18: cyrus-sasl-2.1.21-linksrcs.patch
|
Patch18: cyrus-sasl-2.1.21-linksrcs.patch
|
||||||
Patch19: cyrus-sasl-2.1.21-openssl-098.patch
|
Patch21: cyrus-sasl-2.1.22-no-static-deps.patch
|
||||||
Patch20: cyrus-sasl-2.1.21-openldap-2.3.patch
|
|
||||||
Patch21: cyrus-sasl-2.1.21-no-static-deps.patch
|
|
||||||
Patch22: cyrus-sasl-2.1.21-gssapi-generic.patch
|
Patch22: cyrus-sasl-2.1.21-gssapi-generic.patch
|
||||||
Patch23: cyrus-sasl-2.1.19-omit_realm.patch
|
Patch23: cyrus-sasl-2.1.19-omit_realm.patch
|
||||||
Patch24: cyrus-sasl-2.1.21-sizes.patch
|
Patch24: cyrus-sasl-2.1.21-sizes.patch
|
||||||
@ -140,10 +138,8 @@ popd
|
|||||||
%patch13 -p1 -b .notgnu
|
%patch13 -p1 -b .notgnu
|
||||||
%patch14 -p1 -b .conflict
|
%patch14 -p1 -b .conflict
|
||||||
%patch15 -p1 -b .path
|
%patch15 -p1 -b .path
|
||||||
%patch17 -p1 -b .builddir
|
%patch16 -p1 -b .builddir
|
||||||
%patch18 -p1 -b .linksrcs
|
%patch18 -p1 -b .linksrcs
|
||||||
%patch19 -p1 -b .openssl-098
|
|
||||||
%patch20 -p1 -b .openldap-2.3
|
|
||||||
%patch21 -p1 -b .no-static-deps
|
%patch21 -p1 -b .no-static-deps
|
||||||
%patch22 -p1 -b .gssapi-generic
|
%patch22 -p1 -b .gssapi-generic
|
||||||
#%patch23 -p1 -b .omit_realm
|
#%patch23 -p1 -b .omit_realm
|
||||||
@ -233,6 +229,7 @@ shift
|
|||||||
--enable-shared --enable-static \
|
--enable-shared --enable-static \
|
||||||
--disable-java \
|
--disable-java \
|
||||||
--with-plugindir=%{_plugindir2} \
|
--with-plugindir=%{_plugindir2} \
|
||||||
|
--with-configdir=%{_plugindir2}:%{_sysconfdir}/sasl2 \
|
||||||
--disable-krb4 \
|
--disable-krb4 \
|
||||||
--enable-gssapi${krb5_prefix:+=${krb5_prefix}} \
|
--enable-gssapi${krb5_prefix:+=${krb5_prefix}} \
|
||||||
--with-gss_impl=mit \
|
--with-gss_impl=mit \
|
||||||
@ -257,6 +254,7 @@ shift
|
|||||||
# --enable-auth-sasldb -- EXPERIMENTAL
|
# --enable-auth-sasldb -- EXPERIMENTAL
|
||||||
make sasldir=%{_plugindir2}
|
make sasldir=%{_plugindir2}
|
||||||
make -C saslauthd testsaslauthd
|
make -C saslauthd testsaslauthd
|
||||||
|
make -C sample
|
||||||
popd
|
popd
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -313,6 +311,10 @@ install -m755 -d $RPM_BUILD_ROOT/etc/rc.d/init.d $RPM_BUILD_ROOT/etc/sysconfig
|
|||||||
install -m755 $RPM_SOURCE_DIR/saslauthd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
|
install -m755 $RPM_SOURCE_DIR/saslauthd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
|
||||||
install -m644 $RPM_SOURCE_DIR/saslauthd.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
|
install -m644 $RPM_SOURCE_DIR/saslauthd.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
|
||||||
|
|
||||||
|
# Install the config dirs if they're not already there.
|
||||||
|
install -m755 -d $RPM_BUILD_ROOT/%{_sysconfdir}/sasl2
|
||||||
|
install -m755 -d $RPM_BUILD_ROOT/%{_plugindir2}
|
||||||
|
|
||||||
# Provide an easy way to query the list of available mechanisms.
|
# Provide an easy way to query the list of available mechanisms.
|
||||||
libtool --mode=install \
|
libtool --mode=install \
|
||||||
install -m755 build-static/lib/sasl2-static-mechlist \
|
install -m755 build-static/lib/sasl2-static-mechlist \
|
||||||
@ -354,6 +356,7 @@ fi
|
|||||||
%{_plugindir2}/*sasldb*.la
|
%{_plugindir2}/*sasldb*.la
|
||||||
%{_mandir}/man8/*
|
%{_mandir}/man8/*
|
||||||
%{_sbindir}/dbconverter-2
|
%{_sbindir}/dbconverter-2
|
||||||
|
%{_sbindir}/pluginviewer
|
||||||
%{_sbindir}/saslpasswd2
|
%{_sbindir}/saslpasswd2
|
||||||
%{_sbindir}/sasldblistusers2
|
%{_sbindir}/sasldblistusers2
|
||||||
%{_sbindir}/saslauthd
|
%{_sbindir}/saslauthd
|
||||||
@ -366,6 +369,7 @@ fi
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc AUTHORS COPYING NEWS README doc/*.html
|
%doc AUTHORS COPYING NEWS README doc/*.html
|
||||||
%{_libdir}/libsasl*.so.*
|
%{_libdir}/libsasl*.so.*
|
||||||
|
%dir %{_sysconfdir}/sasl2
|
||||||
%dir %{_plugindir2}/
|
%dir %{_plugindir2}/
|
||||||
%{_plugindir2}/*anonymous*.so*
|
%{_plugindir2}/*anonymous*.so*
|
||||||
%{_plugindir2}/*anonymous*.la
|
%{_plugindir2}/*anonymous*.la
|
||||||
@ -417,6 +421,9 @@ fi
|
|||||||
%{_sbindir}/sasl2-shared-mechlist
|
%{_sbindir}/sasl2-shared-mechlist
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 22 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.22-1
|
||||||
|
- update to 2.1.22, adding pluginviewer to %%{_sbindir}
|
||||||
|
|
||||||
* Tue May 16 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.21-12
|
* Tue May 16 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.21-12
|
||||||
- add conditionalized build dependency on openldap-devel (#191855)
|
- add conditionalized build dependency on openldap-devel (#191855)
|
||||||
- patch md5global.h to be the same on all architectures
|
- patch md5global.h to be the same on all architectures
|
||||||
|
Loading…
Reference in New Issue
Block a user