a3910120e8
- Update to 3.0.3, which contains an important security fix. The fix is not embargoed but no CVE has been assigned yet. - Drop patches merged upstream. - An update of imaptest has resulted in three additional cassandane failures, reported upstream as https://github.com/cyrusimap/cyrus-imapd/issues/2087. In order to get the security fix out without delay, those three tests have been disabled.
14 lines
872 B
Plaintext
14 lines
872 B
Plaintext
diff --git a/perl/sieve/managesieve/Makefile.PL.in b/perl/sieve/managesieve/Makefile.PL.in
|
|
index 2bb715d..422504d 100644
|
|
--- a/perl/sieve/managesieve/Makefile.PL.in
|
|
+++ b/perl/sieve/managesieve/Makefile.PL.in
|
|
@@ -69,7 +69,7 @@ WriteMakefile(
|
|
'ABSTRACT' => 'Cyrus Sieve management interface',
|
|
'VERSION_FROM' => "@top_srcdir@/perl/sieve/managesieve/managesieve.pm", # finds $VERSION
|
|
'MYEXTLIB' => '../lib/.libs/libisieve.a @top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
|
|
- 'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@"],
|
|
+ 'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@ -lsqlite3 -lpq"],
|
|
'CCFLAGS' => '@GCOV_CFLAGS@',
|
|
'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
|
|
'INC' => "-I@top_srcdir@/lib -I@top_srcdir@/perl/sieve -I@top_srcdir@/perl/sieve/lib @SASLFLAGS@ @SSL_CPPFLAGS@",
|