b2c08d2974
- Re-enable --as-needed, now that PCRE has been patched. - Add workaround for improper linking of some Perl modules.
27 lines
1.6 KiB
Plaintext
27 lines
1.6 KiB
Plaintext
diff --git a/perl/imap/Makefile.PL.in b/perl/imap/Makefile.PL.in
|
|
index a0fda4a..5fb0f1f 100644
|
|
--- a/perl/imap/Makefile.PL.in
|
|
+++ b/perl/imap/Makefile.PL.in
|
|
@@ -89,7 +89,7 @@ WriteMakefile(
|
|
},
|
|
'clean' => {'FILES' => 'libcyrperl.a cyradm'},
|
|
'OBJECT' => 'IMAP.o',
|
|
- 'MYEXTLIB' => '@top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
|
|
+ 'MYEXTLIB' => '@top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a -lpcreposix',
|
|
'LIBS' => [ "$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@"],
|
|
'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
|
|
'INC' => "-I@top_srcdir@ -I@top_srcdir@/com_err/et @SASLFLAGS@ @SSL_CPPFLAGS@ -I@top_srcdir@/perl/imap",
|
|
diff --git a/perl/sieve/managesieve/Makefile.PL.in b/perl/sieve/managesieve/Makefile.PL.in
|
|
index 2a3415a..f2a2592 100644
|
|
--- a/perl/sieve/managesieve/Makefile.PL.in
|
|
+++ b/perl/sieve/managesieve/Makefile.PL.in
|
|
@@ -68,7 +68,7 @@ WriteMakefile(
|
|
'NAME' => 'Cyrus::SIEVE::managesieve',
|
|
'ABSTRACT' => 'Cyrus Sieve management interface',
|
|
'VERSION_FROM' => "@top_srcdir@/perl/sieve/managesieve/managesieve.pm", # finds $VERSION
|
|
- 'MYEXTLIB' => '../lib/.libs/libisieve.a @top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
|
|
+ 'MYEXTLIB' => '../lib/.libs/libisieve.a @top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a -lpcreposix',
|
|
'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@ @SQLITE_LIBADD@ @MYSQL_LIBADD@ @PGSQL_LIBADD@"],
|
|
'CCFLAGS' => '@GCOV_CFLAGS@',
|
|
'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
|