Update Perl linking patch.
This commit is contained in:
parent
31f345edd4
commit
a977a86703
@ -9,7 +9,7 @@
|
|||||||
|
|
||||||
Name: cyrus-imapd
|
Name: cyrus-imapd
|
||||||
Version: 3.0.8
|
Version: 3.0.8
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
|
|
||||||
%define ssl_pem_file /etc/pki/%name/%name.pem
|
%define ssl_pem_file /etc/pki/%name/%name.pem
|
||||||
|
|
||||||
@ -47,7 +47,7 @@ Patch3: patch-vzic-proper-cflags
|
|||||||
# https://github.com/cyrusimap/cyrus-imapd/issues/2621
|
# https://github.com/cyrusimap/cyrus-imapd/issues/2621
|
||||||
Patch4: patch-clamav101
|
Patch4: patch-clamav101
|
||||||
|
|
||||||
# Ugly workaround for some compiled Perl modules not being linked against
|
# Workaround for some compiled Perl modules not being linked against
|
||||||
# libpcreposix, which causes them to fail to load.
|
# libpcreposix, which causes them to fail to load.
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1668723
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1668723
|
||||||
# https://github.com/cyrusimap/cyrus-imapd/issues/2629#issuecomment-456925909
|
# https://github.com/cyrusimap/cyrus-imapd/issues/2629#issuecomment-456925909
|
||||||
@ -690,6 +690,9 @@ getent passwd cyrus >/dev/null || /usr/sbin/useradd -c "Cyrus IMAP Server" -d /v
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 24 2019 Jason L Tibbitts III <tibbs@math.uh.edu> - 3.0.8-8
|
||||||
|
- Update Perl linkage patch.
|
||||||
|
|
||||||
* Wed Jan 23 2019 Pete Walter <pwalter@fedoraproject.org> - 3.0.8-7
|
* Wed Jan 23 2019 Pete Walter <pwalter@fedoraproject.org> - 3.0.8-7
|
||||||
- Rebuild for ICU 63
|
- Rebuild for ICU 63
|
||||||
|
|
||||||
|
@ -1,26 +1,26 @@
|
|||||||
diff --git a/perl/imap/Makefile.PL.in b/perl/imap/Makefile.PL.in
|
diff --git a/perl/imap/Makefile.PL.in b/perl/imap/Makefile.PL.in
|
||||||
index a0fda4a..5fb0f1f 100644
|
index a0fda4a..df71c0c 100644
|
||||||
--- a/perl/imap/Makefile.PL.in
|
--- a/perl/imap/Makefile.PL.in
|
||||||
+++ b/perl/imap/Makefile.PL.in
|
+++ b/perl/imap/Makefile.PL.in
|
||||||
@@ -89,7 +89,7 @@ WriteMakefile(
|
@@ -90,7 +90,7 @@ WriteMakefile(
|
||||||
},
|
|
||||||
'clean' => {'FILES' => 'libcyrperl.a cyradm'},
|
'clean' => {'FILES' => 'libcyrperl.a cyradm'},
|
||||||
'OBJECT' => 'IMAP.o',
|
'OBJECT' => 'IMAP.o',
|
||||||
- 'MYEXTLIB' => '@top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
|
'MYEXTLIB' => '@top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
|
||||||
+ 'MYEXTLIB' => '@top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a -lpcreposix',
|
- 'LIBS' => [ "$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@"],
|
||||||
'LIBS' => [ "$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@"],
|
+ 'LIBS' => [ "$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@ -lpcreposix"],
|
||||||
'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
|
'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
|
||||||
'INC' => "-I@top_srcdir@ -I@top_srcdir@/com_err/et @SASLFLAGS@ @SSL_CPPFLAGS@ -I@top_srcdir@/perl/imap",
|
'INC' => "-I@top_srcdir@ -I@top_srcdir@/com_err/et @SASLFLAGS@ @SSL_CPPFLAGS@ -I@top_srcdir@/perl/imap",
|
||||||
|
'EXE_FILES' => [cyradm],
|
||||||
diff --git a/perl/sieve/managesieve/Makefile.PL.in b/perl/sieve/managesieve/Makefile.PL.in
|
diff --git a/perl/sieve/managesieve/Makefile.PL.in b/perl/sieve/managesieve/Makefile.PL.in
|
||||||
index 2a3415a..f2a2592 100644
|
index 2a3415a..67fb2d1 100644
|
||||||
--- a/perl/sieve/managesieve/Makefile.PL.in
|
--- a/perl/sieve/managesieve/Makefile.PL.in
|
||||||
+++ b/perl/sieve/managesieve/Makefile.PL.in
|
+++ b/perl/sieve/managesieve/Makefile.PL.in
|
||||||
@@ -68,7 +68,7 @@ WriteMakefile(
|
@@ -69,7 +69,7 @@ WriteMakefile(
|
||||||
'NAME' => 'Cyrus::SIEVE::managesieve',
|
|
||||||
'ABSTRACT' => 'Cyrus Sieve management interface',
|
'ABSTRACT' => 'Cyrus Sieve management interface',
|
||||||
'VERSION_FROM' => "@top_srcdir@/perl/sieve/managesieve/managesieve.pm", # finds $VERSION
|
'VERSION_FROM' => "@top_srcdir@/perl/sieve/managesieve/managesieve.pm", # finds $VERSION
|
||||||
- 'MYEXTLIB' => '../lib/.libs/libisieve.a @top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
|
'MYEXTLIB' => '../lib/.libs/libisieve.a @top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
|
||||||
+ 'MYEXTLIB' => '../lib/.libs/libisieve.a @top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a -lpcreposix',
|
- 'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@ @SQLITE_LIBADD@ @MYSQL_LIBADD@ @PGSQL_LIBADD@"],
|
||||||
'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@ @SQLITE_LIBADD@ @MYSQL_LIBADD@ @PGSQL_LIBADD@"],
|
+ 'LIBS' => ["$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@ @SQLITE_LIBADD@ @MYSQL_LIBADD@ @PGSQL_LIBADD@ -lpcreposix"],
|
||||||
'CCFLAGS' => '@GCOV_CFLAGS@',
|
'CCFLAGS' => '@GCOV_CFLAGS@',
|
||||||
'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
|
'DEFINE' => '-DPERL_POLLUTE', # e.g., '-DHAVE_SOMETHING'
|
||||||
|
'INC' => "-I@top_srcdir@/lib -I@top_srcdir@/perl/sieve -I@top_srcdir@/perl/sieve/lib @SASLFLAGS@ @SSL_CPPFLAGS@",
|
||||||
|
Loading…
Reference in New Issue
Block a user