Fix a couple of open tickets.

Add patch to fix imtest (rhbz#1543481).
Fix vzic makefile to use proper cflags (rhbz#1550543).
This commit is contained in:
Jason Tibbitts 2018-03-01 12:55:25 -06:00
parent e58c32913f
commit 0387a93271
3 changed files with 67 additions and 1 deletions

View File

@ -0,0 +1,29 @@
From 7214a7e3a60c628575a73dab0437e065b9e9a32a Mon Sep 17 00:00:00 2001
From: Pavel Zhukov <pzhukov@redhat.com>
Date: Tue, 27 Feb 2018 09:48:13 +0100
Subject: [PATCH] Check if mechlist buffer is not empty
Check if mechlist is null is redundant because it's initialized in
ask_capabilities flow. As the result some capabilities may be lost and
reported as not advertised
Keeping (now reduntant) null check to avoid regressions in the future
This is regression in 9fd201ba2b4ab58eda3372fb6765e1d5d8f027b4
Bug-Url: https://bugzilla.redhat.com/1543481
---
imtest/imtest.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/imtest/imtest.c b/imtest/imtest.c
index 716e2b252..85f4cc5ce 100644
--- a/imtest/imtest.c
+++ b/imtest/imtest.c
@@ -3084,7 +3084,7 @@ int main(int argc, char **argv)
/* try to get the capabilities from the banner */
mechlist = ask_capability(protocol, servername,
&capabilities, AUTO_BANNER);
- if (!mechlist && !(capabilities & CAPA_STARTTLS)) {
+ if ((!mechlist || !buf_len(mechlist)) && !(capabilities & CAPA_STARTTLS)) {
/* found no capabilities in banner -> get them explicitly */
protocol->banner.is_capa = 0;
}

View File

@ -9,7 +9,7 @@
Name: cyrus-imapd
Version: 3.0.5
Release: 6%{?dist}
Release: 7%{?dist}
%define ssl_pem_file /etc/pki/%name/%name.pem
@ -45,6 +45,14 @@ Patch5: https://github.com/elliefm/cyrus-imapd/commit/79244173353d95149ad1944f61
# Fix squatter segfaults seen on rawhide.
Patch6: https://github.com/cyrusimap/cyrus-imapd/commit/24af24aa77144e0c1ab976657833b470502be7a8.patch
# Fix imtest -m gssapi on some servers.
# https://bugzilla.redhat.com/show_bug.cgi?id=1543481
# https://github.com/cyrusimap/cyrus-imapd/pull/2268
Patch7: https://github.com/cyrusimap/cyrus-imapd/commit/7214a7e3a60c628575a73dab0437e065b9e9a32a.patch
# vzic uses an old makefile that needs hacks to use the proper flags
Patch8: patch-vzic-proper-cflags
Source10: cyrus-imapd.logrotate
Source11: cyrus-imapd.pam-config
Source12: cyrus-imapd.sysconfig
@ -630,6 +638,10 @@ getent passwd cyrus >/dev/null || /usr/sbin/useradd -c "Cyrus IMAP Server" -d /v
%changelog
* Thu Mar 01 2018 Jason L Tibbitts III <tibbs@math.uh.edu> - 3.0.5-7
- Add patch to fix imtest (rhbz#1543481).
- Fix vzic makefile to use proper cflags (rhbz#1550543).
* Mon Feb 26 2018 Jason L Tibbitts III <tibbs@math.uh.edu> - 3.0.5-6
- Update cassandane checkout.
- Add two new build dependencies.

25
patch-vzic-proper-cflags Normal file
View File

@ -0,0 +1,25 @@
diff --git a/tools/vzic/Makefile b/tools/vzic/Makefile
index 8ae6afa..3882998 100644
--- a/tools/vzic/Makefile
+++ b/tools/vzic/Makefile
@@ -45,17 +45,17 @@ LIBICAL_LDADD = -lical
GLIB_CFLAGS = `pkg-config --cflags glib-2.0`
GLIB_LDADD = `pkg-config --libs glib-2.0`
-CFLAGS = -g -I../.. -DOLSON_DIR=\"$(OLSON_DIR)\" -DPRODUCT_ID='"$(PRODUCT_ID)"' -DTZID_PREFIX='"$(TZID_PREFIX)"' $(GLIB_CFLAGS) $(LIBICAL_CFLAGS)
+CFLAGS += -I../.. -DOLSON_DIR=\"$(OLSON_DIR)\" -DPRODUCT_ID='"$(PRODUCT_ID)"' -DTZID_PREFIX='"$(TZID_PREFIX)"' $(GLIB_CFLAGS) $(LIBICAL_CFLAGS)
OBJECTS = vzic.o vzic-parse.o vzic-dump.o vzic-output.o
all: vzic
vzic: $(OBJECTS)
- $(CC) $(OBJECTS) $(GLIB_LDADD) -o vzic
+ $(CC) $(LDFLAGS) $(OBJECTS) $(GLIB_LDADD) -o vzic
test-vzic: test-vzic.o
- $(CC) test-vzic.o $(LIBICAL_LDADD) -o test-vzic
+ $(CC) $(LDFLAGS) test-vzic.o $(LIBICAL_LDADD) -o test-vzic
# Dependencies.
$(OBJECTS): vzic.h