- add missing quote in libcurl.m4 (#576252)
This commit is contained in:
parent
f83e9bb439
commit
ff7d0c62dc
@ -1,23 +1,8 @@
|
||||
From df39ccc590abcfa275907ce8ed259fb11da33623 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Thu, 18 Mar 2010 22:07:21 +0100
|
||||
Subject: [PATCH 2/2] throw CURLE_SSL_CERTPROBLEM in case peer rejects a cert
|
||||
|
||||
... supported only by NSS for now. It may be extended for OpenSSL at
|
||||
some point if anybody helps with deciphering of its error codes.
|
||||
|
||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
||||
---
|
||||
lib/nss.c | 30 ++++++++++++++++++++++++++++--
|
||||
lib/sendf.c | 18 ++++++++++++------
|
||||
lib/urldata.h | 3 +++
|
||||
3 files changed, 43 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/lib/nss.c b/lib/nss.c
|
||||
index 9dd84a2..a5523dc 100644
|
||||
index 2366c57..2c029c4 100644
|
||||
--- a/lib/nss.c
|
||||
+++ b/lib/nss.c
|
||||
@@ -1341,6 +1341,29 @@ CURLcode Curl_nss_connect(struct connectdata *conn, int sockindex)
|
||||
@@ -1337,6 +1337,29 @@ error:
|
||||
return curlerr;
|
||||
}
|
||||
|
||||
@ -47,7 +32,7 @@ index 9dd84a2..a5523dc 100644
|
||||
/* return number of sent (non-SSL) bytes */
|
||||
int Curl_nss_send(struct connectdata *conn, /* connection data */
|
||||
int sockindex, /* socketindex */
|
||||
@@ -1352,7 +1375,9 @@ int Curl_nss_send(struct connectdata *conn, /* connection data */
|
||||
@@ -1348,7 +1371,9 @@ int Curl_nss_send(struct connectdata *conn, /* connection data */
|
||||
rc = PR_Send(conn->ssl[sockindex].handle, mem, (int)len, 0, -1);
|
||||
|
||||
if(rc < 0) {
|
||||
@ -58,7 +43,7 @@ index 9dd84a2..a5523dc 100644
|
||||
return -1;
|
||||
}
|
||||
return rc; /* number of bytes */
|
||||
@@ -1381,7 +1406,8 @@ ssize_t Curl_nss_recv(struct connectdata * conn, /* connection data */
|
||||
@@ -1377,7 +1402,8 @@ ssize_t Curl_nss_recv(struct connectdata * conn, /* connection data */
|
||||
*wouldblock = TRUE;
|
||||
return -1; /* basically EWOULDBLOCK */
|
||||
}
|
||||
@ -129,6 +114,3 @@ index d03146a..c24a450 100644
|
||||
#ifdef USE_SSLEAY
|
||||
/* these ones requires specific SSL-types */
|
||||
SSL_CTX* ctx;
|
||||
--
|
||||
1.7.0.2
|
||||
|
||||
|
13
curl-7.20.0-m4-typo.patch
Normal file
13
curl-7.20.0-m4-typo.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/docs/libcurl/libcurl.m4 b/docs/libcurl/libcurl.m4
|
||||
index ce8e476..50dc20d 100644
|
||||
--- a/docs/libcurl/libcurl.m4
|
||||
+++ b/docs/libcurl/libcurl.m4
|
||||
@@ -198,7 +198,7 @@ x=CURLOPT_VERBOSE;
|
||||
|
||||
# We don't have --protocols, so just assume that all
|
||||
# protocols are available
|
||||
- _libcurl_protocols="HTTP FTP FILE TELNET LDAP DICT TFTP
|
||||
+ _libcurl_protocols="HTTP FTP FILE TELNET LDAP DICT TFTP"
|
||||
|
||||
if test x$libcurl_feature_SSL = xyes ; then
|
||||
_libcurl_protocols="$_libcurl_protocols HTTPS"
|
30
curl.spec
30
curl.spec
@ -1,17 +1,20 @@
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.20.0
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: MIT
|
||||
Group: Applications/Internet
|
||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
|
||||
Source2: curlbuild.h
|
||||
|
||||
# bz #576252
|
||||
Patch0: curl-7.20.0-m4-typo.patch
|
||||
|
||||
# http://permalink.gmane.org/gmane.comp.web.curl.library/27110
|
||||
Patch0: curl-7.20.0-read.patch
|
||||
Patch1: curl-7.20.0-read.patch
|
||||
|
||||
# http://permalink.gmane.org/gmane.comp.web.curl.library/27111
|
||||
Patch1: curl-7.20.0-cc-err.patch
|
||||
Patch2: curl-7.20.0-cc-err.patch
|
||||
|
||||
# patch making libcurl multilib ready (by excluding static libraries)
|
||||
Patch101: curl-7.15.3-multilib.patch
|
||||
@ -98,10 +101,20 @@ use cURL's capabilities internally.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
# upstream patches (not yet applied)
|
||||
# Convert docs to UTF-8
|
||||
# NOTE: we do this _before_ applying of all patches, which are already UTF-8
|
||||
for f in CHANGES README; do
|
||||
iconv -f iso-8859-1 -t utf8 < ${f} > ${f}.utf8
|
||||
mv -f ${f}.utf8 ${f}
|
||||
done
|
||||
|
||||
# upstream patches (already applied)
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
# upstream patches (not yet applied)
|
||||
%patch2 -p1
|
||||
|
||||
# Fedora patches
|
||||
%patch101 -p1
|
||||
%patch102 -p1
|
||||
@ -122,12 +135,6 @@ autoreconf
|
||||
# replace hard wired port numbers in the test suite
|
||||
sed -i s/899\\\([0-9]\\\)/%{?__isa_bits}9\\1/ tests/data/test*
|
||||
|
||||
# Convert docs to UTF-8
|
||||
for f in CHANGES README; do
|
||||
iconv -f iso-8859-1 -t utf8 < ${f} > ${f}.utf8
|
||||
mv -f ${f}.utf8 ${f}
|
||||
done
|
||||
|
||||
%build
|
||||
%configure --disable-static \
|
||||
--enable-ares \
|
||||
@ -219,6 +226,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/aclocal/libcurl.m4
|
||||
|
||||
%changelog
|
||||
* Tue Mar 23 2010 Kamil Dudka <kdudka@redhat.com> 7.20.0-4
|
||||
- add missing quote in libcurl.m4 (#576252)
|
||||
|
||||
* Fri Mar 19 2010 Kamil Dudka <kdudka@redhat.com> 7.20.0-3
|
||||
- throw CURLE_SSL_CERTPROBLEM in case peer rejects a certificate (#565972)
|
||||
- valgrind temporarily disabled (#574889)
|
||||
|
Loading…
Reference in New Issue
Block a user