new upstream release - 7.68.0
This commit is contained in:
parent
13f70ceee2
commit
dfb411a0a2
@ -1,316 +0,0 @@
|
||||
From 37a36231c5e34ae31b1968481fad2e8d76613fbd Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Stenberg <daniel@haxx.se>
|
||||
Date: Wed, 13 Nov 2019 11:33:29 +0100
|
||||
Subject: [PATCH] curl: fix -T globbing
|
||||
|
||||
Regression from e59371a4936f8 (7.67.0)
|
||||
|
||||
Added test 490, 491 and 492 to verify the functionality.
|
||||
|
||||
Reported-by: Kamil Dudka
|
||||
Reported-by: Anderson Sasaki
|
||||
|
||||
Fixes #4588
|
||||
Closes #4591
|
||||
|
||||
Upstream-commit: 7a46aeb0be3fa00826b0c47a8bc06eddff448659
|
||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
||||
---
|
||||
src/tool_operate.c | 15 ++++---
|
||||
tests/data/Makefile.inc | 2 +
|
||||
tests/data/test490 | 68 +++++++++++++++++++++++++++++++
|
||||
tests/data/test491 | 64 +++++++++++++++++++++++++++++
|
||||
tests/data/test492 | 89 +++++++++++++++++++++++++++++++++++++++++
|
||||
5 files changed, 232 insertions(+), 6 deletions(-)
|
||||
create mode 100644 tests/data/test490
|
||||
create mode 100644 tests/data/test491
|
||||
create mode 100644 tests/data/test492
|
||||
|
||||
diff --git a/src/tool_operate.c b/src/tool_operate.c
|
||||
index 3087d2d..4ecb1ed 100644
|
||||
--- a/src/tool_operate.c
|
||||
+++ b/src/tool_operate.c
|
||||
@@ -829,12 +829,6 @@ static CURLcode single_transfer(struct GlobalConfig *global,
|
||||
separator = ((!state->outfiles ||
|
||||
!strcmp(state->outfiles, "-")) && urlnum > 1);
|
||||
|
||||
- /* Here's looping around each globbed URL */
|
||||
-
|
||||
- if(state->li >= urlnum) {
|
||||
- state->li = 0;
|
||||
- state->up++;
|
||||
- }
|
||||
if(state->up < state->infilenum) {
|
||||
struct per_transfer *per;
|
||||
struct OutStruct *outs;
|
||||
@@ -1908,6 +1902,15 @@ static CURLcode single_transfer(struct GlobalConfig *global,
|
||||
per->retrystart = tvnow();
|
||||
|
||||
state->li++;
|
||||
+ /* Here's looping around each globbed URL */
|
||||
+ if(state->li >= urlnum) {
|
||||
+ state->li = 0;
|
||||
+ state->urlnum = 0; /* forced reglob of URLs */
|
||||
+ glob_cleanup(state->urls);
|
||||
+ state->urls = NULL;
|
||||
+ state->up++;
|
||||
+ Curl_safefree(state->uploadfile); /* clear it to get the next */
|
||||
+ }
|
||||
}
|
||||
else {
|
||||
/* Free this URL node data without destroying the
|
||||
diff --git a/tests/data/Makefile.inc b/tests/data/Makefile.inc
|
||||
index 557f928..212900e 100644
|
||||
--- a/tests/data/Makefile.inc
|
||||
+++ b/tests/data/Makefile.inc
|
||||
@@ -66,6 +66,8 @@ test393 test394 test395 \
|
||||
test400 test401 test402 test403 test404 test405 test406 test407 test408 \
|
||||
test409 \
|
||||
\
|
||||
+test490 test491 test492 \
|
||||
+\
|
||||
test500 test501 test502 test503 test504 test505 test506 test507 test508 \
|
||||
test509 test510 test511 test512 test513 test514 test515 test516 test517 \
|
||||
test518 test519 test520 test521 test522 test523 test524 test525 test526 \
|
||||
diff --git a/tests/data/test490 b/tests/data/test490
|
||||
new file mode 100644
|
||||
index 0000000..a3383a9
|
||||
--- /dev/null
|
||||
+++ b/tests/data/test490
|
||||
@@ -0,0 +1,68 @@
|
||||
+<testcase>
|
||||
+<info>
|
||||
+<keywords>
|
||||
+HTTP
|
||||
+HTTP PUT
|
||||
+</keywords>
|
||||
+</info>
|
||||
+
|
||||
+#
|
||||
+# Server-side
|
||||
+<reply>
|
||||
+<data>
|
||||
+HTTP/1.1 200 OK
|
||||
+Date: Thu, 09 Nov 2010 14:49:00 GMT
|
||||
+Server: test-server/fake
|
||||
+Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
|
||||
+ETag: "21025-dc7-39462498"
|
||||
+Accept-Ranges: bytes
|
||||
+Content-Length: 6
|
||||
+Connection: close
|
||||
+Content-Type: text/html
|
||||
+Funny-head: yesyes
|
||||
+
|
||||
+-foo-
|
||||
+</data>
|
||||
+</reply>
|
||||
+
|
||||
+#
|
||||
+# Client-side
|
||||
+<client>
|
||||
+<server>
|
||||
+http
|
||||
+</server>
|
||||
+ <name>
|
||||
+Two globbed HTTP PUTs
|
||||
+ </name>
|
||||
+ <command>
|
||||
+http://%HOSTIP:%HTTPPORT/490 -T '{log/in490,log/in490}'
|
||||
+</command>
|
||||
+<file name="log/in490">
|
||||
+surprise!
|
||||
+</file>
|
||||
+</client>
|
||||
+
|
||||
+#
|
||||
+# Verify data after the test has been "shot"
|
||||
+<verify>
|
||||
+<strip>
|
||||
+^User-Agent:.*
|
||||
+</strip>
|
||||
+<protocol>
|
||||
+PUT /490 HTTP/1.1
|
||||
+Host: 127.0.0.1:8990
|
||||
+Accept: */*
|
||||
+Content-Length: 10
|
||||
+Expect: 100-continue
|
||||
+
|
||||
+surprise!
|
||||
+PUT /490 HTTP/1.1
|
||||
+Host: 127.0.0.1:8990
|
||||
+Accept: */*
|
||||
+Content-Length: 10
|
||||
+Expect: 100-continue
|
||||
+
|
||||
+surprise!
|
||||
+</protocol>
|
||||
+</verify>
|
||||
+</testcase>
|
||||
diff --git a/tests/data/test491 b/tests/data/test491
|
||||
new file mode 100644
|
||||
index 0000000..b49c06c
|
||||
--- /dev/null
|
||||
+++ b/tests/data/test491
|
||||
@@ -0,0 +1,64 @@
|
||||
+<testcase>
|
||||
+<info>
|
||||
+<keywords>
|
||||
+HTTP
|
||||
+HTTP PUT
|
||||
+</keywords>
|
||||
+</info>
|
||||
+
|
||||
+#
|
||||
+# Server-side
|
||||
+<reply>
|
||||
+<data>
|
||||
+HTTP/1.1 200 OK
|
||||
+Date: Thu, 09 Nov 2010 14:49:00 GMT
|
||||
+Server: test-server/fake
|
||||
+Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
|
||||
+ETag: "21025-dc7-39462498"
|
||||
+Accept-Ranges: bytes
|
||||
+Content-Length: 6
|
||||
+Connection: close
|
||||
+Content-Type: text/html
|
||||
+Funny-head: yesyes
|
||||
+
|
||||
+-foo-
|
||||
+</data>
|
||||
+</reply>
|
||||
+
|
||||
+#
|
||||
+# Client-side
|
||||
+<client>
|
||||
+<server>
|
||||
+http
|
||||
+</server>
|
||||
+ <name>
|
||||
+Two globbed HTTP PUTs, the second upload file is missing
|
||||
+ </name>
|
||||
+ <command>
|
||||
+http://%HOSTIP:%HTTPPORT/491 -T '{log/in491,log/bad491}'
|
||||
+</command>
|
||||
+<file name="log/in491">
|
||||
+surprise!
|
||||
+</file>
|
||||
+</client>
|
||||
+
|
||||
+#
|
||||
+# Verify data after the test has been "shot"
|
||||
+<verify>
|
||||
+<strip>
|
||||
+^User-Agent:.*
|
||||
+</strip>
|
||||
+<protocol>
|
||||
+PUT /491 HTTP/1.1
|
||||
+Host: 127.0.0.1:8990
|
||||
+Accept: */*
|
||||
+Content-Length: 10
|
||||
+Expect: 100-continue
|
||||
+
|
||||
+surprise!
|
||||
+</protocol>
|
||||
+<errorcode>
|
||||
+26
|
||||
+</errorcode>
|
||||
+</verify>
|
||||
+</testcase>
|
||||
diff --git a/tests/data/test492 b/tests/data/test492
|
||||
new file mode 100644
|
||||
index 0000000..12edd8b
|
||||
--- /dev/null
|
||||
+++ b/tests/data/test492
|
||||
@@ -0,0 +1,89 @@
|
||||
+<testcase>
|
||||
+<info>
|
||||
+<keywords>
|
||||
+HTTP
|
||||
+HTTP PUT
|
||||
+</keywords>
|
||||
+</info>
|
||||
+
|
||||
+#
|
||||
+# Server-side
|
||||
+<reply>
|
||||
+<data>
|
||||
+HTTP/1.1 200 OK
|
||||
+Date: Thu, 09 Nov 2010 14:49:00 GMT
|
||||
+Server: test-server/fake
|
||||
+Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
|
||||
+ETag: "21025-dc7-39462498"
|
||||
+Accept-Ranges: bytes
|
||||
+Content-Length: 6
|
||||
+Connection: close
|
||||
+Content-Type: text/html
|
||||
+Funny-head: yesyes
|
||||
+
|
||||
+-foo-
|
||||
+</data>
|
||||
+</reply>
|
||||
+
|
||||
+#
|
||||
+# Client-side
|
||||
+<client>
|
||||
+<server>
|
||||
+http
|
||||
+</server>
|
||||
+ <name>
|
||||
+Two globbed HTTP PUTs to two globbed URLs
|
||||
+ </name>
|
||||
+ <command>
|
||||
+'http://%HOSTIP:%HTTPPORT/{one,two}/' -T '{log/first492,log/second492}' -H "Testno: 492"
|
||||
+</command>
|
||||
+<file name="log/first492">
|
||||
+first 492 contents
|
||||
+</file>
|
||||
+<file1 name="log/second492">
|
||||
+second 492 contents
|
||||
+</file1>
|
||||
+</client>
|
||||
+
|
||||
+#
|
||||
+# Verify data after the test has been "shot"
|
||||
+<verify>
|
||||
+<strip>
|
||||
+^User-Agent:.*
|
||||
+</strip>
|
||||
+<protocol>
|
||||
+PUT /one/first492 HTTP/1.1
|
||||
+Host: 127.0.0.1:8990
|
||||
+Accept: */*
|
||||
+Testno: 492
|
||||
+Content-Length: 19
|
||||
+Expect: 100-continue
|
||||
+
|
||||
+first 492 contents
|
||||
+PUT /two/first492 HTTP/1.1
|
||||
+Host: 127.0.0.1:8990
|
||||
+Accept: */*
|
||||
+Testno: 492
|
||||
+Content-Length: 19
|
||||
+Expect: 100-continue
|
||||
+
|
||||
+first 492 contents
|
||||
+PUT /one/second492 HTTP/1.1
|
||||
+Host: 127.0.0.1:8990
|
||||
+Accept: */*
|
||||
+Testno: 492
|
||||
+Content-Length: 20
|
||||
+Expect: 100-continue
|
||||
+
|
||||
+second 492 contents
|
||||
+PUT /two/second492 HTTP/1.1
|
||||
+Host: 127.0.0.1:8990
|
||||
+Accept: */*
|
||||
+Testno: 492
|
||||
+Content-Length: 20
|
||||
+Expect: 100-continue
|
||||
+
|
||||
+second 492 contents
|
||||
+</protocol>
|
||||
+</verify>
|
||||
+</testcase>
|
||||
--
|
||||
2.20.1
|
||||
|
@ -12,7 +12,7 @@ diff --git a/configure b/configure
|
||||
index 8f079a3..53b4774 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -16331,18 +16331,11 @@ $as_echo "yes" >&6; }
|
||||
@@ -16336,18 +16336,11 @@ $as_echo "yes" >&6; }
|
||||
gccvhi=`echo $gccver | cut -d . -f1`
|
||||
gccvlo=`echo $gccver | cut -d . -f2`
|
||||
compiler_num=`(expr $gccvhi "*" 100 + $gccvlo) 2>/dev/null`
|
||||
|
@ -33,7 +33,7 @@ index 080421b..ea3b806 100644
|
||||
+lib1560_CFLAGS = $(AM_CFLAGS) -fno-builtin-strcmp
|
||||
lib1560_LDADD = $(TESTUTIL_LIBS)
|
||||
|
||||
lib1591_SOURCES = lib1591.c $(SUPPORTFILES) $(TESTUTIL) $(WARNLESS)
|
||||
lib1564_SOURCES = lib1564.c $(SUPPORTFILES) $(TESTUTIL) $(WARNLESS)
|
||||
--
|
||||
2.17.2
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQEzBAABCgAdFiEEJ+3q8i86vOtQ25oSXMkI/bceEsIFAl3CauAACgkQXMkI/bce
|
||||
EsKe7Qf+Py/Wufz3AqqpJ1Xr0oigaV1Sa5AAyRD+KX8jwSJTRaRahaECGMhmR9vh
|
||||
kBaMFtycctCKcK1masI9GSeTX5nCtmaWzELLsBXynm/l2W+hrW1AD2R++YuM384t
|
||||
O078GxgsgRH0m8MacSKoV5yPOv/h9URnVMTavkAIfnW50vw17akDZ9MW2NhJzKpP
|
||||
s6GgWTMB5gomTHlnlHjTjtNoVbKKrV4v9YyRwqzI3XHXYtYOA7iufP4wnT+dpSm5
|
||||
ZLdbg5Nq+1pCTEiMg3KZKYNriypoLJuWuSF+bKc54CGN63eoUxXgU6js9ViHS5JS
|
||||
3dPfzzRA8wgROem58QhHnrR9c2CmdQ==
|
||||
=5gov
|
||||
-----END PGP SIGNATURE-----
|
11
curl-7.68.0.tar.xz.asc
Normal file
11
curl-7.68.0.tar.xz.asc
Normal file
@ -0,0 +1,11 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQEzBAABCgAdFiEEJ+3q8i86vOtQ25oSXMkI/bceEsIFAl4Vd+gACgkQXMkI/bce
|
||||
EsILUwf/YMvltTP+zlsldTRctrfC7FIZkjjj+pYylejKVajl84NZ+JnrH7o/zRyx
|
||||
blZ+D6b8CYW/3It+IPxtGPvUXW0rhmBU4ClT39mXfZBV19+WhCX7rIi3Y/ylTQ0Y
|
||||
rCfKNmiw+51u0Mug6cgsV+OAjDyLSsCu/VpWY7wyBBCHwZxYHshcdxbMvps0FBhO
|
||||
odCmP7wtXfDKxXiycGzgRxoKQ2Xd4EmBxICecPOvPnVmrCJdANjyrPQHsY8FYPG9
|
||||
piZ+bwxKCtZLfA6jsYKGelEh8KUew5eTBoSYCz7oXsPFeCmKVaRIPHYxe+RKlG9C
|
||||
IklQkFVg3FqWvtGU2eXOALyxrZnRUQ==
|
||||
=XyDf
|
||||
-----END PGP SIGNATURE-----
|
11
curl.spec
11
curl.spec
@ -1,13 +1,10 @@
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.67.0
|
||||
Release: 2%{?dist}
|
||||
Version: 7.68.0
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
|
||||
|
||||
# fix infinite loop on upload using a glob (#1771025)
|
||||
Patch1: 0001-curl-7.67.0-upload-glob.patch
|
||||
|
||||
# patch making libcurl multilib ready
|
||||
Patch101: 0101-curl-7.32.0-multilib.patch
|
||||
|
||||
@ -174,7 +171,6 @@ be installed.
|
||||
%setup -q
|
||||
|
||||
# upstream patches
|
||||
%patch1 -p1
|
||||
|
||||
# Fedora patches
|
||||
%patch101 -p1
|
||||
@ -350,6 +346,9 @@ rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
|
||||
%{_libdir}/libcurl.so.4.[0-9].[0-9].minimal
|
||||
|
||||
%changelog
|
||||
* Wed Jan 08 2020 Kamil Dudka <kdudka@redhat.com> - 7.68.0-1
|
||||
- new upstream release
|
||||
|
||||
* Thu Nov 14 2019 Kamil Dudka <kdudka@redhat.com> - 7.67.0-2
|
||||
- fix infinite loop on upload using a glob (#1771025)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (curl-7.67.0.tar.xz) = 1d5a344be92dd61b1ba5189eff0fe337e492f2e850794943570fe71c985d0af60bd412082be646e07aaa8639908593e1ce4bb2d07db35394ec377e8ce8b9ae29
|
||||
SHA512 (curl-7.68.0.tar.xz) = bf365609c9a66a05b3a263d02bcd3f81f905570c5739c8ec522a296b4b8e2a479d64d5524e8345e14eafad28995ee22d923522f1a45fa40eb46db38759c2eb2c
|
||||
|
Loading…
Reference in New Issue
Block a user