new upstream release - 7.27.0
This commit is contained in:
parent
20e0756c88
commit
c9fa3c1968
@ -1,253 +0,0 @@
|
||||
From 74be99357669da26900ae23b5005ddeabb91b453 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Mon, 21 May 2012 16:31:21 +0200
|
||||
Subject: [PATCH 1/2] nss: avoid using explicit casts of code pointers
|
||||
|
||||
---
|
||||
lib/nss.c | 11 ++++-------
|
||||
1 files changed, 4 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/lib/nss.c b/lib/nss.c
|
||||
index 6b93893..885a120 100644
|
||||
--- a/lib/nss.c
|
||||
+++ b/lib/nss.c
|
||||
@@ -670,11 +670,10 @@ static SECStatus BadCertHandler(void *arg, PRFileDesc *sock)
|
||||
/**
|
||||
* Inform the application that the handshake is complete.
|
||||
*/
|
||||
-static SECStatus HandshakeCallback(PRFileDesc *sock, void *arg)
|
||||
+static void HandshakeCallback(PRFileDesc *sock, void *arg)
|
||||
{
|
||||
(void)sock;
|
||||
(void)arg;
|
||||
- return SECSuccess;
|
||||
}
|
||||
|
||||
static void display_cert_info(struct SessionHandle *data,
|
||||
@@ -1341,12 +1340,10 @@ CURLcode Curl_nss_connect(struct connectdata *conn, int sockindex)
|
||||
goto error;
|
||||
|
||||
data->set.ssl.certverifyresult=0; /* not checked yet */
|
||||
- if(SSL_BadCertHook(model, (SSLBadCertHandler) BadCertHandler, conn)
|
||||
- != SECSuccess) {
|
||||
+ if(SSL_BadCertHook(model, BadCertHandler, conn) != SECSuccess)
|
||||
goto error;
|
||||
- }
|
||||
- if(SSL_HandshakeCallback(model, (SSLHandshakeCallback) HandshakeCallback,
|
||||
- NULL) != SECSuccess)
|
||||
+
|
||||
+ if(SSL_HandshakeCallback(model, HandshakeCallback, NULL) != SECSuccess)
|
||||
goto error;
|
||||
|
||||
if(data->set.ssl.verifypeer) {
|
||||
--
|
||||
1.7.1
|
||||
|
||||
From 72f4b534c4f57a71c458257c4ea317d557cf59f5 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Mon, 21 May 2012 16:19:12 +0200
|
||||
Subject: [PATCH 2/2] nss: use human-readable error messages provided by NSS
|
||||
|
||||
Bug: http://lists.baseurl.org/pipermail/yum-devel/2012-January/009002.html
|
||||
---
|
||||
lib/nss.c | 128 +++++++++++++++++++++++++-------------------------------
|
||||
1 files changed, 57 insertions(+), 71 deletions(-)
|
||||
|
||||
diff --git a/lib/nss.c b/lib/nss.c
|
||||
index 885a120..d60b184 100644
|
||||
--- a/lib/nss.c
|
||||
+++ b/lib/nss.c
|
||||
@@ -186,6 +186,11 @@ static const char* nss_error_to_name(PRErrorCode code)
|
||||
return "unknown error";
|
||||
}
|
||||
|
||||
+static void nss_print_error_message(struct SessionHandle *data, PRUint32 err)
|
||||
+{
|
||||
+ failf(data, "%s", PR_ErrorToString(err, PR_LANGUAGE_I_DEFAULT));
|
||||
+}
|
||||
+
|
||||
static SECStatus set_ciphers(struct SessionHandle *data, PRFileDesc * model,
|
||||
char *cipher_list)
|
||||
{
|
||||
@@ -612,61 +617,6 @@ static SECStatus nss_auth_cert_hook(void *arg, PRFileDesc *fd, PRBool checksig,
|
||||
return SSL_AuthCertificate(CERT_GetDefaultCertDB(), fd, checksig, isServer);
|
||||
}
|
||||
|
||||
-static SECStatus BadCertHandler(void *arg, PRFileDesc *sock)
|
||||
-{
|
||||
- SECStatus result = SECFailure;
|
||||
- struct connectdata *conn = (struct connectdata *)arg;
|
||||
- PRErrorCode err = PR_GetError();
|
||||
- CERTCertificate *cert = NULL;
|
||||
- char *subject, *subject_cn, *issuer;
|
||||
-
|
||||
- conn->data->set.ssl.certverifyresult=err;
|
||||
- cert = SSL_PeerCertificate(sock);
|
||||
- subject = CERT_NameToAscii(&cert->subject);
|
||||
- subject_cn = CERT_GetCommonName(&cert->subject);
|
||||
- issuer = CERT_NameToAscii(&cert->issuer);
|
||||
- CERT_DestroyCertificate(cert);
|
||||
-
|
||||
- switch(err) {
|
||||
- case SEC_ERROR_CA_CERT_INVALID:
|
||||
- infof(conn->data, "Issuer certificate is invalid: '%s'\n", issuer);
|
||||
- break;
|
||||
- case SEC_ERROR_UNTRUSTED_ISSUER:
|
||||
- infof(conn->data, "Certificate is signed by an untrusted issuer: '%s'\n",
|
||||
- issuer);
|
||||
- break;
|
||||
- case SSL_ERROR_BAD_CERT_DOMAIN:
|
||||
- if(conn->data->set.ssl.verifyhost) {
|
||||
- failf(conn->data, "SSL: certificate subject name '%s' does not match "
|
||||
- "target host name '%s'", subject_cn, conn->host.dispname);
|
||||
- }
|
||||
- else {
|
||||
- result = SECSuccess;
|
||||
- infof(conn->data, "warning: SSL: certificate subject name '%s' does not "
|
||||
- "match target host name '%s'\n", subject_cn, conn->host.dispname);
|
||||
- }
|
||||
- break;
|
||||
- case SEC_ERROR_EXPIRED_CERTIFICATE:
|
||||
- infof(conn->data, "Remote Certificate has expired.\n");
|
||||
- break;
|
||||
- case SEC_ERROR_UNKNOWN_ISSUER:
|
||||
- infof(conn->data, "Peer's certificate issuer is not recognized: '%s'\n",
|
||||
- issuer);
|
||||
- break;
|
||||
- default:
|
||||
- infof(conn->data, "Bad certificate received. Subject = '%s', "
|
||||
- "Issuer = '%s'\n", subject, issuer);
|
||||
- break;
|
||||
- }
|
||||
- if(result == SECSuccess)
|
||||
- infof(conn->data, "SSL certificate verify ok.\n");
|
||||
- PR_Free(subject);
|
||||
- PR_Free(subject_cn);
|
||||
- PR_Free(issuer);
|
||||
-
|
||||
- return result;
|
||||
-}
|
||||
-
|
||||
/**
|
||||
* Inform the application that the handshake is complete.
|
||||
*/
|
||||
@@ -728,6 +678,31 @@ static void display_conn_info(struct connectdata *conn, PRFileDesc *sock)
|
||||
return;
|
||||
}
|
||||
|
||||
+static SECStatus BadCertHandler(void *arg, PRFileDesc *sock)
|
||||
+{
|
||||
+ struct connectdata *conn = (struct connectdata *)arg;
|
||||
+ struct SessionHandle *data = conn->data;
|
||||
+ PRErrorCode err = PR_GetError();
|
||||
+ CERTCertificate *cert;
|
||||
+
|
||||
+ /* remember the cert verification result */
|
||||
+ data->set.ssl.certverifyresult = err;
|
||||
+
|
||||
+ if(err == SSL_ERROR_BAD_CERT_DOMAIN && !data->set.ssl.verifyhost)
|
||||
+ /* we are asked not to verify the host name */
|
||||
+ return SECSuccess;
|
||||
+
|
||||
+ /* print only info about the cert, the error is printed off the callback */
|
||||
+ cert = SSL_PeerCertificate(sock);
|
||||
+ if(cert) {
|
||||
+ infof(data, "Server certificate:\n");
|
||||
+ display_cert_info(data, cert);
|
||||
+ CERT_DestroyCertificate(cert);
|
||||
+ }
|
||||
+
|
||||
+ return SECFailure;
|
||||
+}
|
||||
+
|
||||
/**
|
||||
*
|
||||
* Check that the Peer certificate's issuer certificate matches the one found
|
||||
@@ -1108,20 +1083,17 @@ int Curl_nss_close_all(struct SessionHandle *data)
|
||||
return 0;
|
||||
}
|
||||
|
||||
-/* handle client certificate related errors if any; return false otherwise */
|
||||
-static bool handle_cc_error(PRInt32 err, struct SessionHandle *data)
|
||||
+/* return true if the given error code is related to a client certificate */
|
||||
+static bool is_cc_error(PRInt32 err)
|
||||
{
|
||||
switch(err) {
|
||||
case SSL_ERROR_BAD_CERT_ALERT:
|
||||
- failf(data, "SSL error: SSL_ERROR_BAD_CERT_ALERT");
|
||||
return true;
|
||||
|
||||
case SSL_ERROR_REVOKED_CERT_ALERT:
|
||||
- failf(data, "SSL error: SSL_ERROR_REVOKED_CERT_ALERT");
|
||||
return true;
|
||||
|
||||
case SSL_ERROR_EXPIRED_CERT_ALERT:
|
||||
- failf(data, "SSL error: SSL_ERROR_EXPIRED_CERT_ALERT");
|
||||
return true;
|
||||
|
||||
default:
|
||||
@@ -1460,10 +1432,14 @@ CURLcode Curl_nss_connect(struct connectdata *conn, int sockindex)
|
||||
data->state.ssl_connect_retry = FALSE;
|
||||
|
||||
err = PR_GetError();
|
||||
- if(handle_cc_error(err, data))
|
||||
+ if(is_cc_error(err))
|
||||
curlerr = CURLE_SSL_CERTPROBLEM;
|
||||
- else
|
||||
- infof(data, "NSS error %d (%s)\n", err, nss_error_to_name(err));
|
||||
+
|
||||
+ /* print the error number and error string */
|
||||
+ infof(data, "NSS error %d (%s)\n", err, nss_error_to_name(err));
|
||||
+
|
||||
+ /* print a human-readable message describing the error if available */
|
||||
+ nss_print_error_message(data, err);
|
||||
|
||||
if(model)
|
||||
PR_Close(model);
|
||||
@@ -1496,12 +1472,17 @@ static ssize_t nss_send(struct connectdata *conn, /* connection data */
|
||||
PRInt32 err = PR_GetError();
|
||||
if(err == PR_WOULD_BLOCK_ERROR)
|
||||
*curlcode = CURLE_AGAIN;
|
||||
- else if(handle_cc_error(err, conn->data))
|
||||
- *curlcode = CURLE_SSL_CERTPROBLEM;
|
||||
else {
|
||||
+ /* print the error number and error string */
|
||||
const char *err_name = nss_error_to_name(err);
|
||||
- failf(conn->data, "SSL write: error %d (%s)", err, err_name);
|
||||
- *curlcode = CURLE_SEND_ERROR;
|
||||
+ infof(conn->data, "SSL write: error %d (%s)\n", err, err_name);
|
||||
+
|
||||
+ /* print a human-readable message describing the error if available */
|
||||
+ nss_print_error_message(conn->data, err);
|
||||
+
|
||||
+ *curlcode = (is_cc_error(err))
|
||||
+ ? CURLE_SSL_CERTPROBLEM
|
||||
+ : CURLE_SEND_ERROR;
|
||||
}
|
||||
return -1;
|
||||
}
|
||||
@@ -1523,12 +1504,17 @@ static ssize_t nss_recv(struct connectdata * conn, /* connection data */
|
||||
|
||||
if(err == PR_WOULD_BLOCK_ERROR)
|
||||
*curlcode = CURLE_AGAIN;
|
||||
- else if(handle_cc_error(err, conn->data))
|
||||
- *curlcode = CURLE_SSL_CERTPROBLEM;
|
||||
else {
|
||||
+ /* print the error number and error string */
|
||||
const char *err_name = nss_error_to_name(err);
|
||||
- failf(conn->data, "SSL read: errno %d (%s)", err, err_name);
|
||||
- *curlcode = CURLE_RECV_ERROR;
|
||||
+ infof(conn->data, "SSL read: errno %d (%s)\n", err, err_name);
|
||||
+
|
||||
+ /* print a human-readable message describing the error if available */
|
||||
+ nss_print_error_message(conn->data, err);
|
||||
+
|
||||
+ *curlcode = (is_cc_error(err))
|
||||
+ ? CURLE_SSL_CERTPROBLEM
|
||||
+ : CURLE_RECV_ERROR;
|
||||
}
|
||||
return -1;
|
||||
}
|
||||
--
|
||||
1.7.1
|
||||
|
@ -1,42 +0,0 @@
|
||||
From 68857e40d69ef792bfcc6d7395c65305a4117c51 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Fri, 8 Jun 2012 23:02:57 +0200
|
||||
Subject: [PATCH] ssl: fix duplicated SSL handshake with multi interface and proxy
|
||||
|
||||
Bug: https://bugzilla.redhat.com/788526
|
||||
Reported by: Enrico Scholz
|
||||
---
|
||||
lib/sslgen.c | 10 +++++-----
|
||||
1 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/lib/sslgen.c b/lib/sslgen.c
|
||||
index a77fd78..14649a9 100644
|
||||
--- a/lib/sslgen.c
|
||||
+++ b/lib/sslgen.c
|
||||
@@ -211,18 +211,18 @@ CURLcode
|
||||
Curl_ssl_connect_nonblocking(struct connectdata *conn, int sockindex,
|
||||
bool *done)
|
||||
{
|
||||
-#ifdef curlssl_connect_nonblocking
|
||||
CURLcode res;
|
||||
/* mark this is being ssl requested from here on. */
|
||||
conn->ssl[sockindex].use = TRUE;
|
||||
+#ifdef curlssl_connect_nonblocking
|
||||
res = curlssl_connect_nonblocking(conn, sockindex, done);
|
||||
- if(!res && *done)
|
||||
- Curl_pgrsTime(conn->data, TIMER_APPCONNECT); /* SSL is connected */
|
||||
- return res;
|
||||
#else
|
||||
*done = TRUE; /* fallback to BLOCKING */
|
||||
- return Curl_ssl_connect(conn, sockindex);
|
||||
+ res = curlssl_connect(conn, sockindex);
|
||||
#endif /* non-blocking connect support */
|
||||
+ if(!res && *done)
|
||||
+ Curl_pgrsTime(conn->data, TIMER_APPCONNECT); /* SSL is connected */
|
||||
+ return res;
|
||||
}
|
||||
|
||||
/*
|
||||
--
|
||||
1.7.1
|
||||
|
@ -1,95 +0,0 @@
|
||||
From 402328f2fc91e82c1f8b73500e3e8ce2e5b728c5 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Fri, 20 Jul 2012 13:33:58 +0200
|
||||
Subject: [PATCH] http: print reason phrase from HTTP status line on error
|
||||
|
||||
[upstream commit d317ca50ae7d8bb250431f86709e53b94f7f6ddf]
|
||||
|
||||
Bug: https://bugzilla.redhat.com/676596
|
||||
---
|
||||
lib/http.c | 39 +++++++++++++++++++++++++++++++++++++--
|
||||
tests/data/test24 | 5 ++++-
|
||||
2 files changed, 41 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/lib/http.c b/lib/http.c
|
||||
index a139894..1d6519f 100644
|
||||
--- a/lib/http.c
|
||||
+++ b/lib/http.c
|
||||
@@ -2727,6 +2727,42 @@ static CURLcode header_append(struct SessionHandle *data,
|
||||
return CURLE_OK;
|
||||
}
|
||||
|
||||
+static void print_http_error(struct SessionHandle *data)
|
||||
+{
|
||||
+ struct SingleRequest *k = &data->req;
|
||||
+ char *beg = k->p;
|
||||
+
|
||||
+ /* make sure that data->req.p points to the HTTP status line */
|
||||
+ if(!strncmp(beg, "HTTP", 4)) {
|
||||
+
|
||||
+ /* skip to HTTP status code */
|
||||
+ beg = strchr(beg, ' ');
|
||||
+ if(beg && *++beg) {
|
||||
+
|
||||
+ /* find trailing CR */
|
||||
+ char end_char = '\r';
|
||||
+ char *end = strchr(beg, end_char);
|
||||
+ if(!end) {
|
||||
+ /* try to find LF (workaround for non-compliant HTTP servers) */
|
||||
+ end_char = '\n';
|
||||
+ end = strchr(beg, end_char);
|
||||
+ }
|
||||
+
|
||||
+ if(end) {
|
||||
+ /* temporarily replace CR or LF by NUL and print the error message */
|
||||
+ *end = '\0';
|
||||
+ failf(data, "The requested URL returned error: %s", beg);
|
||||
+
|
||||
+ /* restore the previously replaced CR or LF */
|
||||
+ *end = end_char;
|
||||
+ return;
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ /* fall-back to printing the HTTP status code only */
|
||||
+ failf(data, "The requested URL returned error: %d", k->httpcode);
|
||||
+}
|
||||
|
||||
/*
|
||||
* Read any HTTP header lines from the server and pass them to the client app.
|
||||
@@ -3114,8 +3150,7 @@ CURLcode Curl_http_readwrite_headers(struct SessionHandle *data,
|
||||
}
|
||||
else {
|
||||
/* serious error, go home! */
|
||||
- failf (data, "The requested URL returned error: %d",
|
||||
- k->httpcode);
|
||||
+ print_http_error(data);
|
||||
return CURLE_HTTP_RETURNED_ERROR;
|
||||
}
|
||||
}
|
||||
diff --git a/tests/data/test24 b/tests/data/test24
|
||||
index 7985f43..18e7d5b 100644
|
||||
--- a/tests/data/test24
|
||||
+++ b/tests/data/test24
|
||||
@@ -24,7 +24,7 @@ http
|
||||
HTTP GET fail silently on HTTP error return
|
||||
</name>
|
||||
<command>
|
||||
-http://%HOSTIP:%HTTPPORT/24 --fail
|
||||
+http://%HOSTIP:%HTTPPORT/24 --fail --silent --show-error
|
||||
</command>
|
||||
</client>
|
||||
|
||||
@@ -43,5 +43,8 @@ Accept: */*
|
||||
<errorcode>
|
||||
22
|
||||
</errorcode>
|
||||
+<file2 name="log/stderr24">
|
||||
+curl: (22) The requested URL returned error: 404 BAD BOY
|
||||
+</file2>
|
||||
</verify>
|
||||
</testcase>
|
||||
--
|
||||
1.7.1
|
||||
|
@ -7,7 +7,7 @@ diff --git a/curl-config.in b/curl-config.in
|
||||
index 150004d..95d0759 100644
|
||||
--- a/curl-config.in
|
||||
+++ b/curl-config.in
|
||||
@@ -74,7 +74,7 @@ while test $# -gt 0; do
|
||||
@@ -75,7 +75,7 @@ while test $# -gt 0; do
|
||||
;;
|
||||
|
||||
--cc)
|
||||
@ -16,7 +16,7 @@ index 150004d..95d0759 100644
|
||||
;;
|
||||
|
||||
--prefix)
|
||||
@@ -136,24 +136,14 @@ while test $# -gt 0; do
|
||||
@@ -142,24 +142,14 @@ while test $# -gt 0; do
|
||||
;;
|
||||
|
||||
--libs)
|
@ -6,7 +6,7 @@ diff --git a/configure b/configure
|
||||
index d3ecf69..6d8f085 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -15084,18 +15084,11 @@ $as_echo "yes" >&6; }
|
||||
@@ -15093,18 +15093,11 @@ $as_echo "yes" >&6; }
|
||||
gccvhi=`echo $gccver | cut -d . -f1`
|
||||
gccvlo=`echo $gccver | cut -d . -f2`
|
||||
compiler_num=`(expr $gccvhi "*" 100 + $gccvlo) 2>/dev/null`
|
@ -19,7 +19,7 @@ diff --git a/tests/data/Makefile.in b/tests/data/Makefile.in
|
||||
index 435b126..1d71c4e 100644
|
||||
--- a/tests/data/Makefile.in
|
||||
+++ b/tests/data/Makefile.in
|
||||
@@ -332,7 +332,7 @@ test1078 test1079 test1080 test1081 test1082 test1083 test1084 test1085 \
|
||||
@@ -338,7 +338,7 @@ test1078 test1079 test1080 test1081 test1082 test1083 test1084 test1085 \
|
||||
test1086 test1087 test1088 test1089 test1090 test1091 test1092 test1093 \
|
||||
test1094 test1095 test1096 test1097 test1098 test1099 test1100 test1101 \
|
||||
test1102 test1103 test1104 test1105 test1106 test1107 test1108 test1109 \
|
@ -1,12 +1,30 @@
|
||||
CHANGES | 18 +++++++++---------
|
||||
CHANGES | 16 ++++++++--------
|
||||
README | 2 +-
|
||||
2 files changed, 10 insertions(+), 10 deletions(-)
|
||||
2 files changed, 9 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/CHANGES b/CHANGES
|
||||
index 2335841..d4d37c2 100644
|
||||
--- a/CHANGES
|
||||
+++ b/CHANGES
|
||||
@@ -604,18 +604,18 @@ Daniel Stenberg (1 Apr 2012)
|
||||
@@ -272,7 +272,7 @@ Daniel Stenberg (9 Jul 2012)
|
||||
|
||||
- cookie: fixed typo in comment
|
||||
|
||||
-- [Christian Hägele brought this change]
|
||||
+- [Christian Hägele brought this change]
|
||||
|
||||
https_getsock: provided for schannel backend as well
|
||||
|
||||
@@ -454,7 +454,7 @@ Yang Tse (3 Jul 2012)
|
||||
testcurl.pl: fix missing semicolon
|
||||
|
||||
Daniel Stenberg (2 Jul 2012)
|
||||
-- [Christian Hägele brought this change]
|
||||
+- [Christian Hägele brought this change]
|
||||
|
||||
unicode NTLM SSPI: heap corruption fixed
|
||||
|
||||
@@ -2563,18 +2563,18 @@ Daniel Stenberg (1 Apr 2012)
|
||||
Reported by: Michael Wallner
|
||||
|
||||
Steve Holme (31 Mar 2012)
|
||||
@ -28,7 +46,7 @@ index 2335841..d4d37c2 100644
|
||||
|
||||
md5: Add support for calculating the md5 sum of buffers incrementally
|
||||
|
||||
@@ -1913,7 +1913,7 @@ Daniel Stenberg (20 Dec 2011)
|
||||
@@ -3866,7 +3866,7 @@ Daniel Stenberg (20 Dec 2011)
|
||||
This offers an alternative to the existing Curl_socket_ready() API which
|
||||
only checks one socket for read and one for write.
|
||||
|
||||
@ -37,7 +55,7 @@ index 2335841..d4d37c2 100644
|
||||
|
||||
curl.h: add __ANDROID__ macro check
|
||||
|
||||
@@ -2126,7 +2126,7 @@ Daniel Stenberg (12 Dec 2011)
|
||||
@@ -4079,7 +4079,7 @@ Daniel Stenberg (12 Dec 2011)
|
||||
linking with a static openssl requires a set of more libs to be linked
|
||||
on Windows.
|
||||
|
||||
@ -46,7 +64,7 @@ index 2335841..d4d37c2 100644
|
||||
|
||||
Bug: http://curl.haxx.se/mail/lib-2011-12/0063.html
|
||||
Reported by: Ward Willats
|
||||
@@ -3386,7 +3386,7 @@ Daniel Stenberg (25 Sep 2011)
|
||||
@@ -5333,7 +5333,7 @@ Daniel Stenberg (25 Sep 2011)
|
||||
damaging.
|
||||
|
||||
Bug: http://curl.haxx.se/bug/view.cgi?id=3413181
|
||||
@ -55,33 +73,6 @@ index 2335841..d4d37c2 100644
|
||||
|
||||
Yang Tse (24 Sep 2011)
|
||||
- curl tool: fix a compiler warning
|
||||
@@ -4386,7 +4386,7 @@ Daniel Stenberg (8 Aug 2011)
|
||||
Update the phrasing to reflect our more strict interpretation:
|
||||
http://curl.haxx.se/mail/lib-2011-08/0064.html
|
||||
|
||||
-- [Cristian Rodríguez brought this change]
|
||||
+- [Cristian RodrÃguez brought this change]
|
||||
|
||||
OpenSSL: Use SSL_MODE_RELEASE_BUFFERS if available, reduces memory use
|
||||
|
||||
@@ -4394,7 +4394,7 @@ Daniel Stenberg (8 Aug 2011)
|
||||
http://www.openssl.org/docs/ssl/SSL_CTX_set_mode.html
|
||||
http://www.imperialviolet.org/2010/06/25/overclocking-ssl.html
|
||||
|
||||
- Signed-off-by: Cristian Rodríguez <crrodriguez@opensuse.org>
|
||||
+ Signed-off-by: Cristian RodrÃguez <crrodriguez@opensuse.org>
|
||||
|
||||
- TODO-RELEASE: close issue #292
|
||||
|
||||
@@ -4428,7 +4428,7 @@ Daniel Stenberg (6 Aug 2011)
|
||||
provided" by Christian H<E4>gele
|
||||
http://curl.haxx.se/mail/lib-2011-08/0009.html
|
||||
|
||||
-- [Christian Hägele brought this change]
|
||||
+- [Christian Hägele brought this change]
|
||||
|
||||
asyn-thread: check for dotted addresses before thread starts
|
||||
|
||||
diff --git a/README b/README
|
||||
index 2ffacc3..cfd6760 100644
|
||||
--- a/README
|
@ -1,6 +1,11 @@
|
||||
diff -up curl-7.26.0/tests/data/Makefile.am.ppc1319 curl-7.26.0/tests/data/Makefile.am
|
||||
--- curl-7.26.0/tests/data/Makefile.am.ppc1319 2012-05-30 12:32:16.396720278 +0200
|
||||
+++ curl-7.26.0/tests/data/Makefile.am 2012-05-30 12:32:40.475870630 +0200
|
||||
tests/data/Makefile.am | 2 +-
|
||||
tests/data/Makefile.in | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tests/data/Makefile.am b/tests/data/Makefile.am
|
||||
index bb4722e..d6879c9 100644
|
||||
--- a/tests/data/Makefile.am
|
||||
+++ b/tests/data/Makefile.am
|
||||
@@ -81,7 +81,7 @@ test1208 test1209 test1210 test1211 \
|
||||
test1220 \
|
||||
test1300 test1301 test1302 test1303 test1304 test1305 \
|
||||
@ -8,17 +13,18 @@ diff -up curl-7.26.0/tests/data/Makefile.am.ppc1319 curl-7.26.0/tests/data/Makef
|
||||
-test1314 test1315 test1316 test1317 test1318 test1319 test1320 test1321 \
|
||||
+test1314 test1315 test1316 test1317 test1318 test1320 test1321 \
|
||||
test1322 test1323 test1324 test1325 test1326 test1327 test1328 test1329 \
|
||||
test1331 test1332 test1333 \
|
||||
test1400 test1401 test1402 test1403 test1404 test1405 test1406 test1407 \
|
||||
diff -up curl-7.26.0/tests/data/Makefile.in.ppc1319 curl-7.26.0/tests/data/Makefile.in
|
||||
--- curl-7.26.0/tests/data/Makefile.in.ppc1319 2012-05-30 12:32:24.891420536 +0200
|
||||
+++ curl-7.26.0/tests/data/Makefile.in 2012-05-30 12:32:47.225632459 +0200
|
||||
@@ -340,7 +340,7 @@ test1208 test1209 test1210 test1211 \
|
||||
test1331 test1332 test1333 test1334 test1335 test1336 test1337 test1338 \
|
||||
test1339 test1340 test1341 test1342 test1343 test1344 test1345 test1346 \
|
||||
diff --git a/tests/data/Makefile.in b/tests/data/Makefile.in
|
||||
index c7e9d96..ec70dce 100644
|
||||
--- a/tests/data/Makefile.in
|
||||
+++ b/tests/data/Makefile.in
|
||||
@@ -346,7 +346,7 @@ test1208 test1209 test1210 test1211 \
|
||||
test1220 \
|
||||
test1300 test1301 test1302 test1303 test1304 test1305 \
|
||||
test1306 test1307 test1308 test1309 test1310 test1311 test1312 test1313 \
|
||||
-test1314 test1315 test1316 test1317 test1318 test1319 test1320 test1321 \
|
||||
+test1314 test1315 test1316 test1317 test1318 test1320 test1321 \
|
||||
test1322 test1323 test1324 test1325 test1326 test1327 test1328 test1329 \
|
||||
test1331 test1332 test1333 \
|
||||
test1400 test1401 test1402 test1403 test1404 test1405 test1406 test1407 \
|
||||
test1331 test1332 test1333 test1334 test1335 test1336 test1337 test1338 \
|
||||
test1339 test1340 test1341 test1342 test1343 test1344 test1345 test1346 \
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.12 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAk++XP4ACgkQeOEcayedXJGItwCgtc6ECD4l6E7Q4ZEJDOzBB5bQ
|
||||
LWoAoLFWWUbcd+sBu/+s6fOGxgETHqT2
|
||||
=4I4f
|
||||
-----END PGP SIGNATURE-----
|
7
curl-7.27.0.tar.lzma.asc
Normal file
7
curl-7.27.0.tar.lzma.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.12 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlATBJgACgkQeOEcayedXJG7qwCgpx6vCgDNTRZ2th1SnQw+V8WD
|
||||
eIQAn1FrMLQyxZIF/9oDW67e4jnctUV4
|
||||
=31wG
|
||||
-----END PGP SIGNATURE-----
|
30
curl.spec
30
curl.spec
@ -1,33 +1,24 @@
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.26.0
|
||||
Release: 6%{?dist}
|
||||
Version: 7.27.0
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Group: Applications/Internet
|
||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
|
||||
Source2: curlbuild.h
|
||||
Source3: hide_selinux.c
|
||||
|
||||
# use human-readable error messages provided by NSS
|
||||
Patch1: 0001-curl-7.26.0-72f4b534.patch
|
||||
|
||||
# fix duplicated SSL handshake with multi interface and proxy (#788526)
|
||||
Patch2: 0002-curl-7.26.0-68857e40.patch
|
||||
|
||||
# print reason phrase from HTTP status line on error (#676596)
|
||||
Patch3: 0003-curl-7.26.0-d317ca50.patch
|
||||
|
||||
# patch making libcurl multilib ready
|
||||
Patch101: 0101-curl-7.25.0-multilib.patch
|
||||
Patch101: 0101-curl-7.27.0-multilib.patch
|
||||
|
||||
# prevent configure script from discarding -g in CFLAGS (#496778)
|
||||
Patch102: 0102-curl-7.26.0-debug.patch
|
||||
Patch102: 0102-curl-7.27.0-debug.patch
|
||||
|
||||
# use localhost6 instead of ip6-localhost in the curl test-suite
|
||||
Patch104: 0104-curl-7.19.7-localhost6.patch
|
||||
|
||||
# exclude test1112 from the test suite (#565305)
|
||||
Patch105: 0105-curl-7.26.0-disable-test1112.patch
|
||||
Patch105: 0105-curl-7.27.0-disable-test1112.patch
|
||||
|
||||
# disable valgrind for certain test-cases (libssh2 problem)
|
||||
Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
|
||||
@ -37,10 +28,10 @@ Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
|
||||
|
||||
# Fix character encoding of docs, which are of mixed encoding originally so
|
||||
# a simple iconv can't fix them
|
||||
Patch108: 0108-curl-7.26.0-utf8.patch
|
||||
Patch108: 0108-curl-7.27.0-utf8.patch
|
||||
|
||||
# server timeout on ppc64
|
||||
Patch109: 0109-curl-7.26.0-disable-test1319.patch
|
||||
Patch109: 0109-curl-7.27.0-disable-test1319.patch
|
||||
|
||||
Provides: webclient
|
||||
URL: http://curl.haxx.se/
|
||||
@ -116,9 +107,7 @@ documentation of the library, too.
|
||||
%setup -q
|
||||
|
||||
# upstream patches
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
|
||||
# Fedora patches
|
||||
%patch101 -p1
|
||||
@ -241,6 +230,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/aclocal/libcurl.m4
|
||||
|
||||
%changelog
|
||||
* Sat Jul 28 2012 Kamil Dudka <kdudka@redhat.com> 7.27.0-1
|
||||
- new upstream release
|
||||
|
||||
* Mon Jul 23 2012 Kamil Dudka <kdudka@redhat.com> 7.26.0-6
|
||||
- print reason phrase from HTTP status line on error (#676596)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user