libtest: avoid symbol lookup error in libstubgss.so

This commit is contained in:
Kamil Dudka 2018-12-12 14:39:00 +01:00
parent a94ce82de0
commit c91c27bce9
2 changed files with 29 additions and 0 deletions

View File

@ -0,0 +1,25 @@
From d8a3bdce7a43cb777866c34d3dabf908254e516d Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Wed, 12 Dec 2018 14:25:32 +0100
Subject: [PATCH] libtest: avoid symbol lookup error in libstubgss.so
---
tests/libtest/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/libtest/Makefile.am b/tests/libtest/Makefile.am
index 56c84a7..117b79f 100644
--- a/tests/libtest/Makefile.am
+++ b/tests/libtest/Makefile.am
@@ -123,7 +123,7 @@ libstubgss_la_CFLAGS = $(AM_CFLAGS) -g
libstubgss_la_SOURCES = stub_gssapi.c stub_gssapi.h
-libstubgss_la_LIBADD =
+libstubgss_la_LIBADD = $(top_builddir)/lib/libcurl.la
libstubgss_la_DEPENDENCIES =
endif
--
2.17.2

View File

@ -17,6 +17,9 @@ Patch103: 0103-curl-7.59.0-python3.patch
# use localhost6 instead of ip6-localhost in the curl test-suite
Patch104: 0104-curl-7.19.7-localhost6.patch
# libtest: avoid symbol lookup error in libstubgss.so
Patch105: 0105-curl-7.63.0-libstubgss-ldadd.patch
Provides: curl-full = %{version}-%{release}
Provides: webclient
URL: https://curl.haxx.se/
@ -169,6 +172,7 @@ be installed.
%patch102 -p1
%patch103 -p1
%patch104 -p1
%patch105 -p1
# make tests/*.py use Python 3
sed -e '1 s|^#!/.*python|#!%{__python3}|' -i tests/*.py