- update to curl-7.18.0
- drop sslgen patch -> applied upstream - fix typo in description
This commit is contained in:
parent
de7fe678d0
commit
c8e160aef5
10
.cvsignore
10
.cvsignore
@ -1,9 +1 @@
|
|||||||
curl-7.15.4.tar.bz2
|
curl-7.18.0.tar.bz2
|
||||||
curl-7.15.5.tar.bz2
|
|
||||||
curl-7.16.0.tar.bz2
|
|
||||||
curl-7.16.1.tar.bz2
|
|
||||||
curl-7.16.2.tar.bz2
|
|
||||||
curl-7.16.3.tar.bz2
|
|
||||||
curl-7.16.4.tar.bz2
|
|
||||||
curl-7.17.0.tar.bz2
|
|
||||||
curl-7.17.1.tar.bz2
|
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
--- curl-7.16.2/curl-config.in.multilib 2007-02-18 10:41:27.000000000 +0100
|
diff -up curl-7.18.0/curl-config.in.multilib curl-7.18.0/curl-config.in
|
||||||
+++ curl-7.16.2/curl-config.in 2007-04-11 20:00:16.000000000 +0200
|
--- curl-7.18.0/curl-config.in.multilib 2008-01-10 23:14:02.000000000 +0100
|
||||||
@@ -71,7 +71,7 @@
|
+++ curl-7.18.0/curl-config.in 2008-01-28 21:37:50.000000000 +0100
|
||||||
|
@@ -72,7 +72,7 @@
|
||||||
;;
|
;;
|
||||||
|
|
||||||
--cc)
|
--cc)
|
||||||
@ -9,11 +10,11 @@
|
|||||||
;;
|
;;
|
||||||
|
|
||||||
--prefix)
|
--prefix)
|
||||||
@@ -181,16 +181,7 @@
|
@@ -189,16 +189,7 @@
|
||||||
;;
|
;;
|
||||||
|
|
||||||
--libs)
|
--libs)
|
||||||
- if test "X@libdir@" != "X/usr/lib"; then
|
- if test "X@libdir@" != "X/usr/lib" -a "X@libdir@" != "X/usr/lib64"; then
|
||||||
- CURLLIBDIR="-L@libdir@ "
|
- CURLLIBDIR="-L@libdir@ "
|
||||||
- else
|
- else
|
||||||
- CURLLIBDIR=""
|
- CURLLIBDIR=""
|
||||||
@ -26,4 +27,4 @@
|
|||||||
+ pkg-config libcurl --libs
|
+ pkg-config libcurl --libs
|
||||||
;;
|
;;
|
||||||
|
|
||||||
*)
|
--static-libs)
|
||||||
|
@ -1,9 +1,7 @@
|
|||||||
Patch for #316191 curl-config doesn't advertise support of SSL and HTTPS when
|
diff -up curl-7.18.0/curl-config.in.curl-config curl-7.18.0/curl-config.in
|
||||||
built against nss (Lubomir Kundrak <lkundrak@redhat.com>)
|
--- curl-7.18.0/curl-config.in.curl-config 2008-01-28 21:39:08.000000000 +0100
|
||||||
|
+++ curl-7.18.0/curl-config.in 2008-01-28 21:46:36.000000000 +0100
|
||||||
--- curl-7.16.4/curl-config.in.sslconfig 2007-10-02 22:55:15.000000000 +0200
|
@@ -57,6 +57,8 @@
|
||||||
+++ curl-7.16.4/curl-config.in 2007-10-02 22:58:19.000000000 +0200
|
|
||||||
@@ -56,6 +56,8 @@
|
|
||||||
usage 1
|
usage 1
|
||||||
fi
|
fi
|
||||||
|
|
||||||
@ -12,30 +10,30 @@ built against nss (Lubomir Kundrak <lkundrak@redhat.com>)
|
|||||||
while test $# -gt 0; do
|
while test $# -gt 0; do
|
||||||
case "$1" in
|
case "$1" in
|
||||||
# this deals with options in the style
|
# this deals with options in the style
|
||||||
@@ -80,9 +82,9 @@
|
@@ -81,9 +83,9 @@
|
||||||
|
|
||||||
--feature|--features)
|
--feature|--features)
|
||||||
if test "@USE_SSLEAY@" = "1"; then
|
if test "@USE_SSLEAY@" = "1"; then
|
||||||
- echo "SSL"
|
- echo "SSL"
|
||||||
NTLM=1 # OpenSSL implies NTLM
|
NTLM=1 # OpenSSL implies NTLM
|
||||||
- elif test -n "@USE_GNUTLS@"; then
|
- elif test -n "@SSL_ENABLED@"; then
|
||||||
+ fi
|
+ fi
|
||||||
+ if test -n "$USE_SSL"; then
|
+ if test -n "$USE_SSL"; then
|
||||||
echo "SSL"
|
echo "SSL"
|
||||||
fi
|
fi
|
||||||
if test "@KRB4_ENABLED@" = "1"; then
|
if test "@KRB4_ENABLED@" = "1"; then
|
||||||
@@ -112,13 +114,13 @@
|
@@ -113,13 +115,13 @@
|
||||||
--protocols)
|
--protocols)
|
||||||
if test "@CURL_DISABLE_HTTP@" != "1"; then
|
if test "@CURL_DISABLE_HTTP@" != "1"; then
|
||||||
echo "HTTP"
|
echo "HTTP"
|
||||||
- if test "@USE_SSLEAY@" = "1"; then
|
- if test "@SSL_ENABLED@" = "1"; then
|
||||||
+ if test "$USE_SSL" = "1"; then
|
+ if test "$USE_SSL" = "1"; then
|
||||||
echo "HTTPS"
|
echo "HTTPS"
|
||||||
fi
|
fi
|
||||||
fi
|
fi
|
||||||
if test "@CURL_DISABLE_FTP@" != "1"; then
|
if test "@CURL_DISABLE_FTP@" != "1"; then
|
||||||
echo "FTP"
|
echo "FTP"
|
||||||
- if test "@USE_SSLEAY@" = "1"; then
|
- if test "@SSL_ENABLED@" = "1"; then
|
||||||
+ if test "$USE_SSL" = "1"; then
|
+ if test "$USE_SSL" = "1"; then
|
||||||
echo "FTPS"
|
echo "FTPS"
|
||||||
fi
|
fi
|
||||||
|
17
curl.spec
17
curl.spec
@ -1,15 +1,14 @@
|
|||||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||||
Name: curl
|
Name: curl
|
||||||
Version: 7.17.1
|
Version: 7.18.0
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
|
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
|
||||||
Patch1: curl-7.15.3-multilib.patch
|
Patch1: curl-7.15.3-multilib.patch
|
||||||
Patch2: curl-7.16.0-privlibs.patch
|
Patch2: curl-7.16.0-privlibs.patch
|
||||||
Patch3: curl-7.16.4-curl-config.patch
|
Patch3: curl-7.16.4-curl-config.patch
|
||||||
Patch4: curl-7.17.1-sslgen.patch
|
Patch4: curl-7.17.1-badsocket.patch
|
||||||
Patch5: curl-7.17.1-badsocket.patch
|
|
||||||
Provides: webclient
|
Provides: webclient
|
||||||
URL: http://curl.haxx.se/
|
URL: http://curl.haxx.se/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -20,7 +19,7 @@ BuildRequires: nss-devel >= 3.11.7-7, openldap-devel, krb5-devel
|
|||||||
cURL is a tool for getting files from HTTP, FTP, FILE, LDAP, LDAPS,
|
cURL is a tool for getting files from HTTP, FTP, FILE, LDAP, LDAPS,
|
||||||
DICT, TELNET and TFTP servers, using any of the supported protocols.
|
DICT, TELNET and TFTP servers, using any of the supported protocols.
|
||||||
cURL is designed to work without user interaction or any kind of
|
cURL is designed to work without user interaction or any kind of
|
||||||
interactivity. cURL 5;3~offers many useful capabilities, like proxy support,
|
interactivity. cURL offers many useful capabilities, like proxy support,
|
||||||
user authentication, FTP upload, HTTP post, and file transfer resume.
|
user authentication, FTP upload, HTTP post, and file transfer resume.
|
||||||
|
|
||||||
%package -n libcurl
|
%package -n libcurl
|
||||||
@ -50,8 +49,7 @@ use cURL's capabilities internally.
|
|||||||
%patch1 -p1 -b .multilib
|
%patch1 -p1 -b .multilib
|
||||||
%patch2 -p1 -b .privlibs
|
%patch2 -p1 -b .privlibs
|
||||||
%patch3 -p1 -b .curl-config
|
%patch3 -p1 -b .curl-config
|
||||||
%patch4 -p1 -b .sslgen
|
%patch4 -p1 -b .badsocket
|
||||||
%patch5 -p1 -b .badsocket
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CPPFLAGS="$(pkg-config --cflags nss) -DHAVE_PK11_CREATEGENERICOBJECT"
|
export CPPFLAGS="$(pkg-config --cflags nss) -DHAVE_PK11_CREATEGENERICOBJECT"
|
||||||
@ -108,6 +106,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/aclocal/libcurl.m4
|
%{_datadir}/aclocal/libcurl.m4
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 28 2008 Jindrich Novy <jnovy@redhat.com> 7.18.0-1
|
||||||
|
- update to curl-7.18.0
|
||||||
|
- drop sslgen patch -> applied upstream
|
||||||
|
- fix typo in description
|
||||||
|
|
||||||
* Tue Jan 22 2008 Jindrich Novy <jnovy@redhat.com> 7.17.1-6
|
* Tue Jan 22 2008 Jindrich Novy <jnovy@redhat.com> 7.17.1-6
|
||||||
- fix curl-devel obsoletes so that we don't break F8->F9 upgrade
|
- fix curl-devel obsoletes so that we don't break F8->F9 upgrade
|
||||||
path (#429612)
|
path (#429612)
|
||||||
|
Loading…
Reference in New Issue
Block a user