new upstream release - 7.48.0
This commit is contained in:
parent
e2daf98253
commit
b041400317
@ -1,47 +0,0 @@
|
||||
From 090ee789dda468fe0d9b715ec4e5dc47a948a239 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Tim=20R=C3=BChsen?= <tim.ruehsen@gmx.de>
|
||||
Date: Wed, 2 Mar 2016 11:07:16 +0100
|
||||
Subject: [PATCH] cookie: do not refuse cookies for localhost
|
||||
|
||||
Closes #658
|
||||
---
|
||||
lib/cookie.c | 10 ++++++----
|
||||
tests/data/test1136 | 1 +
|
||||
2 files changed, 7 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/lib/cookie.c b/lib/cookie.c
|
||||
index d62f446..e5c7b7e 100644
|
||||
--- a/lib/cookie.c
|
||||
+++ b/lib/cookie.c
|
||||
@@ -788,10 +788,12 @@ Curl_cookie_add(struct SessionHandle *data,
|
||||
#ifdef USE_LIBPSL
|
||||
/* Check if the domain is a Public Suffix and if yes, ignore the cookie.
|
||||
This needs a libpsl compiled with builtin data. */
|
||||
- if(co->domain && !isip(co->domain) && (psl = psl_builtin()) != NULL) {
|
||||
- if(psl_is_public_suffix(psl, co->domain)) {
|
||||
- infof(data, "cookie '%s' dropped, domain '%s' is a public suffix\n",
|
||||
- co->name, co->domain);
|
||||
+ if(domain && co->domain && !isip(co->domain)) {
|
||||
+ if (((psl = psl_builtin()) != NULL)
|
||||
+ && !psl_is_cookie_domain_acceptable(psl, domain, co->domain)) {
|
||||
+ infof(data,
|
||||
+ "cookie '%s' dropped, domain '%s' must not set cookies for '%s'\n",
|
||||
+ co->name, domain, co->domain);
|
||||
freecookie(co);
|
||||
return NULL;
|
||||
}
|
||||
diff --git a/tests/data/test1136 b/tests/data/test1136
|
||||
index e42ca06..d3327e8 100644
|
||||
--- a/tests/data/test1136
|
||||
+++ b/tests/data/test1136
|
||||
@@ -58,6 +58,7 @@ http://www.example.ck/1136 http://www.ck/1136 http://z-1.compute-1.amazonaws.com
|
||||
|
||||
.www.example.ck TRUE / FALSE 0 test2 allowed2
|
||||
.www.ck TRUE / FALSE 0 test4 allowed4
|
||||
+.z-1.compute-1.amazonaws.com TRUE / FALSE 0 test5 forbidden5
|
||||
</file>
|
||||
</verify>
|
||||
</testcase>
|
||||
--
|
||||
2.5.0
|
||||
|
@ -12,7 +12,7 @@ diff --git a/configure b/configure
|
||||
index 8f079a3..53b4774 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -16017,18 +16017,11 @@ $as_echo "yes" >&6; }
|
||||
@@ -16617,18 +16617,11 @@ $as_echo "yes" >&6; }
|
||||
gccvhi=`echo $gccver | cut -d . -f1`
|
||||
gccvlo=`echo $gccver | cut -d . -f2`
|
||||
compiler_num=`(expr $gccvhi "*" 100 + $gccvlo) 2>/dev/null`
|
||||
@ -33,7 +33,7 @@ index 8f079a3..53b4774 100755
|
||||
+ flags_opt_yes=""
|
||||
flags_opt_off="-O0"
|
||||
|
||||
if test -z "$SED"; then
|
||||
OLDCPPFLAGS=$CPPFLAGS
|
||||
diff --git a/m4/curl-compilers.m4 b/m4/curl-compilers.m4
|
||||
index 0cbba7a..9175b5b 100644
|
||||
--- a/m4/curl-compilers.m4
|
||||
|
@ -12,8 +12,8 @@ diff --git a/tests/data/test165 b/tests/data/test165
|
||||
index ddfe1e9..b2cbc4f 100644
|
||||
--- a/tests/data/test165
|
||||
+++ b/tests/data/test165
|
||||
@@ -54,5 +54,8 @@ Accept: */*
|
||||
Proxy-Connection: Keep-Alive
|
||||
@@ -53,5 +53,8 @@ Host: www.xn--4cab6c.se
|
||||
Accept: */*
|
||||
|
||||
</protocol>
|
||||
+<valgrind>
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1
|
||||
|
||||
iEYEABECAAYFAla4X80ACgkQeOEcayedXJFLWACglcsd1JCV1a5mQlzMVI166llH
|
||||
66oAn3wjtUvix9Gn59EGwBz1k5Kby2gH
|
||||
=Zg6S
|
||||
-----END PGP SIGNATURE-----
|
7
curl-7.48.0.tar.lzma.asc
Normal file
7
curl-7.48.0.tar.lzma.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1
|
||||
|
||||
iEYEABECAAYFAlbyPqAACgkQeOEcayedXJHnxQCgiQ5JvClsu1EWLgDFM4aqAsZf
|
||||
mmYAnizZMyraOk0q42/1A/0GnkavRUx1
|
||||
=rVbn
|
||||
-----END PGP SIGNATURE-----
|
11
curl.spec
11
curl.spec
@ -1,15 +1,12 @@
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.47.1
|
||||
Release: 4%{?dist}
|
||||
Version: 7.48.0
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Group: Applications/Internet
|
||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
|
||||
Source2: curlbuild.h
|
||||
|
||||
# do not refuse cookies for localhost (#1308791)
|
||||
Patch1: 0001-curl-7.47.1-psl-localhost.patch
|
||||
|
||||
# patch making libcurl multilib ready
|
||||
Patch101: 0101-curl-7.32.0-multilib.patch
|
||||
|
||||
@ -121,7 +118,6 @@ documentation of the library, too.
|
||||
%setup -q
|
||||
|
||||
# upstream patches
|
||||
%patch1 -p1
|
||||
|
||||
# Fedora patches
|
||||
%patch101 -p1
|
||||
@ -234,6 +230,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/aclocal/libcurl.m4
|
||||
|
||||
%changelog
|
||||
* Wed Mar 23 2016 Kamil Dudka <kdudka@redhat.com> 7.48.0-1
|
||||
- new upstream release
|
||||
|
||||
* Wed Mar 02 2016 Kamil Dudka <kdudka@redhat.com> 7.47.1-4
|
||||
- do not refuse cookies for localhost (#1308791)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user