avoid an invalid timeout event on a reused handle (#679709)
This commit is contained in:
parent
39828449b7
commit
a80b6c3aa4
29
0001-curl-7.21.6-f551aa5.patch
Normal file
29
0001-curl-7.21.6-f551aa5.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From ef22ddf278431ab39924ac468ab4b31ee6e5af95 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Tue, 7 Jun 2011 15:57:13 +0200
|
||||
Subject: [PATCH] disconnect: wipe out the keeps_speed time stamp
|
||||
|
||||
When closing a connection, the speedchecker's timestamp is now deleted
|
||||
so that it cannot accidentally be used by a fresh connection on the same
|
||||
handle when examining the transfer speed.
|
||||
|
||||
Bug: https://bugzilla.redhat.com/679709
|
||||
---
|
||||
lib/url.c | 1 +
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/lib/url.c b/lib/url.c
|
||||
index 3bc8db0..9f8c2c4 100644
|
||||
--- a/lib/url.c
|
||||
+++ b/lib/url.c
|
||||
@@ -2671,6 +2671,7 @@ CURLcode Curl_disconnect(struct connectdata *conn, bool dead_connection)
|
||||
|
||||
conn_free(conn);
|
||||
data->state.current_conn = NULL;
|
||||
+ Curl_speedinit(data);
|
||||
|
||||
return CURLE_OK;
|
||||
}
|
||||
--
|
||||
1.7.4.4
|
||||
|
@ -6,7 +6,7 @@ diff --git a/configure b/configure
|
||||
index d3ecf69..6d8f085 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -14222,18 +14222,11 @@ $as_echo "yes" >&6; }
|
||||
@@ -15001,18 +15001,11 @@ $as_echo "yes" >&6; }
|
||||
gccvhi=`echo $gccver | cut -d . -f1`
|
||||
gccvlo=`echo $gccver | cut -d . -f2`
|
||||
compiler_num=`(expr $gccvhi "*" 100 + $gccvlo) 2>/dev/null`
|
||||
|
@ -19,7 +19,7 @@ diff --git a/tests/data/Makefile.in b/tests/data/Makefile.in
|
||||
index 435b126..1d71c4e 100644
|
||||
--- a/tests/data/Makefile.in
|
||||
+++ b/tests/data/Makefile.in
|
||||
@@ -307,7 +307,7 @@ EXTRA_DIST = test1 test108 test117 test1
|
||||
@@ -308,7 +308,7 @@ EXTRA_DIST = test1 test108 test117 test1
|
||||
test561 test1098 test1099 test562 test563 test1100 test564 test1101 \
|
||||
test1102 test1103 test1104 test299 test310 test311 test312 test1105 \
|
||||
test565 test800 test1106 test801 test566 test802 test803 test1107 \
|
||||
|
11
curl.spec
11
curl.spec
@ -1,13 +1,16 @@
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.21.6
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: MIT
|
||||
Group: Applications/Internet
|
||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
|
||||
Source2: curlbuild.h
|
||||
Source3: hide_selinux.c
|
||||
|
||||
# avoid an invalid timeout event on a reused handle (#679709)
|
||||
Patch1: 0001-curl-7.21.6-f551aa5.patch
|
||||
|
||||
# patch making libcurl multilib ready
|
||||
Patch101: 0101-curl-7.21.1-multilib.patch
|
||||
|
||||
@ -106,6 +109,9 @@ for f in CHANGES README; do
|
||||
mv -f ${f}.utf8 ${f}
|
||||
done
|
||||
|
||||
# upstream patches (already applied)
|
||||
%patch1 -p1
|
||||
|
||||
# Fedora patches
|
||||
%patch101 -p1
|
||||
%patch102 -p1
|
||||
@ -218,6 +224,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/aclocal/libcurl.m4
|
||||
|
||||
%changelog
|
||||
* Wed Jun 08 2011 Kamil Dudka <kdudka@redhat.com> 7.21.6-2
|
||||
- avoid an invalid timeout event on a reused handle (#679709)
|
||||
|
||||
* Sat Apr 23 2011 Paul Howarth <paul@city-fan.org> 7.21.6-1
|
||||
- new upstream release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user