new upstream release - 7.34.0
This commit is contained in:
parent
5fc861594c
commit
a16bdb8ecc
@ -1,32 +0,0 @@
|
||||
From 2a9dd8d2e6d013c1c2ed7f5e12b4bcc89cc8f3bb Mon Sep 17 00:00:00 2001
|
||||
From: Steve Holme <steve_holme@hotmail.com>
|
||||
Date: Tue, 15 Oct 2013 21:31:14 +0100
|
||||
Subject: [PATCH] test906: Fixed failing test on some platforms
|
||||
|
||||
Bug: http://sourceforge.net/p/curl/bugs/1291
|
||||
Reported-by: David Walser
|
||||
|
||||
[upstream commit 4d49ffe165a51d45cef79bf81cb867dbcf06b092]
|
||||
|
||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
||||
---
|
||||
tests/data/test906 | 3 +++
|
||||
1 files changed, 3 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/tests/data/test906 b/tests/data/test906
|
||||
index 5072e90..6cf6bed 100644
|
||||
--- a/tests/data/test906
|
||||
+++ b/tests/data/test906
|
||||
@@ -41,6 +41,9 @@ mail body
|
||||
<command>
|
||||
smtp://%HOSTIP:%SMTPPORT/906 --mail-rcpt recipient@example.com --mail-from sender@example.com -u testuser:testpass -T -
|
||||
</command>
|
||||
+<precheck>
|
||||
+chkhostname curlhost
|
||||
+</precheck>
|
||||
</client>
|
||||
|
||||
#
|
||||
--
|
||||
1.7.1
|
||||
|
@ -1,44 +0,0 @@
|
||||
From 8002bea97bdea4fcade466de2b88172ba03d5259 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Fri, 18 Oct 2013 15:37:18 +0200
|
||||
Subject: [PATCH] curl_sasl: initialize NSS before using crypto
|
||||
|
||||
[upstream commit 86c64f3daf0079e96f4694b10fe1bc53944110fc]
|
||||
---
|
||||
lib/curl_sasl.c | 13 ++++++++++++-
|
||||
1 files changed, 12 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/lib/curl_sasl.c b/lib/curl_sasl.c
|
||||
index b3ffc66..9a0bc0f 100644
|
||||
--- a/lib/curl_sasl.c
|
||||
+++ b/lib/curl_sasl.c
|
||||
@@ -40,6 +40,10 @@
|
||||
#include "warnless.h"
|
||||
#include "curl_memory.h"
|
||||
|
||||
+#ifdef USE_NSS
|
||||
+#include "nssg.h" /* for Curl_nss_force_init() */
|
||||
+#endif
|
||||
+
|
||||
#define _MPRINTF_REPLACE /* use our functions only */
|
||||
#include <curl/mprintf.h>
|
||||
|
||||
@@ -468,7 +472,14 @@ CURLcode Curl_sasl_create_ntlm_type3_message(struct SessionHandle *data,
|
||||
struct ntlmdata *ntlm,
|
||||
char **outptr, size_t *outlen)
|
||||
{
|
||||
- CURLcode result = Curl_ntlm_decode_type2_message(data, header, ntlm);
|
||||
+ CURLcode result;
|
||||
+#ifdef USE_NSS
|
||||
+ /* make sure the crypto backend is initialized */
|
||||
+ result = Curl_nss_force_init(data);
|
||||
+ if(result)
|
||||
+ return result;
|
||||
+#endif
|
||||
+ result = Curl_ntlm_decode_type2_message(data, header, ntlm);
|
||||
|
||||
if(!result)
|
||||
result = Curl_ntlm_create_type3_message(data, userp, passwdp, ntlm,
|
||||
--
|
||||
1.7.1
|
||||
|
@ -1,32 +0,0 @@
|
||||
From 06c74b11fa976246307fbcbd36f71f59f2beaa6f Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Mon, 21 Oct 2013 18:47:54 +0200
|
||||
Subject: [PATCH] ssh: initialize per-handle data in ssh_connect()
|
||||
|
||||
... if not already initialized. This fixes a regression introduced by
|
||||
commit 4ad8e142da463ab208d5b5565e53291c8e5ef038, which caused test619
|
||||
to intermittently fail on certain machines (namely Fedora build hosts).
|
||||
|
||||
[upstream commit f70b2c77f4889316acb75d41e97a7f28c9a6a995]
|
||||
---
|
||||
lib/ssh.c | 4 ++++
|
||||
1 files changed, 4 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/lib/ssh.c b/lib/ssh.c
|
||||
index 79f58bb..e8b8b7c 100644
|
||||
--- a/lib/ssh.c
|
||||
+++ b/lib/ssh.c
|
||||
@@ -2719,6 +2719,10 @@ static CURLcode ssh_connect(struct connectdata *conn, bool *done)
|
||||
CURLcode result;
|
||||
struct SessionHandle *data = conn->data;
|
||||
|
||||
+ /* initialize per-handle data if not already */
|
||||
+ if(!data->req.protop)
|
||||
+ ssh_setup_connection(conn);
|
||||
+
|
||||
/* We default to persistent connections. We set this already in this connect
|
||||
function to make the re-use checks properly be able to check this bit. */
|
||||
conn->bits.close = FALSE;
|
||||
--
|
||||
1.7.1
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -12,7 +12,7 @@ diff --git a/configure b/configure
|
||||
index 8f079a3..53b4774 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -16000,18 +16000,11 @@ $as_echo "yes" >&6; }
|
||||
@@ -15999,18 +15999,11 @@ $as_echo "yes" >&6; }
|
||||
gccvhi=`echo $gccver | cut -d . -f1`
|
||||
gccvlo=`echo $gccver | cut -d . -f2`
|
||||
compiler_num=`(expr $gccvhi "*" 100 + $gccvlo) 2>/dev/null`
|
||||
|
@ -12,7 +12,7 @@ diff --git a/configure b/configure
|
||||
index a466175..cb63075 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -15465,13 +15465,9 @@ fi
|
||||
@@ -15464,13 +15464,9 @@ fi
|
||||
|
||||
|
||||
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.15 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlJcAyIACgkQeOEcayedXJGmzgCgiGvAZ1jUvbBw/ywZSday3J9j
|
||||
KucAn2xv4XLijiR4cDH6z8bnN0zH+lpk
|
||||
=o6A/
|
||||
-----END PGP SIGNATURE-----
|
7
curl-7.34.0.tar.lzma.asc
Normal file
7
curl-7.34.0.tar.lzma.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.15 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlKwApYACgkQeOEcayedXJFJBwCffGnq3xU7TrvmolGByalNcwAj
|
||||
lcUAoJdHDyD3IFQ98N0sCjKE6SKDTZMi
|
||||
=Mx7t
|
||||
-----END PGP SIGNATURE-----
|
23
curl.spec
23
curl.spec
@ -1,24 +1,12 @@
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.33.0
|
||||
Release: 2%{?dist}
|
||||
Version: 7.34.0
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Group: Applications/Internet
|
||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
|
||||
Source2: curlbuild.h
|
||||
|
||||
# test906: Fixed failing test on some platforms
|
||||
Patch1: 0001-curl-7.33.0-4d49ffe1.patch
|
||||
|
||||
# fix missing initialization in NTLM code causing test 906 to fail
|
||||
Patch2: 0002-curl-7.33.0-86c64f3d.patch
|
||||
|
||||
# fix missing initialization in SSH code causing test 619 to fail
|
||||
Patch3: 0003-curl-7.33.0-f70b2c77.patch
|
||||
|
||||
# allow to use TLS > 1.0 if built against recent NSS
|
||||
Patch4: 0004-curl-7.33.0-7fc9325a.patch
|
||||
|
||||
# patch making libcurl multilib ready
|
||||
Patch101: 0101-curl-7.32.0-multilib.patch
|
||||
|
||||
@ -116,10 +104,6 @@ documentation of the library, too.
|
||||
%setup -q
|
||||
|
||||
# upstream patches
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
# Fedora patches
|
||||
%patch101 -p1
|
||||
@ -238,6 +222,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/aclocal/libcurl.m4
|
||||
|
||||
%changelog
|
||||
* Wed Dec 18 2013 Kamil Dudka <kdudka@redhat.com> 7.34.0-1
|
||||
- new upstream release
|
||||
|
||||
* Mon Dec 02 2013 Kamil Dudka <kdudka@redhat.com> 7.33.0-2
|
||||
- allow to use TLS > 1.0 if built against recent NSS
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user