new upstream release - 7.65.1
This commit is contained in:
parent
b6ccff47ac
commit
901da63160
@ -1,203 +0,0 @@
|
|||||||
From f2cc9d8d194c4eef706cb5470bdf6f7483b4e3cf Mon Sep 17 00:00:00 2001
|
|
||||||
From: Daniel Stenberg <daniel@haxx.se>
|
|
||||||
Date: Wed, 22 May 2019 23:15:34 +0200
|
|
||||||
Subject: [PATCH] Revert "progress: CURL_DISABLE_PROGRESS_METER"
|
|
||||||
|
|
||||||
This reverts commit 3b06e68b7734cb10a555f9d7e804dd5d808236a4.
|
|
||||||
|
|
||||||
Clearly this change wasn't good enough as it broke CURLOPT_LOW_SPEED_LIMIT +
|
|
||||||
CURLOPT_LOW_SPEED_TIME
|
|
||||||
|
|
||||||
Reported-by: Dave Reisner
|
|
||||||
|
|
||||||
Fixes #3927
|
|
||||||
Closes #3928
|
|
||||||
|
|
||||||
Upstream-commit: c6b58137237a89081b4efc33ae0ecf7282e40132
|
|
||||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
|
||||||
---
|
|
||||||
lib/progress.c | 110 ++++++++++++++++++++++---------------------------
|
|
||||||
1 file changed, 49 insertions(+), 61 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/lib/progress.c b/lib/progress.c
|
|
||||||
index f586d59b4..fe9929bb9 100644
|
|
||||||
--- a/lib/progress.c
|
|
||||||
+++ b/lib/progress.c
|
|
||||||
@@ -5,7 +5,7 @@
|
|
||||||
* | (__| |_| | _ <| |___
|
|
||||||
* \___|\___/|_| \_\_____|
|
|
||||||
*
|
|
||||||
- * Copyright (C) 1998 - 2019, Daniel Stenberg, <daniel@haxx.se>, et al.
|
|
||||||
+ * Copyright (C) 1998 - 2018, Daniel Stenberg, <daniel@haxx.se>, et al.
|
|
||||||
*
|
|
||||||
* This software is licensed as described in the file COPYING, which
|
|
||||||
* you should have received as part of this distribution. The terms
|
|
||||||
@@ -31,7 +31,6 @@
|
|
||||||
/* check rate limits within this many recent milliseconds, at minimum. */
|
|
||||||
#define MIN_RATE_LIMIT_PERIOD 3000
|
|
||||||
|
|
||||||
-#ifndef CURL_DISABLE_PROGRESS_METER
|
|
||||||
/* Provide a string that is 2 + 1 + 2 + 1 + 2 = 8 letters long (plus the zero
|
|
||||||
byte) */
|
|
||||||
static void time2str(char *r, curl_off_t seconds)
|
|
||||||
@@ -120,7 +119,6 @@ static char *max5data(curl_off_t bytes, char *max5)
|
|
||||||
|
|
||||||
return max5;
|
|
||||||
}
|
|
||||||
-#endif
|
|
||||||
|
|
||||||
/*
|
|
||||||
|
|
||||||
@@ -364,13 +362,17 @@ void Curl_pgrsSetUploadSize(struct Curl_easy *data, curl_off_t size)
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
-#ifndef CURL_DISABLE_PROGRESS_METER
|
|
||||||
-static void progress_meter(struct connectdata *conn)
|
|
||||||
+/*
|
|
||||||
+ * Curl_pgrsUpdate() returns 0 for success or the value returned by the
|
|
||||||
+ * progress callback!
|
|
||||||
+ */
|
|
||||||
+int Curl_pgrsUpdate(struct connectdata *conn)
|
|
||||||
{
|
|
||||||
struct curltime now;
|
|
||||||
curl_off_t timespent;
|
|
||||||
curl_off_t timespent_ms; /* milliseconds */
|
|
||||||
struct Curl_easy *data = conn->data;
|
|
||||||
+ int nowindex = data->progress.speeder_c% CURR_TIME;
|
|
||||||
bool shownow = FALSE;
|
|
||||||
curl_off_t dl = data->progress.downloaded;
|
|
||||||
curl_off_t ul = data->progress.uploaded;
|
|
||||||
@@ -397,9 +399,7 @@ static void progress_meter(struct connectdata *conn)
|
|
||||||
/* Calculations done at most once a second, unless end is reached */
|
|
||||||
if(data->progress.lastshow != now.tv_sec) {
|
|
||||||
int countindex; /* amount of seconds stored in the speeder array */
|
|
||||||
- int nowindex = data->progress.speeder_c% CURR_TIME;
|
|
||||||
- if(!(data->progress.flags & PGRS_HIDE))
|
|
||||||
- shownow = TRUE;
|
|
||||||
+ shownow = TRUE;
|
|
||||||
|
|
||||||
data->progress.lastshow = now.tv_sec;
|
|
||||||
|
|
||||||
@@ -461,12 +461,8 @@ static void progress_meter(struct connectdata *conn)
|
|
||||||
data->progress.ulspeed + data->progress.dlspeed;
|
|
||||||
|
|
||||||
} /* Calculations end */
|
|
||||||
- if(!shownow)
|
|
||||||
- /* only show the internal progress meter once per second */
|
|
||||||
- return;
|
|
||||||
- else {
|
|
||||||
- /* If there's no external callback set, use internal code to show
|
|
||||||
- progress */
|
|
||||||
+
|
|
||||||
+ if(!(data->progress.flags & PGRS_HIDE)) {
|
|
||||||
/* progress meter has not been shut off */
|
|
||||||
char max5[6][10];
|
|
||||||
curl_off_t dlpercen = 0;
|
|
||||||
@@ -481,6 +477,42 @@ static void progress_meter(struct connectdata *conn)
|
|
||||||
curl_off_t dlestimate = 0;
|
|
||||||
curl_off_t total_estimate;
|
|
||||||
|
|
||||||
+ if(data->set.fxferinfo) {
|
|
||||||
+ int result;
|
|
||||||
+ /* There's a callback set, call that */
|
|
||||||
+ Curl_set_in_callback(data, true);
|
|
||||||
+ result = data->set.fxferinfo(data->set.progress_client,
|
|
||||||
+ data->progress.size_dl,
|
|
||||||
+ data->progress.downloaded,
|
|
||||||
+ data->progress.size_ul,
|
|
||||||
+ data->progress.uploaded);
|
|
||||||
+ Curl_set_in_callback(data, false);
|
|
||||||
+ if(result)
|
|
||||||
+ failf(data, "Callback aborted");
|
|
||||||
+ return result;
|
|
||||||
+ }
|
|
||||||
+ if(data->set.fprogress) {
|
|
||||||
+ int result;
|
|
||||||
+ /* The older deprecated callback is set, call that */
|
|
||||||
+ Curl_set_in_callback(data, true);
|
|
||||||
+ result = data->set.fprogress(data->set.progress_client,
|
|
||||||
+ (double)data->progress.size_dl,
|
|
||||||
+ (double)data->progress.downloaded,
|
|
||||||
+ (double)data->progress.size_ul,
|
|
||||||
+ (double)data->progress.uploaded);
|
|
||||||
+ Curl_set_in_callback(data, false);
|
|
||||||
+ if(result)
|
|
||||||
+ failf(data, "Callback aborted");
|
|
||||||
+ return result;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ if(!shownow)
|
|
||||||
+ /* only show the internal progress meter once per second */
|
|
||||||
+ return 0;
|
|
||||||
+
|
|
||||||
+ /* If there's no external callback set, use internal code to show
|
|
||||||
+ progress */
|
|
||||||
+
|
|
||||||
if(!(data->progress.flags & PGRS_HEADERS_OUT)) {
|
|
||||||
if(data->state.resume_from) {
|
|
||||||
fprintf(data->set.err,
|
|
||||||
@@ -563,57 +595,13 @@ static void progress_meter(struct connectdata *conn)
|
|
||||||
time_total, /* 8 letters */ /* total time */
|
|
||||||
time_spent, /* 8 letters */ /* time spent */
|
|
||||||
time_left, /* 8 letters */ /* time left */
|
|
||||||
- max5data(data->progress.current_speed, max5[5])
|
|
||||||
- );
|
|
||||||
+ max5data(data->progress.current_speed, max5[5]) /* current speed */
|
|
||||||
+ );
|
|
||||||
|
|
||||||
/* we flush the output stream to make it appear as soon as possible */
|
|
||||||
fflush(data->set.err);
|
|
||||||
- } /* don't show now */
|
|
||||||
-}
|
|
||||||
-#else
|
|
||||||
- /* progress bar disabled */
|
|
||||||
-#define progress_meter(x)
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
|
|
||||||
-/*
|
|
||||||
- * Curl_pgrsUpdate() returns 0 for success or the value returned by the
|
|
||||||
- * progress callback!
|
|
||||||
- */
|
|
||||||
-int Curl_pgrsUpdate(struct connectdata *conn)
|
|
||||||
-{
|
|
||||||
- struct Curl_easy *data = conn->data;
|
|
||||||
- if(!(data->progress.flags & PGRS_HIDE)) {
|
|
||||||
- if(data->set.fxferinfo) {
|
|
||||||
- int result;
|
|
||||||
- /* There's a callback set, call that */
|
|
||||||
- Curl_set_in_callback(data, true);
|
|
||||||
- result = data->set.fxferinfo(data->set.progress_client,
|
|
||||||
- data->progress.size_dl,
|
|
||||||
- data->progress.downloaded,
|
|
||||||
- data->progress.size_ul,
|
|
||||||
- data->progress.uploaded);
|
|
||||||
- Curl_set_in_callback(data, false);
|
|
||||||
- if(result)
|
|
||||||
- failf(data, "Callback aborted");
|
|
||||||
- return result;
|
|
||||||
- }
|
|
||||||
- if(data->set.fprogress) {
|
|
||||||
- int result;
|
|
||||||
- /* The older deprecated callback is set, call that */
|
|
||||||
- Curl_set_in_callback(data, true);
|
|
||||||
- result = data->set.fprogress(data->set.progress_client,
|
|
||||||
- (double)data->progress.size_dl,
|
|
||||||
- (double)data->progress.downloaded,
|
|
||||||
- (double)data->progress.size_ul,
|
|
||||||
- (double)data->progress.uploaded);
|
|
||||||
- Curl_set_in_callback(data, false);
|
|
||||||
- if(result)
|
|
||||||
- failf(data, "Callback aborted");
|
|
||||||
- return result;
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
- progress_meter(conn);
|
|
||||||
+ } /* !(data->progress.flags & PGRS_HIDE) */
|
|
||||||
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.20.1
|
|
||||||
|
|
@ -12,7 +12,7 @@ diff --git a/configure b/configure
|
|||||||
index 8f079a3..53b4774 100755
|
index 8f079a3..53b4774 100755
|
||||||
--- a/configure
|
--- a/configure
|
||||||
+++ b/configure
|
+++ b/configure
|
||||||
@@ -16273,18 +16273,11 @@ $as_echo "yes" >&6; }
|
@@ -16268,18 +16268,11 @@ $as_echo "yes" >&6; }
|
||||||
gccvhi=`echo $gccver | cut -d . -f1`
|
gccvhi=`echo $gccver | cut -d . -f1`
|
||||||
gccvlo=`echo $gccver | cut -d . -f2`
|
gccvlo=`echo $gccver | cut -d . -f2`
|
||||||
compiler_num=`(expr $gccvhi "*" 100 + $gccvlo) 2>/dev/null`
|
compiler_num=`(expr $gccvhi "*" 100 + $gccvlo) 2>/dev/null`
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
|
|
||||||
iQEzBAABCgAdFiEEJ+3q8i86vOtQ25oSXMkI/bceEsIFAlzk438ACgkQXMkI/bce
|
|
||||||
EsITWggAgk129Kxp4Br7Nn2+vyygKwv3dDEm87wJVuQka8gT2pZ9ZVQ6rEX9j0sR
|
|
||||||
RETf8KrEbSlOBgl2EJpgToL5kgiMCweTXced3VY2szVVibenBa2Zd9MpSl5Sf7hH
|
|
||||||
axinhdvEPNH+w8WuprEqZh+d/T5grAxChPJz4bLqKQI5fw5T3IuMfYTjZqx8DkOt
|
|
||||||
4FekihWCr6N/nW9BFOz8H19GFtotYSwoPvQJ+RmB7+Zt7ruHjRgyINCgxbWPvs4P
|
|
||||||
eZNWykqQ9FaXLSoJQYjLvEx0smye0bxSu3EIYBeL60fiFWJaSHQPyfBgC3JC+dD6
|
|
||||||
ufxhEk814I4XzPaRFTLjgzjmTqRMPw==
|
|
||||||
=4VIp
|
|
||||||
-----END PGP SIGNATURE-----
|
|
11
curl-7.65.1.tar.xz.asc
Normal file
11
curl-7.65.1.tar.xz.asc
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
|
||||||
|
iQEzBAABCgAdFiEEJ+3q8i86vOtQ25oSXMkI/bceEsIFAlz3WXoACgkQXMkI/bce
|
||||||
|
EsLceAgAg0RTq0HLyI2DtJyR4b60vKXTFizjIxEEBJ9NCjpxwUTg4q3H6tzIOuCR
|
||||||
|
PrPQXMADKtZpWwBDO1LV0CoUykw3vWxkG8uf5v/2GhdMdRGKm1TBgj1XN8SuAYTB
|
||||||
|
Srpus7LtyiIuElpOGUNNTIMcVXjT4ykJbLU61ykNSPc8IxK3KSY0C+dc/IpQQWQe
|
||||||
|
FmkMhuEpI4heu3uTmaj/UDs5LN+pv383XUTbMZvtgzDlquoyECGYX88+K6HC3doy
|
||||||
|
HiulXv99BUckmnCvbzL9Ly/QsbYq41UJLfc8HN4B1VtKTXkZJFyHwd8NMlSl8rQq
|
||||||
|
CLhRgj7IFk6VAEPpF3jJrmuvDxvdng==
|
||||||
|
=hzYt
|
||||||
|
-----END PGP SIGNATURE-----
|
11
curl.spec
11
curl.spec
@ -1,13 +1,10 @@
|
|||||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||||
Name: curl
|
Name: curl
|
||||||
Version: 7.65.0
|
Version: 7.65.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
|
Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# fix spurious timeout events with speed-limit (#1714893)
|
|
||||||
Patch1: 0001-curl-7.65.0-speed-limit-timeout.patch
|
|
||||||
|
|
||||||
# patch making libcurl multilib ready
|
# patch making libcurl multilib ready
|
||||||
Patch101: 0101-curl-7.32.0-multilib.patch
|
Patch101: 0101-curl-7.32.0-multilib.patch
|
||||||
|
|
||||||
@ -174,7 +171,6 @@ be installed.
|
|||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
# Fedora patches
|
# Fedora patches
|
||||||
%patch101 -p1
|
%patch101 -p1
|
||||||
@ -350,6 +346,9 @@ rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
|
|||||||
%{_libdir}/libcurl.so.4.[0-9].[0-9].minimal
|
%{_libdir}/libcurl.so.4.[0-9].[0-9].minimal
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 05 2019 Kamil Dudka <kdudka@redhat.com> - 7.65.1-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
* Thu May 30 2019 Kamil Dudka <kdudka@redhat.com> - 7.65.0-2
|
* Thu May 30 2019 Kamil Dudka <kdudka@redhat.com> - 7.65.0-2
|
||||||
- fix spurious timeout events with speed-limit (#1714893)
|
- fix spurious timeout events with speed-limit (#1714893)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (curl-7.65.0.tar.xz) = 032c065c1d4bd07ba028625f8fab6a09e7cb8505a5f19339b3abdee5a9cda7d091c11f075fe3fc227d082690a66c558c770a4cd9fb17b52acc13794976a770c5
|
SHA512 (curl-7.65.1.tar.xz) = aba2d979a416d14a0f0852d595665e49fc4f7bff3bee31f3a52b90ba9dc5ffdb09c092777f124215470b72c47ebca7ddb47844cbf5c0e9142099272b6ac55df4
|
||||||
|
Loading…
Reference in New Issue
Block a user