- update to 7.16.3
- drop .print patch, applied upstream - next series of merge review fixes by Paul Howarth - remove aclocal stuff, no more needed - simplify makefile arguments - don't reference standard library paths in libcurl.pc - include docs/CONTRIBUTE
This commit is contained in:
parent
01c1656558
commit
8520523ace
@ -3,3 +3,4 @@ curl-7.15.5.tar.bz2
|
|||||||
curl-7.16.0.tar.bz2
|
curl-7.16.0.tar.bz2
|
||||||
curl-7.16.1.tar.bz2
|
curl-7.16.1.tar.bz2
|
||||||
curl-7.16.2.tar.bz2
|
curl-7.16.2.tar.bz2
|
||||||
|
curl-7.16.3.tar.bz2
|
||||||
|
@ -1,46 +0,0 @@
|
|||||||
===================================================================
|
|
||||||
RCS file: /cvsroot/curl/curl/lib/progress.c,v
|
|
||||||
retrieving revision 1.83
|
|
||||||
retrieving revision 1.84
|
|
||||||
diff -u -r1.83 -r1.84
|
|
||||||
--- curl/lib/progress.c 2007/03/23 04:23:53 1.83
|
|
||||||
+++ curl/lib/progress.c 2007/04/18 20:02:41 1.84
|
|
||||||
@@ -245,6 +245,7 @@
|
|
||||||
long ulestimate=0;
|
|
||||||
long dlestimate=0;
|
|
||||||
long total_estimate;
|
|
||||||
+ bool shownow=FALSE;
|
|
||||||
|
|
||||||
now = Curl_tvnow(); /* what time is it */
|
|
||||||
|
|
||||||
@@ -266,6 +267,7 @@
|
|
||||||
|
|
||||||
/* Calculations done at most once a second, unless end is reached */
|
|
||||||
if(data->progress.lastshow != (long)now.tv_sec) {
|
|
||||||
+ shownow = TRUE;
|
|
||||||
|
|
||||||
data->progress.lastshow = now.tv_sec;
|
|
||||||
|
|
||||||
@@ -346,7 +348,12 @@
|
|
||||||
return result;
|
|
||||||
}
|
|
||||||
|
|
||||||
- /* If there's no external callback set, use internal code to show progress */
|
|
||||||
+ if(!shownow)
|
|
||||||
+ /* only show the internal progress meter once per second */
|
|
||||||
+ return 0;
|
|
||||||
+
|
|
||||||
+ /* If there's no external callback set, use internal code to show
|
|
||||||
+ progress */
|
|
||||||
|
|
||||||
if(!(data->progress.flags & PGRS_HEADERS_OUT)) {
|
|
||||||
if(data->reqdata.resume_from) {
|
|
||||||
@@ -422,7 +429,7 @@
|
|
||||||
/* we flush the output stream to make it appear as soon as possible */
|
|
||||||
fflush(data->set.err);
|
|
||||||
|
|
||||||
- }
|
|
||||||
+ } /* !(data->progress.flags & PGRS_HIDE) */
|
|
||||||
|
|
||||||
return 0;
|
|
||||||
}
|
|
34
curl.spec
34
curl.spec
@ -3,14 +3,13 @@
|
|||||||
|
|
||||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||||
Name: curl
|
Name: curl
|
||||||
Version: 7.16.2
|
Version: 7.16.3
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
|
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
|
||||||
Patch1: curl-7.15.3-multilib.patch
|
Patch1: curl-7.15.3-multilib.patch
|
||||||
Patch2: curl-7.16.0-privlibs.patch
|
Patch2: curl-7.16.0-privlibs.patch
|
||||||
Patch3: curl-7.16.2-print.patch
|
|
||||||
URL: http://curl.haxx.se/
|
URL: http://curl.haxx.se/
|
||||||
Requires: openssl
|
Requires: openssl
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -39,35 +38,26 @@ use cURL's capabilities internally.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .multilib
|
%patch1 -p1 -b .multilib
|
||||||
%patch2 -p1 -b .privlibs
|
%patch2 -p1 -b .privlibs
|
||||||
%patch3 -p1 -b .print
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
aclocal
|
|
||||||
libtoolize --force
|
|
||||||
./reconf
|
|
||||||
|
|
||||||
if pkg-config openssl ; then
|
if pkg-config openssl ; then
|
||||||
CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
|
CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
|
||||||
LDFLAGS=`pkg-config --libs openssl`; export LDFLAGS
|
LDFLAGS=`pkg-config --libs openssl`; export LDFLAGS
|
||||||
fi
|
fi
|
||||||
%configure --with-ssl=%{_prefix} --enable-ipv6 \
|
%configure --with-ssl=%{_prefix} --enable-ipv6 \
|
||||||
--with-ca-bundle=%{buildroot}%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
|
--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
|
||||||
--with-gssapi=%{_prefix}/kerberos --with-libidn \
|
--with-gssapi=%{_prefix}/kerberos --with-libidn \
|
||||||
--with-ldap-lib=libldap-%{ldap_version}.so.0 \
|
--with-ldap-lib=libldap-%{ldap_version}.so.0 \
|
||||||
--with-lber-lib=liblber-%{ldap_version}.so.0 \
|
--with-lber-lib=liblber-%{ldap_version}.so.0 \
|
||||||
--disable-static
|
--disable-static
|
||||||
|
sed -i -e 's,-L/usr/lib ,,g;s,-L/usr/lib64 ,,g;s,-L/usr/lib$,,g;s,-L/usr/lib64$,,g' \
|
||||||
|
Makefile libcurl.pc
|
||||||
make CFLAGS="$RPM_OPT_FLAGS" %{?_smp_mflags}
|
make CFLAGS="$RPM_OPT_FLAGS" %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
make INSTALL="%{__install} -p" \
|
make DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" install
|
||||||
prefix=%{buildroot}%{_prefix} \
|
|
||||||
includedir=%{buildroot}%{_includedir} \
|
|
||||||
libdir=%{buildroot}%{_libdir} \
|
|
||||||
bindir=%{buildroot}%{_bindir} \
|
|
||||||
mandir=%{buildroot}%{_mandir} \
|
|
||||||
install
|
|
||||||
|
|
||||||
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
|
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
|
||||||
install -d $RPM_BUILD_ROOT/%{_datadir}/aclocal
|
install -d $RPM_BUILD_ROOT/%{_datadir}/aclocal
|
||||||
@ -98,6 +88,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc docs/examples/*.c docs/examples/Makefile.example docs/INTERNALS
|
%doc docs/examples/*.c docs/examples/Makefile.example docs/INTERNALS
|
||||||
|
%doc docs/CONTRIBUTE
|
||||||
%{_bindir}/curl-config*
|
%{_bindir}/curl-config*
|
||||||
%{_includedir}/curl
|
%{_includedir}/curl
|
||||||
%{_libdir}/*.so
|
%{_libdir}/*.so
|
||||||
@ -107,12 +98,21 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/aclocal/libcurl.m4
|
%{_datadir}/aclocal/libcurl.m4
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 25 2007 Jindrich Novy <jnovy@redhat.com> 7.16.3-1
|
||||||
|
- update to 7.16.3
|
||||||
|
- drop .print patch, applied upstream
|
||||||
|
- next series of merge review fixes by Paul Howarth
|
||||||
|
- remove aclocal stuff, no more needed
|
||||||
|
- simplify makefile arguments
|
||||||
|
- don't reference standard library paths in libcurl.pc
|
||||||
|
- include docs/CONTRIBUTE
|
||||||
|
|
||||||
* Mon Jun 18 2007 Jindrich Novy <jnovy@redhat.com> 7.16.2-5
|
* Mon Jun 18 2007 Jindrich Novy <jnovy@redhat.com> 7.16.2-5
|
||||||
- don't print like crazy (#236981), backported from upstream CVS
|
- don't print like crazy (#236981), backported from upstream CVS
|
||||||
|
|
||||||
* Fri Jun 15 2007 Jindrich Novy <jnovy@redhat.com> 7.16.2-4
|
* Fri Jun 15 2007 Jindrich Novy <jnovy@redhat.com> 7.16.2-4
|
||||||
- another series of review fixes (#225671),
|
- another series of review fixes (#225671),
|
||||||
thanks to Paul Horwath
|
thanks to Paul Howarth
|
||||||
- check version of ldap library automatically
|
- check version of ldap library automatically
|
||||||
- don't use %%makeinstall and preserve timestamps
|
- don't use %%makeinstall and preserve timestamps
|
||||||
- drop useless patches
|
- drop useless patches
|
||||||
|
Loading…
Reference in New Issue
Block a user