new upstream release - 7.28.1
This commit is contained in:
parent
0f5dbc27da
commit
83db90f0ad
@ -4,9 +4,9 @@ Date: Wed, 31 Oct 2012 11:38:30 +0100
|
||||
Subject: [PATCH] prevent configure script from discarding -g in CFLAGS (#496778)
|
||||
|
||||
---
|
||||
configure | 15 ++++-----------
|
||||
m4/curl-compilers.m4 | 15 ++++-----------
|
||||
2 files changed, 8 insertions(+), 22 deletions(-)
|
||||
configure | 13 +++----------
|
||||
m4/curl-compilers.m4 | 13 +++----------
|
||||
2 files changed, 6 insertions(+), 20 deletions(-)
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 8f079a3..53b4774 100755
|
||||
@ -26,10 +26,9 @@ index 8f079a3..53b4774 100755
|
||||
- flags_dbg_all="$flags_dbg_all -gvms"
|
||||
+ flags_dbg_all=""
|
||||
flags_dbg_yes="-g"
|
||||
- flags_dbg_off="-g0"
|
||||
flags_dbg_off=""
|
||||
- flags_opt_all="-O -O0 -O1 -O2 -O3 -Os"
|
||||
- flags_opt_yes="-O2"
|
||||
+ flags_dbg_off=""
|
||||
+ flags_opt_all=""
|
||||
+ flags_opt_yes=""
|
||||
flags_opt_off="-O0"
|
||||
@ -53,10 +52,9 @@ index 0cbba7a..9175b5b 100644
|
||||
- flags_dbg_all="$flags_dbg_all -gvms"
|
||||
+ flags_dbg_all=""
|
||||
flags_dbg_yes="-g"
|
||||
- flags_dbg_off="-g0"
|
||||
flags_dbg_off=""
|
||||
- flags_opt_all="-O -O0 -O1 -O2 -O3 -Os"
|
||||
- flags_opt_yes="-O2"
|
||||
+ flags_dbg_off=""
|
||||
+ flags_opt_all=""
|
||||
+ flags_opt_yes=""
|
||||
flags_opt_off="-O0"
|
@ -6,15 +6,42 @@ Subject: [PATCH] Fix character encoding of docs
|
||||
..., which are of mixed encoding originally so a simple iconv can't
|
||||
fix them.
|
||||
---
|
||||
CHANGES | 16 ++++++++--------
|
||||
CHANGES | 22 +++++++++++-----------
|
||||
README | 2 +-
|
||||
2 files changed, 9 insertions(+), 9 deletions(-)
|
||||
2 files changed, 12 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/CHANGES b/CHANGES
|
||||
index 4568408..5fc1652 100644
|
||||
--- a/CHANGES
|
||||
+++ b/CHANGES
|
||||
@@ -338,7 +338,7 @@ Daniel Stenberg (8 Sep 2012)
|
||||
@@ -154,7 +154,7 @@ Daniel Stenberg (19 Nov 2012)
|
||||
|
||||
- RELEASE-NOTES: synced with fa1ae0abcde
|
||||
|
||||
-- [Cristian Rodríguez brought this change]
|
||||
+- [Cristian RodrÃguez brought this change]
|
||||
|
||||
OpenSSL: Disable SSL/TLS compression
|
||||
|
||||
@@ -209,7 +209,7 @@ Daniel Stenberg (12 Nov 2012)
|
||||
curl --digest -utest:test http://tomcat.test.com:8080/manager/list
|
||||
|
||||
This is because curl uses the same cnonce for several seconds, but
|
||||
- doesn't increment the nonce counter. Tomcat correctly interprets
|
||||
+ doesn't increment the nonce counter. Â Tomcat correctly interprets
|
||||
this as a replay attack and rejects the request.
|
||||
|
||||
When microsecond-precision is available, this commit causes curl to
|
||||
@@ -529,7 +529,7 @@ Daniel Stenberg (23 Oct 2012)
|
||||
|
||||
- href_extractor.c: fix the URL
|
||||
|
||||
-- [Michał Kowalczyk brought this change]
|
||||
+- [MichaÅ Kowalczyk brought this change]
|
||||
|
||||
href_extractor: example code extracting href elements
|
||||
|
||||
@@ -897,7 +897,7 @@ Daniel Stenberg (8 Sep 2012)
|
||||
|
||||
- test1411: verify SMTP without SIZE support
|
||||
|
||||
@ -23,7 +50,7 @@ index 4568408..5fc1652 100644
|
||||
|
||||
SMTP: only send SIZE if supported
|
||||
|
||||
@@ -1094,7 +1094,7 @@ Daniel Stenberg (9 Jul 2012)
|
||||
@@ -1653,7 +1653,7 @@ Daniel Stenberg (9 Jul 2012)
|
||||
|
||||
- cookie: fixed typo in comment
|
||||
|
||||
@ -32,7 +59,7 @@ index 4568408..5fc1652 100644
|
||||
|
||||
https_getsock: provided for schannel backend as well
|
||||
|
||||
@@ -1276,7 +1276,7 @@ Yang Tse (3 Jul 2012)
|
||||
@@ -1835,7 +1835,7 @@ Yang Tse (3 Jul 2012)
|
||||
testcurl.pl: fix missing semicolon
|
||||
|
||||
Daniel Stenberg (2 Jul 2012)
|
||||
@ -41,7 +68,7 @@ index 4568408..5fc1652 100644
|
||||
|
||||
unicode NTLM SSPI: heap corruption fixed
|
||||
|
||||
@@ -3385,18 +3385,18 @@ Daniel Stenberg (1 Apr 2012)
|
||||
@@ -3944,18 +3944,18 @@ Daniel Stenberg (1 Apr 2012)
|
||||
Reported by: Michael Wallner
|
||||
|
||||
Steve Holme (31 Mar 2012)
|
||||
@ -63,7 +90,7 @@ index 4568408..5fc1652 100644
|
||||
|
||||
md5: Add support for calculating the md5 sum of buffers incrementally
|
||||
|
||||
@@ -4688,7 +4688,7 @@ Daniel Stenberg (20 Dec 2011)
|
||||
@@ -5247,7 +5247,7 @@ Daniel Stenberg (20 Dec 2011)
|
||||
This offers an alternative to the existing Curl_socket_ready() API which
|
||||
only checks one socket for read and one for write.
|
||||
|
||||
@ -72,7 +99,7 @@ index 4568408..5fc1652 100644
|
||||
|
||||
curl.h: add __ANDROID__ macro check
|
||||
|
||||
@@ -4901,7 +4901,7 @@ Daniel Stenberg (12 Dec 2011)
|
||||
@@ -5460,7 +5460,7 @@ Daniel Stenberg (12 Dec 2011)
|
||||
linking with a static openssl requires a set of more libs to be linked
|
||||
on Windows.
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.12 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlB11D8ACgkQeOEcayedXJFNwwCg6vTYyoB5HjHRmfk8qdCMfrfv
|
||||
HZ0AmgOtmiIPJvhrXxV7TtcByz9u5qm8
|
||||
=VJDk
|
||||
-----END PGP SIGNATURE-----
|
7
curl-7.28.1.tar.lzma.asc
Normal file
7
curl-7.28.1.tar.lzma.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.12 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlCrLdwACgkQeOEcayedXJEWfACgwzpFlCeVscTbj9lVpcDstIeH
|
||||
Jy4AnjMtLsxo3wBfcLQg2vS/RqGVvLyq
|
||||
=NHEU
|
||||
-----END PGP SIGNATURE-----
|
14
curl.spec
14
curl.spec
@ -1,6 +1,6 @@
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.28.0
|
||||
Version: 7.28.1
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Group: Applications/Internet
|
||||
@ -12,7 +12,7 @@ Source3: hide_selinux.c
|
||||
Patch101: 0101-curl-7.27.0-multilib.patch
|
||||
|
||||
# prevent configure script from discarding -g in CFLAGS (#496778)
|
||||
Patch102: 0102-curl-7.28.0-debug.patch
|
||||
Patch102: 0102-curl-7.28.1-debug.patch
|
||||
|
||||
# use localhost6 instead of ip6-localhost in the curl test-suite
|
||||
Patch104: 0104-curl-7.19.7-localhost6.patch
|
||||
@ -25,7 +25,7 @@ Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
|
||||
|
||||
# Fix character encoding of docs, which are of mixed encoding originally so
|
||||
# a simple iconv can't fix them
|
||||
Patch108: 0108-curl-7.28.0-utf8.patch
|
||||
Patch108: 0108-curl-7.28.1-utf8.patch
|
||||
|
||||
Provides: webclient
|
||||
URL: http://curl.haxx.se/
|
||||
@ -115,9 +115,8 @@ cd tests/data/
|
||||
sed -i s/899\\\([0-9]\\\)/%{?__isa_bits}9\\1/ test*
|
||||
cd -
|
||||
|
||||
# disable test 1112 (#565305) and test 2032
|
||||
# <http://thread.gmane.org/gmane.comp.web.curl.library/37087>
|
||||
printf "1112\n2032\n" >> tests/data/DISABLED
|
||||
# disable test 1112 (#565305)
|
||||
printf "1112\n" >> tests/data/DISABLED
|
||||
|
||||
# disable test 1319 on ppc64 (server times out)
|
||||
%ifarch ppc64
|
||||
@ -225,6 +224,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/aclocal/libcurl.m4
|
||||
|
||||
%changelog
|
||||
* Tue Nov 20 2012 Kamil Dudka <kdudka@redhat.com> 7.28.1-1
|
||||
- new upstream release
|
||||
|
||||
* Wed Oct 31 2012 Kamil Dudka <kdudka@redhat.com> 7.28.0-1
|
||||
- new upstream release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user