new upstream release - 7.33.0

FIXME: test906 fails if compiled against NSS
This commit is contained in:
Kamil Dudka 2013-10-14 22:51:57 +02:00
parent 4ae7271a09
commit 7b8437e3a1
9 changed files with 16 additions and 154 deletions

View File

@ -1,42 +0,0 @@
From 204126a5f1218b7ba02c0abbd9703ee79d0d0776 Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Mon, 12 Aug 2013 15:14:35 +0200
Subject: [PATCH] nss: make sure that NSS is initialized
... prior to calling PK11_GenerateRandom()
---
lib/nss.c | 11 +++++++----
1 files changed, 7 insertions(+), 4 deletions(-)
diff --git a/lib/nss.c b/lib/nss.c
index cc3d9c9..2d4bf9e 100644
--- a/lib/nss.c
+++ b/lib/nss.c
@@ -1543,9 +1543,8 @@ size_t Curl_nss_version(char *buffer, size_t size)
int Curl_nss_seed(struct SessionHandle *data)
{
- /* TODO: implement? */
- (void) data;
- return 0;
+ /* make sure that NSS is initialized */
+ return !!Curl_nss_force_init(data);
}
void Curl_nss_random(struct SessionHandle *data,
@@ -1553,7 +1552,11 @@ void Curl_nss_random(struct SessionHandle *data,
size_t length)
{
Curl_nss_seed(data); /* Initiate the seed if not already done */
- PK11_GenerateRandom(entropy, curlx_uztosi(length));
+ if(SECSuccess != PK11_GenerateRandom(entropy, curlx_uztosi(length))) {
+ /* no way to signal a failure from here, we have to abort */
+ failf(data, "PK11_GenerateRandom() failed, calling abort()...");
+ abort();
+ }
}
void Curl_nss_md5sum(unsigned char *tmp, /* input */
--
1.7.1

View File

@ -1,43 +0,0 @@
From 8ec06ee49bac9191260b21e52c932da1101d83ef Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Mon, 9 Sep 2013 13:10:53 +0200
Subject: [PATCH] url: handle abortion by read/write callbacks, too
Otherwise, the FTP protocol would unnecessarily hang 60 seconds if
aborted in the CURLOPT_HEADERFUNCTION callback.
Reported by: Tomas Mlcoch
Bug: https://bugzilla.redhat.com/1005686
[upstream commit c639d725a37c91fb49bb3a689cb2596fad3a0645]
---
lib/url.c | 8 +++++++-
1 files changed, 7 insertions(+), 1 deletions(-)
diff --git a/lib/url.c b/lib/url.c
index 7cec5bc..80e1e67 100644
--- a/lib/url.c
+++ b/lib/url.c
@@ -5666,12 +5666,18 @@ CURLcode Curl_done(struct connectdata **connp,
conn->dns_entry = NULL;
}
- if(status == CURLE_ABORTED_BY_CALLBACK)
+ switch(status) {
+ case CURLE_ABORTED_BY_CALLBACK:
+ case CURLE_READ_ERROR:
+ case CURLE_WRITE_ERROR:
/* When we're aborted due to a callback return code it basically have to
be counted as premature as there is trouble ahead if we don't. We have
many callbacks and protocols work differently, we could potentially do
this more fine-grained in the future. */
premature = TRUE;
+ default:
+ break;
+ }
/* this calls the protocol-specific function pointer previously set */
if(conn->handler->done)
--
1.7.1

View File

@ -12,7 +12,7 @@ diff --git a/configure b/configure
index 8f079a3..53b4774 100755
--- a/configure
+++ b/configure
@@ -16030,18 +16030,11 @@ $as_echo "yes" >&6; }
@@ -16000,18 +16000,11 @@ $as_echo "yes" >&6; }
gccvhi=`echo $gccver | cut -d . -f1`
gccvlo=`echo $gccver | cut -d . -f2`
compiler_num=`(expr $gccvhi "*" 100 + $gccvlo) 2>/dev/null`

View File

@ -12,7 +12,7 @@ diff --git a/configure b/configure
index a466175..cb63075 100755
--- a/configure
+++ b/configure
@@ -15495,13 +15495,9 @@ fi
@@ -15465,13 +15465,9 @@ fi
@ -33,7 +33,7 @@ diff --git a/configure.ac b/configure.ac
index 49309e6..90c56b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -243,13 +243,17 @@ fi
@@ -242,13 +242,17 @@ fi
AC_SUBST([CPPFLAG_CURL_STATICLIB])

View File

@ -1,42 +0,0 @@
From 2e973be50f75d0a85dcb995f7823f00b1fc85c2f Mon Sep 17 00:00:00 2001
From: Kamil Dudka <kdudka@redhat.com>
Date: Mon, 7 Oct 2013 16:07:50 +0200
Subject: [PATCH] ssh: improve the logic for detecting blocking direction
This fixes a regression introduced by commit 0feeab78 limiting the speed
of SCP upload to 16384 B/s on a fast connection (such as localhost).
http://thread.gmane.org/gmane.comp.web.curl.library/40551/focus=40561
---
lib/ssh.c | 8 +++++---
1 files changed, 5 insertions(+), 3 deletions(-)
diff --git a/lib/ssh.c b/lib/ssh.c
index 422357b..93c65c3 100644
--- a/lib/ssh.c
+++ b/lib/ssh.c
@@ -2287,6 +2287,10 @@ static CURLcode ssh_statemach_act(struct connectdata *conn, bool *block)
sshc->actualcode = result;
}
else {
+ /* store this original bitmask setup to use later on if we can't
+ figure out a "real" bitmask */
+ sshc->orig_waitfor = data->req.keepon;
+
/* we want to use the _sending_ function even when the socket turns
out readable as the underlying libssh2 scp send function will deal
with both accordingly */
@@ -2603,9 +2607,7 @@ static void ssh_block2waitfor(struct connectdata *conn, bool block)
{
struct ssh_conn *sshc = &conn->proto.sshc;
int dir;
- if(!block)
- conn->waitfor = 0;
- else if((dir = libssh2_session_block_directions(sshc->ssh_session))) {
+ if(block && (dir = libssh2_session_block_directions(sshc->ssh_session))) {
/* translate the libssh2 define bits into our own bit defines */
conn->waitfor = ((dir&LIBSSH2_SESSION_BLOCK_INBOUND)?KEEP_RECV:0) |
((dir&LIBSSH2_SESSION_BLOCK_OUTBOUND)?KEEP_SEND:0);
--
1.7.1

View File

@ -1,7 +0,0 @@
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.14 (GNU/Linux)
iEYEABECAAYFAlIIDT4ACgkQeOEcayedXJFOBwCfSGwELnEOcuFSS7Witjk2EFwM
gdcAoPi/rwCi3U6B73B5p+/jR360V2e6
=VRTg
-----END PGP SIGNATURE-----

7
curl-7.33.0.tar.lzma.asc Normal file
View File

@ -0,0 +1,7 @@
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.15 (GNU/Linux)
iEYEABECAAYFAlJcAyIACgkQeOEcayedXJGmzgCgiGvAZ1jUvbBw/ywZSday3J9j
KucAn2xv4XLijiR4cDH6z8bnN0zH+lpk
=o6A/
-----END PGP SIGNATURE-----

View File

@ -1,18 +1,12 @@
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
Name: curl
Version: 7.32.0
Release: 3%{?dist}
Version: 7.33.0
Release: 1%{?dist}
License: MIT
Group: Applications/Internet
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
Source2: curlbuild.h
# make sure that NSS is initialized prior to calling PK11_GenerateRandom()
Patch1: 0001-curl-7.32.0-204126a5.patch
# avoid delay if FTP is aborted in CURLOPT_HEADERFUNCTION callback (#1005686)
Patch2: 0002-curl-7.32.0-c639d725.patch
# patch making libcurl multilib ready
Patch101: 0101-curl-7.32.0-multilib.patch
@ -28,9 +22,6 @@ Patch104: 0104-curl-7.19.7-localhost6.patch
# disable valgrind for certain test-cases (libssh2 problem)
Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
# http://thread.gmane.org/gmane.comp.web.curl.library/40551/focus=40561
Patch105: 0105-curl-7.32.0-scp-upload.patch
# work around valgrind bug (#678518)
Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
@ -113,11 +104,6 @@ documentation of the library, too.
%setup -q
# upstream patches
%patch1 -p1
%patch2 -p1
# patches not yet upstream
%patch105 -p1
# Fedora patches
%patch101 -p1
@ -236,6 +222,9 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/aclocal/libcurl.m4
%changelog
* Mon Oct 14 2013 Kamil Dudka <kdudka@redhat.com> 7.33.0-1
- new upstream release
* Fri Oct 11 2013 Kamil Dudka <kdudka@redhat.com> 7.32.0-3
- do not limit the speed of SCP upload on a fast connection

View File

@ -1 +1 @@
db5948f44e7ef3edbf9a7907af9556ac curl-7.32.0.tar.lzma
eb463192f37c260163e006d6c4d3f114 curl-7.33.0.tar.lzma