new upstream release - 7.25.0
- new upstream release (#806264) - fix character encoding of docs with a patch rather than just iconv - update debug and multilib patches - don't use macros for commands - reduce size of %prep output for readability
This commit is contained in:
parent
51012c0f12
commit
60afc952d9
6
.gitignore
vendored
6
.gitignore
vendored
@ -1,5 +1 @@
|
|||||||
/curl-7.21.6.tar.lzma
|
/curl-[0-9.]*.tar.lzma
|
||||||
/curl-7.21.7.tar.lzma
|
|
||||||
/curl-7.22.0.tar.lzma
|
|
||||||
/curl-7.23.0.tar.lzma
|
|
||||||
/curl-7.24.0.tar.lzma
|
|
||||||
|
@ -26,9 +26,9 @@ index 150004d..95d0759 100644
|
|||||||
- CURLLIBDIR=""
|
- CURLLIBDIR=""
|
||||||
- fi
|
- fi
|
||||||
- if test "X@REQUIRE_LIB_DEPS@" = "Xyes"; then
|
- if test "X@REQUIRE_LIB_DEPS@" = "Xyes"; then
|
||||||
- echo ${CURLLIBDIR}-lcurl @LDFLAGS@ @LIBCURL_LIBS@ @LIBS@
|
- echo ${CURLLIBDIR}-lcurl @LIBCURL_LIBS@ @LIBS@
|
||||||
- else
|
- else
|
||||||
- echo ${CURLLIBDIR}-lcurl @LDFLAGS@ @LIBS@
|
- echo ${CURLLIBDIR}-lcurl @LIBS@
|
||||||
- fi
|
- fi
|
||||||
+ pkg-config libcurl --libs
|
+ pkg-config libcurl --libs
|
||||||
;;
|
;;
|
||||||
@ -39,7 +39,7 @@ index 150004d..95d0759 100644
|
|||||||
|
|
||||||
--configure)
|
--configure)
|
||||||
- echo @CONFIGURE_OPTIONS@
|
- echo @CONFIGURE_OPTIONS@
|
||||||
+ pkg-config libcurl --variable=configure_options | sed 's/^"//;s/"$//'
|
+ pkg-config libcurl --variable=configure_options | sed 's/^"//;s/"$//'
|
||||||
;;
|
;;
|
||||||
|
|
||||||
*)
|
*)
|
||||||
@ -47,7 +47,7 @@ diff --git a/docs/curl-config.1 b/docs/curl-config.1
|
|||||||
index c4f4e2b..3e0ea60 100644
|
index c4f4e2b..3e0ea60 100644
|
||||||
--- a/docs/curl-config.1
|
--- a/docs/curl-config.1
|
||||||
+++ b/docs/curl-config.1
|
+++ b/docs/curl-config.1
|
||||||
@@ -65,7 +65,9 @@ be listed using uppercase and are separated by newlines. There may be none,
|
@@ -65,7 +65,9 @@ be listed using uppercase and are separa
|
||||||
one, or several protocols in the list. (Added in 7.13.0)
|
one, or several protocols in the list. (Added in 7.13.0)
|
||||||
.IP "--static-libs"
|
.IP "--static-libs"
|
||||||
Shows the complete set of libs and other linker options you will need in order
|
Shows the complete set of libs and other linker options you will need in order
|
@ -6,7 +6,7 @@ diff --git a/configure b/configure
|
|||||||
index d3ecf69..6d8f085 100755
|
index d3ecf69..6d8f085 100755
|
||||||
--- a/configure
|
--- a/configure
|
||||||
+++ b/configure
|
+++ b/configure
|
||||||
@@ -15040,18 +15040,11 @@ $as_echo "yes" >&6; }
|
@@ -15045,18 +15045,11 @@ $as_echo "yes" >&6; }
|
||||||
gccvhi=`echo $gccver | cut -d . -f1`
|
gccvhi=`echo $gccver | cut -d . -f1`
|
||||||
gccvlo=`echo $gccver | cut -d . -f2`
|
gccvlo=`echo $gccver | cut -d . -f2`
|
||||||
compiler_num=`(expr $gccvhi "*" 100 + $gccvlo) 2>/dev/null`
|
compiler_num=`(expr $gccvhi "*" 100 + $gccvlo) 2>/dev/null`
|
41
0108-curl-7.25.0-utf8.patch
Normal file
41
0108-curl-7.25.0-utf8.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
--- curl/CHANGES
|
||||||
|
+++ curl/CHANGES
|
||||||
|
@@ -1388,7 +1388,7 @@ Daniel Stenberg (12 Dec 2011)
|
||||||
|
linking with a static openssl requires a set of more libs to be linked
|
||||||
|
on Windows.
|
||||||
|
|
||||||
|
- Thanks also to Steve Holme and Martin Storsjö for additional feedback.
|
||||||
|
+ Thanks also to Steve Holme and Martin Storsjö for additional feedback.
|
||||||
|
|
||||||
|
Bug: http://curl.haxx.se/mail/lib-2011-12/0063.html
|
||||||
|
Reported by: Ward Willats
|
||||||
|
@@ -2648,7 +2648,7 @@ Daniel Stenberg (25 Sep 2011)
|
||||||
|
damaging.
|
||||||
|
|
||||||
|
Bug: http://curl.haxx.se/bug/view.cgi?id=3413181
|
||||||
|
- Reported by: Taneli Vähäkangas
|
||||||
|
+ Reported by: Taneli Vähäkangas
|
||||||
|
|
||||||
|
Yang Tse (24 Sep 2011)
|
||||||
|
- curl tool: fix a compiler warning
|
||||||
|
@@ -5168,9 +5168,9 @@ Daniel Stenberg (12 Apr 2011)
|
||||||
|
- OpenSSL: no-sslv2 aware
|
||||||
|
|
||||||
|
Allow openSSL without SSL2 to be used. This fix is inspired by the fix
|
||||||
|
- provided by Cristian Rodríguez.
|
||||||
|
+ provided by Cristian RodrÃguez.
|
||||||
|
|
||||||
|
- Reported by: Cristian Rodríguez
|
||||||
|
+ Reported by: Cristian RodrÃguez
|
||||||
|
|
||||||
|
- curl_easy_setopt.3: CURLOPT_RESOLVE typo version
|
||||||
|
|
||||||
|
--- curl/README
|
||||||
|
+++ curl/README
|
||||||
|
@@ -45,5 +45,5 @@ GIT
|
||||||
|
NOTICE
|
||||||
|
|
||||||
|
Curl contains pieces of source code that is Copyright (c) 1998, 1999
|
||||||
|
- Kungliga Tekniska Högskolan. This notice is included here to comply with the
|
||||||
|
+ Kungliga Tekniska Högskolan. This notice is included here to comply with the
|
||||||
|
distribution terms.
|
33
curl.spec
33
curl.spec
@ -1,6 +1,6 @@
|
|||||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||||
Name: curl
|
Name: curl
|
||||||
Version: 7.24.0
|
Version: 7.25.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
@ -9,10 +9,10 @@ Source2: curlbuild.h
|
|||||||
Source3: hide_selinux.c
|
Source3: hide_selinux.c
|
||||||
|
|
||||||
# patch making libcurl multilib ready
|
# patch making libcurl multilib ready
|
||||||
Patch101: 0101-curl-7.21.1-multilib.patch
|
Patch101: 0101-curl-7.25.0-multilib.patch
|
||||||
|
|
||||||
# prevent configure script from discarding -g in CFLAGS (#496778)
|
# prevent configure script from discarding -g in CFLAGS (#496778)
|
||||||
Patch102: 0102-curl-7.21.2-debug.patch
|
Patch102: 0102-curl-7.25.0-debug.patch
|
||||||
|
|
||||||
# use localhost6 instead of ip6-localhost in the curl test-suite
|
# use localhost6 instead of ip6-localhost in the curl test-suite
|
||||||
Patch104: 0104-curl-7.19.7-localhost6.patch
|
Patch104: 0104-curl-7.19.7-localhost6.patch
|
||||||
@ -26,9 +26,13 @@ Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
|
|||||||
# work around valgrind bug (#678518)
|
# work around valgrind bug (#678518)
|
||||||
Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
|
Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
|
||||||
|
|
||||||
|
# Fix character encoding of docs, which are of mixed encoding originally so
|
||||||
|
# a simple iconv can't fix them
|
||||||
|
Patch108: 0108-curl-7.25.0-utf8.patch
|
||||||
|
|
||||||
Provides: webclient
|
Provides: webclient
|
||||||
URL: http://curl.haxx.se/
|
URL: http://curl.haxx.se/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
|
||||||
BuildRequires: groff
|
BuildRequires: groff
|
||||||
BuildRequires: krb5-devel
|
BuildRequires: krb5-devel
|
||||||
BuildRequires: libidn-devel
|
BuildRequires: libidn-devel
|
||||||
@ -99,26 +103,22 @@ documentation of the library, too.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
# Convert docs to UTF-8
|
|
||||||
# NOTE: we do this _before_ applying of all patches, which are already UTF-8
|
|
||||||
for f in CHANGES README; do
|
|
||||||
iconv -f iso-8859-1 -t utf8 < ${f} > ${f}.utf8
|
|
||||||
mv -f ${f}.utf8 ${f}
|
|
||||||
done
|
|
||||||
|
|
||||||
# Fedora patches
|
# Fedora patches
|
||||||
%patch101 -p1
|
%patch101 -p1
|
||||||
%patch102 -p1
|
%patch102 -p1
|
||||||
%patch104 -p1
|
%patch104 -p1
|
||||||
%patch106 -p1
|
%patch106 -p1
|
||||||
%patch107 -p1
|
%patch107 -p1
|
||||||
|
%patch108 -p1
|
||||||
|
|
||||||
# exclude test1112 from the test suite (#565305)
|
# exclude test1112 from the test suite (#565305)
|
||||||
%patch105 -p1
|
%patch105 -p1
|
||||||
rm -f tests/data/test1112
|
rm -f tests/data/test1112
|
||||||
|
|
||||||
# replace hard wired port numbers in the test suite
|
# replace hard wired port numbers in the test suite
|
||||||
sed -i s/899\\\([0-9]\\\)/%{?__isa_bits}9\\1/ tests/data/test*
|
cd tests/data/
|
||||||
|
sed -i s/899\\\([0-9]\\\)/%{?__isa_bits}9\\1/ test*
|
||||||
|
cd -
|
||||||
|
|
||||||
%build
|
%build
|
||||||
[ -x /usr/kerberos/bin/krb5-config ] && KRB5_PREFIX="=/usr/kerberos"
|
[ -x /usr/kerberos/bin/krb5-config ] && KRB5_PREFIX="=/usr/kerberos"
|
||||||
@ -167,7 +167,7 @@ export LD_PRELOAD
|
|||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
|
|
||||||
make DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p" install
|
make DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p" install
|
||||||
|
|
||||||
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
|
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
|
||||||
|
|
||||||
@ -218,6 +218,13 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/aclocal/libcurl.m4
|
%{_datadir}/aclocal/libcurl.m4
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 23 2012 Paul Howarth <paul@city-fan.org> 7.25.0-1
|
||||||
|
- new upstream release (#806264)
|
||||||
|
- fix character encoding of docs with a patch rather than just iconv
|
||||||
|
- update debug and multilib patches
|
||||||
|
- don't use macros for commands
|
||||||
|
- reduce size of %%prep output for readability
|
||||||
|
|
||||||
* Tue Jan 24 2012 Kamil Dudka <kdudka@redhat.com> 7.24.0-1
|
* Tue Jan 24 2012 Kamil Dudka <kdudka@redhat.com> 7.24.0-1
|
||||||
- new upstream release (fixes CVE-2012-0036)
|
- new upstream release (fixes CVE-2012-0036)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user