sshserver.pl (used in test suite) now requires the Digest::SHA perl module
This commit is contained in:
parent
ef0743b641
commit
503307b687
45
0001-tests-3021-and-3022-require-libssh2.patch
Normal file
45
0001-tests-3021-and-3022-require-libssh2.patch
Normal file
@ -0,0 +1,45 @@
|
||||
From 4825d0cd3af5a5e51bb5e045cb12283138620d0c Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Stenberg <daniel@haxx.se>
|
||||
Date: Sat, 13 Nov 2021 23:10:42 +0100
|
||||
Subject: [PATCH] test302[12]: run only with the libssh2 backend
|
||||
|
||||
... as the others don't support --hostpubsha256
|
||||
|
||||
Reported-by: Paul Howarth
|
||||
Fixes #8009
|
||||
Closes #8010
|
||||
---
|
||||
tests/data/test3021 | 4 ++++
|
||||
tests/data/test3022 | 4 ++++
|
||||
2 files changed, 8 insertions(+)
|
||||
|
||||
diff --git a/tests/data/test3021 b/tests/data/test3021
|
||||
index 0a02e18443e4..bd6ae8d6dc47 100644
|
||||
--- a/tests/data/test3021
|
||||
+++ b/tests/data/test3021
|
||||
@@ -17,6 +17,10 @@ test
|
||||
#
|
||||
# Client-side
|
||||
<client>
|
||||
+# so far only the libssh2 backend supports SHA256
|
||||
+<features>
|
||||
+libssh2
|
||||
+</features>
|
||||
<server>
|
||||
sftp
|
||||
</server>
|
||||
diff --git a/tests/data/test3022 b/tests/data/test3022
|
||||
index f3477909d698..db24ca9f4a01 100644
|
||||
--- a/tests/data/test3022
|
||||
+++ b/tests/data/test3022
|
||||
@@ -17,6 +17,10 @@ test
|
||||
#
|
||||
# Client-side
|
||||
<client>
|
||||
+# so far only the libssh2 backend supports SHA256
|
||||
+<features>
|
||||
+libssh2
|
||||
+</features>
|
||||
<server>
|
||||
scp
|
||||
</server>
|
10
curl.spec
10
curl.spec
@ -1,7 +1,7 @@
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.80.0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: MIT
|
||||
Source0: https://curl.se/download/%{name}-%{version}.tar.xz
|
||||
Source1: https://curl.se/download/%{name}-%{version}.tar.xz.asc
|
||||
@ -10,6 +10,9 @@ Source1: https://curl.se/download/%{name}-%{version}.tar.xz.asc
|
||||
# which points to the GPG key as of April 7th 2016 of https://daniel.haxx.se/mykey.asc
|
||||
Source2: mykey.asc
|
||||
|
||||
# patch to skip tests 3031/2 unless SSH backend is libssh2
|
||||
Patch1: 0001-tests-3021-and-3022-require-libssh2.patch
|
||||
|
||||
# patch making libcurl multilib ready
|
||||
Patch101: 0101-curl-7.32.0-multilib.patch
|
||||
|
||||
@ -63,6 +66,7 @@ BuildRequires: nghttp2
|
||||
# perl modules used in the test suite
|
||||
BuildRequires: perl(Cwd)
|
||||
BuildRequires: perl(Digest::MD5)
|
||||
BuildRequires: perl(Digest::SHA)
|
||||
BuildRequires: perl(Exporter)
|
||||
BuildRequires: perl(File::Basename)
|
||||
BuildRequires: perl(File::Copy)
|
||||
@ -183,6 +187,7 @@ be installed.
|
||||
%setup -q
|
||||
|
||||
# upstream patches
|
||||
%patch1 -p1
|
||||
|
||||
# Fedora patches
|
||||
%patch101 -p1
|
||||
@ -410,6 +415,9 @@ rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
|
||||
%{_libdir}/libcurl.so.4.[0-9].[0-9].minimal
|
||||
|
||||
%changelog
|
||||
* Sun Nov 14 2021 Paul Howarth <paul@city-fan.org> - 7.80.0-2
|
||||
- sshserver.pl (used in test suite) now requires the Digest::SHA perl module
|
||||
|
||||
* Wed Nov 10 2021 Kamil Dudka <kdudka@redhat.com> - 7.80.0-1
|
||||
- new upstream release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user