new upstream release - 7.21.4
This commit is contained in:
parent
abe6f10c1e
commit
4fddd46419
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
curl-7.21.2.tar.lzma
|
||||
/curl-7.21.3.tar.lzma
|
||||
/curl-7.21.4.tar.lzma
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- curl-7.21.3/tests/server/tftpd.c.orig 2010-12-01 18:45:49.000000000 +0000
|
||||
+++ curl-7.21.3/tests/server/tftpd.c 2010-12-16 13:19:13.489446036 +0000
|
||||
@@ -1291,8 +1291,8 @@
|
||||
pe->e_msg = strerror(error - 100);
|
||||
tp->th_code = EUNDEF; /* set 'undef' errorcode */
|
||||
}
|
||||
- strcpy(tp->th_msg, pe->e_msg);
|
||||
length = (int)strlen(pe->e_msg);
|
||||
+ memcpy(tp->th_msg, pe->e_msg, length + 1);
|
||||
tp->th_msg[length] = '\0';
|
||||
length += 5;
|
||||
if (swrite(peer, &buf.storage[0], length) != length)
|
@ -6,7 +6,7 @@ diff --git a/configure b/configure
|
||||
index d3ecf69..6d8f085 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -14192,18 +14192,11 @@ $as_echo "yes" >&6; }
|
||||
@@ -14204,18 +14204,11 @@ $as_echo "yes" >&6; }
|
||||
gccvhi=`echo $gccver | cut -d . -f1`
|
||||
gccvlo=`echo $gccver | cut -d . -f2`
|
||||
compiler_num=`(expr $gccvhi "*" 100 + $gccvlo) 2>/dev/null`
|
||||
|
@ -14,12 +14,12 @@ index 9370974..b553f54 100644
|
||||
+ test1108 test1109 test1110 test1111 test129 test567 test568 \
|
||||
test569 test570 test571 test572 test804 test805 test806 test807 test573 \
|
||||
test313 test1115 test578 test579 test1116 test1200 test1201 test1202 \
|
||||
test1203 test1117 test1118 test1119 test1120
|
||||
test1203 test1117 test1118 test1119 test1120 test1300 test1301 test1302 \
|
||||
diff --git a/tests/data/Makefile.in b/tests/data/Makefile.in
|
||||
index 435b126..1d71c4e 100644
|
||||
--- a/tests/data/Makefile.in
|
||||
+++ b/tests/data/Makefile.in
|
||||
@@ -302,7 +302,7 @@ EXTRA_DIST = test1 test108 test117 test1
|
||||
@@ -304,7 +304,7 @@ EXTRA_DIST = test1 test108 test117 test1
|
||||
test561 test1098 test1099 test562 test563 test1100 test564 test1101 \
|
||||
test1102 test1103 test1104 test299 test310 test311 test312 test1105 \
|
||||
test565 test800 test1106 test801 test566 test802 test803 test1107 \
|
||||
@ -27,4 +27,4 @@ index 435b126..1d71c4e 100644
|
||||
+ test1108 test1109 test1110 test1111 test129 test567 test568 \
|
||||
test569 test570 test571 test572 test804 test805 test806 test807 test573 \
|
||||
test313 test1115 test578 test579 test1116 test1200 test1201 test1202 \
|
||||
test1203 test1117 test1118 test1119 test1120
|
||||
test1203 test1117 test1118 test1119 test1120 test1300 test1301 test1302 \
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.10 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAk0Iz2QACgkQeOEcayedXJGrpwCfWyvtIlugNkF2FFwFQfofss07
|
||||
XNoAoKIwCqlnHNQx/7B02B2DJRPLctvG
|
||||
=H9uq
|
||||
-----END PGP SIGNATURE-----
|
7
curl-7.21.4.tar.lzma.asc
Normal file
7
curl-7.21.4.tar.lzma.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.10 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAk1dEroACgkQeOEcayedXJGnzwCeJ5QDI1+tKSme9fnZDRAetcQ5
|
||||
KpkAoOqmXiQVgqVLJWWIS9wbhUt+tNcL
|
||||
=2k/t
|
||||
-----END PGP SIGNATURE-----
|
13
curl.spec
13
curl.spec
@ -1,16 +1,13 @@
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.21.3
|
||||
Release: 3%{?dist}
|
||||
Version: 7.21.4
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Group: Applications/Internet
|
||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
|
||||
Source2: curlbuild.h
|
||||
Source3: hide_selinux.c
|
||||
|
||||
# Avoid buffer overflow report from glibc with FORTIFY_SOURCE
|
||||
Patch5: 0005-curl-7.21.3-tftpd-buffer-overflow.patch
|
||||
|
||||
# patch making libcurl multilib ready
|
||||
Patch101: 0101-curl-7.21.1-multilib.patch
|
||||
|
||||
@ -106,9 +103,6 @@ for f in CHANGES README; do
|
||||
mv -f ${f}.utf8 ${f}
|
||||
done
|
||||
|
||||
# upstream patches (not yet applied)
|
||||
%patch5 -p1
|
||||
|
||||
# Fedora patches
|
||||
%patch101 -p1
|
||||
%patch102 -p1
|
||||
@ -220,6 +214,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/aclocal/libcurl.m4
|
||||
|
||||
%changelog
|
||||
* Thu Feb 17 2011 Kamil Dudka <kdudka@redhat.com> 7.21.4-1
|
||||
- new upstream release
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.21.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user