new upstream release - 7.79.1
This commit is contained in:
parent
e2155b2695
commit
407e3960e4
@ -1,101 +0,0 @@
|
||||
From 3b1db8a1032f5728f7da5a1fabe8db0bec1f4574 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Wed, 15 Sep 2021 09:59:14 +0200
|
||||
Subject: [PATCH] tests/sshserver.pl: make it work with openssh-8.7p1
|
||||
|
||||
... by not using options with no argument where an argument is required:
|
||||
|
||||
=== Start of file tests/log/ssh_server.log
|
||||
curl_sshd_config line 6: no argument after keyword "DenyGroups"
|
||||
curl_sshd_config line 7: no argument after keyword "AllowGroups"
|
||||
curl_sshd_config line 10: Deprecated option AuthorizedKeysFile2
|
||||
curl_sshd_config line 29: Deprecated option KeyRegenerationInterval
|
||||
curl_sshd_config line 39: Deprecated option RhostsRSAAuthentication
|
||||
curl_sshd_config line 40: Deprecated option RSAAuthentication
|
||||
curl_sshd_config line 41: Deprecated option ServerKeyBits
|
||||
curl_sshd_config line 45: Deprecated option UseLogin
|
||||
curl_sshd_config line 56: no argument after keyword "AcceptEnv"
|
||||
curl_sshd_config: terminating, 3 bad configuration options
|
||||
=== End of file tests/log/ssh_server.log
|
||||
|
||||
=== Start of file log/sftp_server.log
|
||||
curl_sftp_config line 33: Unsupported option "rhostsrsaauthentication"
|
||||
curl_sftp_config line 34: Unsupported option "rsaauthentication"
|
||||
curl_sftp_config line 52: no argument after keyword "sendenv"
|
||||
curl_sftp_config: terminating, 1 bad configuration options
|
||||
Connection closed.
|
||||
Connection closed
|
||||
=== End of file log/sftp_server.log
|
||||
|
||||
Closes #7724
|
||||
|
||||
Upstream-commit: ab78d2c679dfb37b27e89f42ad050c3153fa7513
|
||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
||||
---
|
||||
tests/sshserver.pl | 14 --------------
|
||||
1 file changed, 14 deletions(-)
|
||||
|
||||
diff --git a/tests/sshserver.pl b/tests/sshserver.pl
|
||||
index d0952a2d8..412cab33e 100644
|
||||
--- a/tests/sshserver.pl
|
||||
+++ b/tests/sshserver.pl
|
||||
@@ -428,9 +428,7 @@ if ($sshdid =~ /OpenSSH-Windows/) {
|
||||
# ssh daemon configuration file options we might use and version support
|
||||
#
|
||||
# AFSTokenPassing : OpenSSH 1.2.1 and later [1]
|
||||
-# AcceptEnv : OpenSSH 3.9.0 and later
|
||||
# AddressFamily : OpenSSH 4.0.0 and later
|
||||
-# AllowGroups : OpenSSH 1.2.1 and later
|
||||
# AllowTcpForwarding : OpenSSH 2.3.0 and later
|
||||
# AllowUsers : OpenSSH 1.2.1 and later
|
||||
# AuthorizedKeysFile : OpenSSH 2.9.9 and later
|
||||
@@ -441,7 +439,6 @@ if ($sshdid =~ /OpenSSH-Windows/) {
|
||||
# ClientAliveCountMax : OpenSSH 2.9.0 and later
|
||||
# ClientAliveInterval : OpenSSH 2.9.0 and later
|
||||
# Compression : OpenSSH 3.3.0 and later
|
||||
-# DenyGroups : OpenSSH 1.2.1 and later
|
||||
# DenyUsers : OpenSSH 1.2.1 and later
|
||||
# ForceCommand : OpenSSH 4.4.0 and later [3]
|
||||
# GatewayPorts : OpenSSH 2.1.0 and later
|
||||
@@ -534,9 +531,6 @@ if ($sshdid =~ /OpenSSH-Windows/) {
|
||||
push @cfgarr, "AllowUsers $username";
|
||||
}
|
||||
|
||||
-push @cfgarr, 'DenyGroups';
|
||||
-push @cfgarr, 'AllowGroups';
|
||||
-push @cfgarr, '#';
|
||||
push @cfgarr, "AuthorizedKeysFile $clipubkeyf_config";
|
||||
push @cfgarr, "AuthorizedKeysFile2 $clipubkeyf_config";
|
||||
push @cfgarr, "HostKey $hstprvkeyf_config";
|
||||
@@ -684,9 +678,6 @@ push @cfgarr, '#';
|
||||
#***************************************************************************
|
||||
# Options that might be supported or not in sshd OpenSSH 2.9.9 and later
|
||||
#
|
||||
-if(sshd_supports_opt('AcceptEnv','')) {
|
||||
- push @cfgarr, 'AcceptEnv';
|
||||
-}
|
||||
if(sshd_supports_opt('AddressFamily','any')) {
|
||||
# Address family must be specified before ListenAddress
|
||||
splice @cfgarr, 14, 0, 'AddressFamily any';
|
||||
@@ -873,7 +864,6 @@ if ($sshdid =~ /OpenSSH-Windows/) {
|
||||
# RemoteForward : OpenSSH 1.2.1 and later [3]
|
||||
# RhostsRSAAuthentication : OpenSSH 1.2.1 and later
|
||||
# RSAAuthentication : OpenSSH 1.2.1 and later
|
||||
-# SendEnv : OpenSSH 3.9.0 and later
|
||||
# ServerAliveCountMax : OpenSSH 3.8.0 and later
|
||||
# ServerAliveInterval : OpenSSH 3.8.0 and later
|
||||
# SmartcardDevice : OpenSSH 2.9.9 and later [1][3]
|
||||
@@ -1028,10 +1018,6 @@ if((($sshid =~ /OpenSSH/) && ($sshvernum >= 370)) ||
|
||||
push @cfgarr, 'RekeyLimit 1G';
|
||||
}
|
||||
|
||||
-if(($sshid =~ /OpenSSH/) && ($sshvernum >= 390)) {
|
||||
- push @cfgarr, 'SendEnv';
|
||||
-}
|
||||
-
|
||||
if((($sshid =~ /OpenSSH/) && ($sshvernum >= 380)) ||
|
||||
(($sshid =~ /SunSSH/) && ($sshvernum >= 120))) {
|
||||
push @cfgarr, 'ServerAliveCountMax 3';
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,53 +0,0 @@
|
||||
From 130f84913b372f27e8db065a614cd34beda3ba14 Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Stenberg <daniel@haxx.se>
|
||||
Date: Thu, 16 Sep 2021 08:50:54 +0200
|
||||
Subject: [PATCH] Curl_http2_setup: don't change connection data on repeat
|
||||
invokes
|
||||
|
||||
Regression from 3cb8a748670ab88c (releasde in 7.79.0). That change moved
|
||||
transfer oriented inits to before the check but also erroneously moved a
|
||||
few connection oriented ones, which causes problems.
|
||||
|
||||
Reported-by: Evangelos Foutras
|
||||
Fixes #7730
|
||||
Closes #7731
|
||||
|
||||
Upstream-commit: 901804ef95777b8e735a55b77f8dd630a58c575b
|
||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
||||
---
|
||||
lib/http2.c | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/lib/http2.c b/lib/http2.c
|
||||
index a3de607c7..6d63f4363 100644
|
||||
--- a/lib/http2.c
|
||||
+++ b/lib/http2.c
|
||||
@@ -2221,12 +2221,6 @@ CURLcode Curl_http2_setup(struct Curl_easy *data,
|
||||
stream->mem = data->state.buffer;
|
||||
stream->len = data->set.buffer_size;
|
||||
|
||||
- httpc->inbuflen = 0;
|
||||
- httpc->nread_inbuf = 0;
|
||||
-
|
||||
- httpc->pause_stream_id = 0;
|
||||
- httpc->drain_total = 0;
|
||||
-
|
||||
multi_connchanged(data->multi);
|
||||
/* below this point only connection related inits are done, which only needs
|
||||
to be done once per connection */
|
||||
@@ -2252,6 +2246,12 @@ CURLcode Curl_http2_setup(struct Curl_easy *data,
|
||||
conn->httpversion = 20;
|
||||
conn->bundle->multiuse = BUNDLE_MULTIPLEX;
|
||||
|
||||
+ httpc->inbuflen = 0;
|
||||
+ httpc->nread_inbuf = 0;
|
||||
+
|
||||
+ httpc->pause_stream_id = 0;
|
||||
+ httpc->drain_total = 0;
|
||||
+
|
||||
infof(data, "Connection state changed (HTTP/2 confirmed)");
|
||||
|
||||
return CURLE_OK;
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,11 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQEzBAABCgAdFiEEJ+3q8i86vOtQ25oSXMkI/bceEsIFAmFBj6gACgkQXMkI/bce
|
||||
EsJkpQgAuTRPniJDsiVa9yqtfgSNq2BG3u+JpcKFC3bJ/PB2DAtNVORNrTYkk3B1
|
||||
wIgfVWYBBJiCXoy5Ivof0MIfUM8kMFJXwHfy0Gs5/60GCy5mXOvVC7IEmKZ24lOU
|
||||
7cNNzNkyR69z1yWM1VFfaDNmO3+GWIvM2YJTEdHlAxABR71FfW/ARtXjSFEJ01FL
|
||||
t9IyDiH56cCkWEFFvM2YxNo0IjduvC5pLBiGfrBe5bAKV63Z0/Qtp18zoVaYgv6Y
|
||||
+yLxv4jgteN/wrTHXVQ5o6FiqoTP/OEpJOLe1Zd4sJhMBkobCPwi5HHAjbavqeFc
|
||||
3zs3aRTNMaVdvv4VqFhO5o8u2kZEbg==
|
||||
=2Tq/
|
||||
-----END PGP SIGNATURE-----
|
11
curl-7.79.1.tar.xz.asc
Normal file
11
curl-7.79.1.tar.xz.asc
Normal file
@ -0,0 +1,11 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQEzBAABCgAdFiEEJ+3q8i86vOtQ25oSXMkI/bceEsIFAmFKyZYACgkQXMkI/bce
|
||||
EsKyewgAivvAdC3J5DBsXlR7NMWpdbVVbT87m8ONxaIflFjwrIPdaazgiX/dsiS9
|
||||
zNaPQe5k5JH0DoQipiebrg4Zi248TTqH8GXi1sAlsqBFjWroYoeKxeCkSLOsFDVj
|
||||
ahZp2UM6FZTTUAQElw92+xlHJ1eD5L5CzIc+VLeVi4PAysrB1L4tPDmOFEfS1iZl
|
||||
wLzxKHuNnuDMWaizfxt9F2yc/ct++sNNuBZ8FHv4nJRIEANY/nCpttQFGgjS8V8l
|
||||
b22q5yIQez7zsCc9o7phS+CWLYEEgrcM+Qw7bmj1ANPgNlQ/dP5FKIwreZB1s5uV
|
||||
FBq4pS30d/CfaaE0vZ27D1G6ZoLvyA==
|
||||
=oayQ
|
||||
-----END PGP SIGNATURE-----
|
15
curl.spec
15
curl.spec
@ -1,7 +1,7 @@
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.79.0
|
||||
Release: 4%{?dist}
|
||||
Version: 7.79.1
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Source0: https://curl.se/download/%{name}-%{version}.tar.xz
|
||||
Source1: https://curl.se/download/%{name}-%{version}.tar.xz.asc
|
||||
@ -10,12 +10,6 @@ Source1: https://curl.se/download/%{name}-%{version}.tar.xz.asc
|
||||
# which points to the GPG key as of April 7th 2016 of https://daniel.haxx.se/mykey.asc
|
||||
Source2: mykey.asc
|
||||
|
||||
# make SCP/SFTP tests work with openssh-8.7p1
|
||||
Patch1: 0001-curl-7.79.0-ssh-tests.patch
|
||||
|
||||
# fix regression in http2 implementation introduced in the last release
|
||||
Patch2: 0002-curl-7.79.0-http2-fixup.patch
|
||||
|
||||
# patch making libcurl multilib ready
|
||||
Patch101: 0101-curl-7.32.0-multilib.patch
|
||||
|
||||
@ -189,8 +183,6 @@ be installed.
|
||||
%setup -q
|
||||
|
||||
# upstream patches
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
# Fedora patches
|
||||
%patch101 -p1
|
||||
@ -376,6 +368,9 @@ rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
|
||||
%{_libdir}/libcurl.so.4.[0-9].[0-9].minimal
|
||||
|
||||
%changelog
|
||||
* Wed Sep 22 2021 Kamil Dudka <kdudka@redhat.com> - 7.79.1-1
|
||||
- new upstream release
|
||||
|
||||
* Thu Sep 16 2021 Kamil Dudka <kdudka@redhat.com> - 7.79.0-4
|
||||
- fix regression in http2 implementation introduced in the last release
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (curl-7.79.0.tar.xz) = 68bccba61f18de9f94c311b0d92cfa6572bb7e55e8773917c13b25203164a5a9f4ef6b8ad84a14d3d5dcb286271bf18c3dd84c4ca353866763c726f9defce808
|
||||
SHA512 (curl-7.79.1.tar.xz) = 1edb71647a7f4dbb070baf1a019b4751aefeda793ff523c504410bb5cc74e5bffc52f20dd889697d1585f9ca3c4e81b1a9caadd182c30c8358ffd25f33e4db4d
|
||||
|
Loading…
Reference in New Issue
Block a user