- another series of review fixes (#225671), thanks to Paul Horwath
- check version of ldap library automatically - don't use %%makeinstall and preserve timestamps - drop useless patches
This commit is contained in:
parent
d1f8e21de8
commit
40373e1494
@ -1,33 +0,0 @@
|
||||
--- curl-7.14.1/configure.ac.orig 2005-09-01 22:29:20.000000000 +0200
|
||||
+++ curl-7.14.1/configure.ac 2005-10-13 09:55:19.395539032 +0200
|
||||
@@ -813,7 +813,7 @@
|
||||
PKGTEST="no"
|
||||
PREFIX_OPENSSL=$OPT_SSL
|
||||
LIB_OPENSSL="$PREFIX_OPENSSL/lib$libsuff"
|
||||
- LDFLAGS="$LDFLAGS -L$LIB_OPENSSL"
|
||||
+ #LDFLAGS="$LDFLAGS -L$LIB_OPENSSL"
|
||||
CPPFLAGS="$CPPFLAGS -I$PREFIX_OPENSSL/include/openssl -I$PREFIX_OPENSSL/include"
|
||||
;;
|
||||
esac
|
||||
@@ -867,7 +867,7 @@
|
||||
HAVECRYPTO="yes"
|
||||
LIBS="-lcrypto $LIBS"
|
||||
],[
|
||||
- LDFLAGS="$CLEANLDFLAGS -L$LIB_OPENSSL"
|
||||
+ LDFLAGS="$CLEANLDFLAGS"
|
||||
CPPFLAGS="$CLEANCPPFLAGS -I$PREFIX_OPENSSL/include/openssl -I$PREFIX_OPENSSL/include"
|
||||
AC_CHECK_LIB(crypto, CRYPTO_add_lock,[
|
||||
HAVECRYPTO="yes"
|
||||
--- curl-7.14.1/lib/Makefile.am.orig 2005-03-31 09:02:03.000000000 +0200
|
||||
+++ curl-7.14.1/lib/Makefile.am 2005-10-13 09:51:55.244574696 +0200
|
||||
@@ -107,8 +107,8 @@
|
||||
|
||||
install-data-hook:
|
||||
@if test -n "@CURL_CA_BUNDLE@"; then \
|
||||
- $(mkinstalldirs) `dirname $(DESTDIR)@CURL_CA_BUNDLE@`; \
|
||||
- @INSTALL_DATA@ $(srcdir)/ca-bundle.crt $(DESTDIR)@CURL_CA_BUNDLE@; \
|
||||
+ $(mkinstalldirs) `dirname $(prefix)/../@CURL_CA_BUNDLE@`; \
|
||||
+ @INSTALL_DATA@ $(srcdir)/ca-bundle.crt $(prefix)/../@CURL_CA_BUNDLE@; \
|
||||
fi
|
||||
|
||||
# this hook is mainly for non-unix systems to build even if configure
|
@ -1,12 +0,0 @@
|
||||
--- curl-7.15.0/configure.ac.ver 2005-11-30 13:33:54.360624896 +0100
|
||||
+++ curl-7.15.0/configure.ac 2005-11-30 13:34:14.009637792 +0100
|
||||
@@ -43,7 +43,8 @@
|
||||
|
||||
dnl
|
||||
dnl we extract the numerical version for curl-config only
|
||||
-VERSIONNUM=`$SED -ne 's/^#define LIBCURL_VERSION_NUM 0x\(.*\)/\1/p' ${srcdir}/include/curl/curlver.h`
|
||||
+VERSIONNUM=`$SED -rne 's/^#define LIBCURL_VERSION_(MAJOR|MINOR|PATCH) ([^ ]*)$/\2/p' ${srcdir}/include/curl/curlver.h | xargs -n1 printf %02x; echo`
|
||||
+
|
||||
AC_SUBST(VERSIONNUM)
|
||||
|
||||
dnl Solaris pkgadd support definitions
|
37
curl.spec
37
curl.spec
@ -1,17 +1,17 @@
|
||||
%define ldap_version 2.3
|
||||
# get the current ldap library version to link against automatically
|
||||
%define ldap_version %(readlink %{_libdir}/libldap.so | sed 's,.*libldap-\\([0-9.]*\\)\\.so\\..*,\\1,')
|
||||
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.16.2
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: MIT
|
||||
Group: Applications/Internet
|
||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
|
||||
Patch0: curl-7.14.1-nousr.patch
|
||||
Patch1: curl-7.15.0-curl_config-version.patch
|
||||
Patch2: curl-7.15.3-multilib.patch
|
||||
Patch3: curl-7.16.0-privlibs.patch
|
||||
Patch1: curl-7.15.3-multilib.patch
|
||||
Patch2: curl-7.16.0-privlibs.patch
|
||||
URL: http://curl.haxx.se/
|
||||
Requires: openssl
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: openssl-devel, libtool, pkgconfig, libidn-devel
|
||||
|
||||
@ -36,10 +36,8 @@ use cURL's capabilities internally.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .nousr
|
||||
%patch1 -p1 -b .ver
|
||||
%patch2 -p1 -b .multilib
|
||||
%patch3 -p1 -b .privlibs
|
||||
%patch1 -p1 -b .multilib
|
||||
%patch2 -p1 -b .privlibs
|
||||
|
||||
%build
|
||||
aclocal
|
||||
@ -51,7 +49,7 @@ if pkg-config openssl ; then
|
||||
LDFLAGS=`pkg-config --libs openssl`; export LDFLAGS
|
||||
fi
|
||||
%configure --with-ssl=%{_prefix} --enable-ipv6 \
|
||||
--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
|
||||
--with-ca-bundle=%{buildroot}%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
|
||||
--with-gssapi=%{_prefix}/kerberos --with-libidn \
|
||||
--with-ldap-lib=libldap-%{ldap_version}.so.0 \
|
||||
--with-lber-lib=liblber-%{ldap_version}.so.0 \
|
||||
@ -60,7 +58,15 @@ make CFLAGS="$RPM_OPT_FLAGS" %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
%makeinstall
|
||||
|
||||
make INSTALL="%{__install} -p" \
|
||||
prefix=%{buildroot}%{_prefix} \
|
||||
includedir=%{buildroot}%{_includedir} \
|
||||
libdir=%{buildroot}%{_libdir} \
|
||||
bindir=%{buildroot}%{_bindir} \
|
||||
mandir=%{buildroot}%{_mandir} \
|
||||
install
|
||||
|
||||
rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
|
||||
install -d $RPM_BUILD_ROOT/%{_datadir}/aclocal
|
||||
install -m 644 docs/libcurl/libcurl.m4 $RPM_BUILD_ROOT/%{_datadir}/aclocal
|
||||
@ -99,6 +105,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/aclocal/libcurl.m4
|
||||
|
||||
%changelog
|
||||
* Fri Jun 15 2007 Jindrich Novy <jnovy@redhat.com> 7.16.2-4
|
||||
- another series of review fixes (#225671),
|
||||
thanks to Paul Horwath
|
||||
- check version of ldap library automatically
|
||||
- don't use %%makeinstall and preserve timestamps
|
||||
- drop useless patches
|
||||
|
||||
* Fri May 11 2007 Jindrich Novy <jnovy@redhat.com> 7.16.2-3
|
||||
- add automake BR to curl-devel to fix aclocal dir. ownership,
|
||||
thanks to Patrice Dumas
|
||||
|
Loading…
Reference in New Issue
Block a user