new upstream release - 7.21.6
This commit is contained in:
parent
fb945ca026
commit
39828449b7
5
.gitignore
vendored
5
.gitignore
vendored
@ -1,4 +1 @@
|
|||||||
curl-7.21.2.tar.lzma
|
/curl-7.21.6.tar.lzma
|
||||||
/curl-7.21.3.tar.lzma
|
|
||||||
/curl-7.21.4.tar.lzma
|
|
||||||
/curl-7.21.5.tar.lzma
|
|
||||||
|
@ -1,75 +0,0 @@
|
|||||||
From 82ecc85d9ed0fc05931fb6d6893eda567a3c443f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Daniel Stenberg <daniel@haxx.se>
|
|
||||||
Date: Mon, 18 Apr 2011 09:03:12 +0200
|
|
||||||
Subject: [PATCH] curl-config: fix --version
|
|
||||||
|
|
||||||
curl-config --version didn't output the correct version string (bug
|
|
||||||
introduced in commit 0355e33b5f7b234cf3), and unfortunately the test
|
|
||||||
case 1022 that was supposed to check for this was broken.
|
|
||||||
|
|
||||||
This change fixes the test to detect this problem and it fixes the
|
|
||||||
output.
|
|
||||||
|
|
||||||
Bug: http://curl.haxx.se/bug/view.cgi?id=3288727
|
|
||||||
---
|
|
||||||
curl-config.in | 4 ++--
|
|
||||||
tests/libtest/test1022.pl | 17 +++++++++++++----
|
|
||||||
2 files changed, 15 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/curl-config.in b/curl-config.in
|
|
||||||
index 27b9f7f..0232803 100644
|
|
||||||
--- a/curl-config.in
|
|
||||||
+++ b/curl-config.in
|
|
||||||
@@ -6,7 +6,7 @@
|
|
||||||
# | (__| |_| | _ <| |___
|
|
||||||
# \___|\___/|_| \_\_____|
|
|
||||||
#
|
|
||||||
-# Copyright (C) 2001 - 2010, Daniel Stenberg, <daniel@haxx.se>, et al.
|
|
||||||
+# Copyright (C) 2001 - 2011, Daniel Stenberg, <daniel@haxx.se>, et al.
|
|
||||||
#
|
|
||||||
# This software is licensed as described in the file COPYING, which
|
|
||||||
# you should have received as part of this distribution. The terms
|
|
||||||
@@ -94,7 +94,7 @@ while test $# -gt 0; do
|
|
||||||
;;
|
|
||||||
|
|
||||||
--version)
|
|
||||||
- echo libcurl @VERSION@
|
|
||||||
+ echo libcurl @CURLVERSION@
|
|
||||||
exit 0
|
|
||||||
;;
|
|
||||||
|
|
||||||
diff --git a/tests/libtest/test1022.pl b/tests/libtest/test1022.pl
|
|
||||||
index 60eee38..7fac00e 100755
|
|
||||||
--- a/tests/libtest/test1022.pl
|
|
||||||
+++ b/tests/libtest/test1022.pl
|
|
||||||
@@ -22,14 +22,23 @@ my $curlconfigversion;
|
|
||||||
open(CURLCONFIG, "sh $ARGV[0] --$what|") || die "Can't get curl-config --$what list\n";
|
|
||||||
$_ = <CURLCONFIG>;
|
|
||||||
chomp;
|
|
||||||
+my $filever=$_;
|
|
||||||
if ( $what eq "version" ) {
|
|
||||||
- /^libcurl ([\.\d]+(-DEV)?)$/ ;
|
|
||||||
- $curlconfigversion = $1;
|
|
||||||
+ if($filever =~ /^libcurl ([\.\d]+(-DEV)?)$/) {
|
|
||||||
+ $curlconfigversion = $1;
|
|
||||||
+ }
|
|
||||||
+ else {
|
|
||||||
+ $curlconfigversion = "illegal value";
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
else {
|
|
||||||
# Convert hex version to decimal for comparison's sake
|
|
||||||
- /^(..)(..)(..)$/ ;
|
|
||||||
- $curlconfigversion = hex($1) . "." . hex($2) . "." . hex($3);
|
|
||||||
+ if($filever =~ /^(..)(..)(..)$/) {
|
|
||||||
+ $curlconfigversion = hex($1) . "." . hex($2) . "." . hex($3);
|
|
||||||
+ }
|
|
||||||
+ else {
|
|
||||||
+ $curlconfigversion = "illegal value";
|
|
||||||
+ }
|
|
||||||
|
|
||||||
# Strip off the -DEV from the curl version if it's there
|
|
||||||
$version =~ s/-DEV$//;
|
|
||||||
--
|
|
||||||
1.7.4.2
|
|
||||||
|
|
13
curl.spec
13
curl.spec
@ -1,16 +1,13 @@
|
|||||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||||
Name: curl
|
Name: curl
|
||||||
Version: 7.21.5
|
Version: 7.21.6
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
|
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
|
||||||
Source2: curlbuild.h
|
Source2: curlbuild.h
|
||||||
Source3: hide_selinux.c
|
Source3: hide_selinux.c
|
||||||
|
|
||||||
# fix the output of curl-config --version
|
|
||||||
Patch1: 0001-curl-7.21.5-82ecc85.patch
|
|
||||||
|
|
||||||
# patch making libcurl multilib ready
|
# patch making libcurl multilib ready
|
||||||
Patch101: 0101-curl-7.21.1-multilib.patch
|
Patch101: 0101-curl-7.21.1-multilib.patch
|
||||||
|
|
||||||
@ -109,9 +106,6 @@ for f in CHANGES README; do
|
|||||||
mv -f ${f}.utf8 ${f}
|
mv -f ${f}.utf8 ${f}
|
||||||
done
|
done
|
||||||
|
|
||||||
# upstream patches
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
# Fedora patches
|
# Fedora patches
|
||||||
%patch101 -p1
|
%patch101 -p1
|
||||||
%patch102 -p1
|
%patch102 -p1
|
||||||
@ -224,6 +218,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/aclocal/libcurl.m4
|
%{_datadir}/aclocal/libcurl.m4
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Apr 23 2011 Paul Howarth <paul@city-fan.org> 7.21.6-1
|
||||||
|
- new upstream release
|
||||||
|
|
||||||
* Mon Apr 18 2011 Kamil Dudka <kdudka@redhat.com> 7.21.5-2
|
* Mon Apr 18 2011 Kamil Dudka <kdudka@redhat.com> 7.21.5-2
|
||||||
- fix the output of curl-config --version (upstream commit 82ecc85)
|
- fix the output of curl-config --version (upstream commit 82ecc85)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user