replace 0105-curl-7.63.0-libstubgss-ldadd.patch by upstream patch
This commit is contained in:
parent
49f5a42f96
commit
32b0144f20
63
0002-curl-7.62.0-libtest-stub_gssapi-snprintf.patch
Normal file
63
0002-curl-7.62.0-libtest-stub_gssapi-snprintf.patch
Normal file
@ -0,0 +1,63 @@
|
|||||||
|
From 510ab52ed43589d96f0fab338eb6286940a29a78 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Daniel Stenberg <daniel@haxx.se>
|
||||||
|
Date: Thu, 3 Jan 2019 12:00:58 +0100
|
||||||
|
Subject: [PATCH] libtest/stub_gssapi: use "real" snprintf
|
||||||
|
|
||||||
|
... since it doesn't link with libcurl.
|
||||||
|
|
||||||
|
Reverts the commit dcd6f81025 changes from this file.
|
||||||
|
|
||||||
|
Bug: https://curl.haxx.se/mail/lib-2019-01/0000.html
|
||||||
|
Reported-by: Shlomi Fish
|
||||||
|
Reviewed-by: Daniel Gustafsson
|
||||||
|
Reviewed-by: Kamil Dudka
|
||||||
|
|
||||||
|
Closes #3434
|
||||||
|
|
||||||
|
Upstream-commit: c7c362a24c0247644f9fde05e8ea353af4a94b04
|
||||||
|
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
||||||
|
---
|
||||||
|
tests/libtest/stub_gssapi.c | 13 ++++++-------
|
||||||
|
1 file changed, 6 insertions(+), 7 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/tests/libtest/stub_gssapi.c b/tests/libtest/stub_gssapi.c
|
||||||
|
index 254a01b31..377b75452 100644
|
||||||
|
--- a/tests/libtest/stub_gssapi.c
|
||||||
|
+++ b/tests/libtest/stub_gssapi.c
|
||||||
|
@@ -5,7 +5,7 @@
|
||||||
|
* | (__| |_| | _ <| |___
|
||||||
|
* \___|\___/|_| \_\_____|
|
||||||
|
*
|
||||||
|
- * Copyright (C) 2017-2018, Daniel Stenberg, <daniel@haxx.se>, et al.
|
||||||
|
+ * Copyright (C) 2017-2019, Daniel Stenberg, <daniel@haxx.se>, et al.
|
||||||
|
*
|
||||||
|
* This software is licensed as described in the file COPYING, which
|
||||||
|
* you should have received as part of this distribution. The terms
|
||||||
|
@@ -28,10 +28,7 @@
|
||||||
|
|
||||||
|
#include "stub_gssapi.h"
|
||||||
|
|
||||||
|
-#define ENABLE_CURLX_PRINTF
|
||||||
|
-/* make the curlx header define all printf() functions to use the curlx_*
|
||||||
|
- versions instead */
|
||||||
|
-#include "curlx.h" /* from the private lib dir */
|
||||||
|
+/* !checksrc! disable SNPRINTF all */
|
||||||
|
|
||||||
|
#define MAX_CREDS_LENGTH 250
|
||||||
|
#define APPROX_TOKEN_LEN 250
|
||||||
|
@@ -207,8 +204,10 @@ OM_uint32 gss_init_sec_context(OM_uint32 *min,
|
||||||
|
}
|
||||||
|
|
||||||
|
/* Token format: creds:target:type:padding */
|
||||||
|
- used = msnprintf(token, length, "%s:%s:%d:", creds,
|
||||||
|
- (char *) target_name, ctx->sent);
|
||||||
|
+ /* Note: this is using the *real* snprintf() and not the curl provided
|
||||||
|
+ one */
|
||||||
|
+ used = snprintf(token, length, "%s:%s:%d:", creds,
|
||||||
|
+ (char *) target_name, ctx->sent);
|
||||||
|
|
||||||
|
if(used >= length) {
|
||||||
|
free(token);
|
||||||
|
--
|
||||||
|
2.17.2
|
||||||
|
|
@ -1,25 +0,0 @@
|
|||||||
From d8a3bdce7a43cb777866c34d3dabf908254e516d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kamil Dudka <kdudka@redhat.com>
|
|
||||||
Date: Wed, 12 Dec 2018 14:25:32 +0100
|
|
||||||
Subject: [PATCH] libtest: avoid symbol lookup error in libstubgss.so
|
|
||||||
|
|
||||||
---
|
|
||||||
tests/libtest/Makefile.am | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/tests/libtest/Makefile.am b/tests/libtest/Makefile.am
|
|
||||||
index 56c84a7..117b79f 100644
|
|
||||||
--- a/tests/libtest/Makefile.am
|
|
||||||
+++ b/tests/libtest/Makefile.am
|
|
||||||
@@ -123,7 +123,7 @@ libstubgss_la_CFLAGS = $(AM_CFLAGS) -g
|
|
||||||
|
|
||||||
libstubgss_la_SOURCES = stub_gssapi.c stub_gssapi.h
|
|
||||||
|
|
||||||
-libstubgss_la_LIBADD =
|
|
||||||
+libstubgss_la_LIBADD = $(top_builddir)/lib/libcurl.la
|
|
||||||
libstubgss_la_DEPENDENCIES =
|
|
||||||
endif
|
|
||||||
|
|
||||||
--
|
|
||||||
2.17.2
|
|
||||||
|
|
13
curl.spec
13
curl.spec
@ -1,13 +1,16 @@
|
|||||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||||
Name: curl
|
Name: curl
|
||||||
Version: 7.63.0
|
Version: 7.63.0
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
|
Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
# revert an upstream commit that broke `fedpkg new-sources` (#1659329)
|
# revert an upstream commit that broke `fedpkg new-sources` (#1659329)
|
||||||
Patch1: 0001-curl-7.62.0-http-post-negotiate.patch
|
Patch1: 0001-curl-7.62.0-http-post-negotiate.patch
|
||||||
|
|
||||||
|
# libtest: avoid symbol lookup error in libstubgss.so
|
||||||
|
Patch2: 0002-curl-7.62.0-libtest-stub_gssapi-snprintf.patch
|
||||||
|
|
||||||
# curl -J: do not append to the destination file (#1658574)
|
# curl -J: do not append to the destination file (#1658574)
|
||||||
Patch7: 0007-curl-7.63.0-JO-preserve-local-file.patch
|
Patch7: 0007-curl-7.63.0-JO-preserve-local-file.patch
|
||||||
|
|
||||||
@ -23,9 +26,6 @@ Patch103: 0103-curl-7.59.0-python3.patch
|
|||||||
# use localhost6 instead of ip6-localhost in the curl test-suite
|
# use localhost6 instead of ip6-localhost in the curl test-suite
|
||||||
Patch104: 0104-curl-7.19.7-localhost6.patch
|
Patch104: 0104-curl-7.19.7-localhost6.patch
|
||||||
|
|
||||||
# libtest: avoid symbol lookup error in libstubgss.so
|
|
||||||
Patch105: 0105-curl-7.63.0-libstubgss-ldadd.patch
|
|
||||||
|
|
||||||
Provides: curl-full = %{version}-%{release}
|
Provides: curl-full = %{version}-%{release}
|
||||||
Provides: webclient
|
Provides: webclient
|
||||||
URL: https://curl.haxx.se/
|
URL: https://curl.haxx.se/
|
||||||
@ -175,6 +175,7 @@ be installed.
|
|||||||
%patch1 -p1 -R
|
%patch1 -p1 -R
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
|
%patch2 -p1
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
|
|
||||||
# Fedora patches
|
# Fedora patches
|
||||||
@ -182,7 +183,6 @@ be installed.
|
|||||||
%patch102 -p1
|
%patch102 -p1
|
||||||
%patch103 -p1
|
%patch103 -p1
|
||||||
%patch104 -p1
|
%patch104 -p1
|
||||||
%patch105 -p1
|
|
||||||
|
|
||||||
# make tests/*.py use Python 3
|
# make tests/*.py use Python 3
|
||||||
sed -e '1 s|^#!/.*python|#!%{__python3}|' -i tests/*.py
|
sed -e '1 s|^#!/.*python|#!%{__python3}|' -i tests/*.py
|
||||||
@ -343,6 +343,9 @@ rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
|
|||||||
%{_libdir}/libcurl.so.4.[0-9].[0-9].minimal
|
%{_libdir}/libcurl.so.4.[0-9].[0-9].minimal
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 04 2019 Kamil Dudka <kdudka@redhat.com> - 7.63.0-4
|
||||||
|
- replace 0105-curl-7.63.0-libstubgss-ldadd.patch by upstream patch
|
||||||
|
|
||||||
* Wed Dec 19 2018 Kamil Dudka <kdudka@redhat.com> - 7.63.0-3
|
* Wed Dec 19 2018 Kamil Dudka <kdudka@redhat.com> - 7.63.0-3
|
||||||
- curl -J: do not append to the destination file (#1658574)
|
- curl -J: do not append to the destination file (#1658574)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user