replace 0104-curl-7.73.0-localhost6.patch by sed invocation
... to avoid conflict resolution on new upstream releases
This commit is contained in:
parent
b57f5589af
commit
25676e54ef
@ -1,65 +0,0 @@
|
|||||||
From 70734612c0f2f6f864e771ab4d2509c903342739 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kamil Dudka <kdudka@redhat.com>
|
|
||||||
Date: Wed, 14 Oct 2020 09:41:28 +0200
|
|
||||||
Subject: [PATCH] use localhost6 instead of ip6-localhost in the curl
|
|
||||||
test-suite
|
|
||||||
|
|
||||||
---
|
|
||||||
tests/data/test1083 | 6 +++---
|
|
||||||
tests/data/test241 | 8 ++++----
|
|
||||||
2 files changed, 7 insertions(+), 7 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tests/data/test1083 b/tests/data/test1083
|
|
||||||
index e441278..b0958b6 100644
|
|
||||||
--- a/tests/data/test1083
|
|
||||||
+++ b/tests/data/test1083
|
|
||||||
@@ -33,13 +33,13 @@ ipv6
|
|
||||||
http-ipv6
|
|
||||||
</server>
|
|
||||||
<name>
|
|
||||||
-HTTP-IPv6 GET with ip6-localhost --interface
|
|
||||||
+HTTP-IPv6 GET with localhost6 --interface
|
|
||||||
</name>
|
|
||||||
<command>
|
|
||||||
--g "http://%HOST6IP:%HTTP6PORT/1083" --interface ip6-localhost
|
|
||||||
+-g "http://%HOST6IP:%HTTP6PORT/1083" --interface localhost6
|
|
||||||
</command>
|
|
||||||
<precheck>
|
|
||||||
-perl -e "if ('%CLIENT6IP' ne '[::1]') {print 'Test requires default test client host address';} else {exec './server/resolve --ipv6 ip6-localhost'; print 'Cannot run precheck resolve';}"
|
|
||||||
+perl -e "if ('%CLIENT6IP' ne '[::1]') {print 'Test requires default test client host address';} else {exec './server/resolve --ipv6 localhost6'; print 'Cannot run precheck resolve';}"
|
|
||||||
</precheck>
|
|
||||||
</client>
|
|
||||||
|
|
||||||
diff --git a/tests/data/test241 b/tests/data/test241
|
|
||||||
index 46eae1f..4e1632c 100644
|
|
||||||
--- a/tests/data/test241
|
|
||||||
+++ b/tests/data/test241
|
|
||||||
@@ -30,13 +30,13 @@ ipv6
|
|
||||||
http-ipv6
|
|
||||||
</server>
|
|
||||||
<name>
|
|
||||||
-HTTP-IPv6 GET (using ip6-localhost)
|
|
||||||
+HTTP-IPv6 GET (using localhost6)
|
|
||||||
</name>
|
|
||||||
<command>
|
|
||||||
--g "http://ip6-localhost:%HTTP6PORT/241"
|
|
||||||
+-g "http://localhost6:%HTTP6PORT/241"
|
|
||||||
</command>
|
|
||||||
<precheck>
|
|
||||||
-./server/resolve --ipv6 ip6-localhost
|
|
||||||
+./server/resolve --ipv6 localhost6
|
|
||||||
</precheck>
|
|
||||||
</client>
|
|
||||||
|
|
||||||
@@ -45,7 +45,7 @@ HTTP-IPv6 GET (using ip6-localhost)
|
|
||||||
<verify>
|
|
||||||
<protocol>
|
|
||||||
GET /241 HTTP/1.1
|
|
||||||
-Host: ip6-localhost:%HTTP6PORT
|
|
||||||
+Host: localhost6:%HTTP6PORT
|
|
||||||
User-Agent: curl/%VERSION
|
|
||||||
Accept: */*
|
|
||||||
|
|
||||||
--
|
|
||||||
2.25.4
|
|
||||||
|
|
21
curl.spec
21
curl.spec
@ -14,9 +14,6 @@ Patch101: 0101-curl-7.32.0-multilib.patch
|
|||||||
# prevent configure script from discarding -g in CFLAGS (#496778)
|
# prevent configure script from discarding -g in CFLAGS (#496778)
|
||||||
Patch102: 0102-curl-7.36.0-debug.patch
|
Patch102: 0102-curl-7.36.0-debug.patch
|
||||||
|
|
||||||
# use localhost6 instead of ip6-localhost in the curl test-suite
|
|
||||||
Patch104: 0104-curl-7.73.0-localhost6.patch
|
|
||||||
|
|
||||||
# prevent valgrind from reporting false positives on x86_64
|
# prevent valgrind from reporting false positives on x86_64
|
||||||
Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
|
Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
|
||||||
|
|
||||||
@ -191,12 +188,8 @@ be installed.
|
|||||||
# Fedora patches
|
# Fedora patches
|
||||||
%patch101 -p1
|
%patch101 -p1
|
||||||
%patch102 -p1
|
%patch102 -p1
|
||||||
%patch104 -p1
|
|
||||||
%patch105 -p1
|
%patch105 -p1
|
||||||
|
|
||||||
# regenerate the configure script and Makefile.in files
|
|
||||||
autoreconf -fiv
|
|
||||||
|
|
||||||
# disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
|
# disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
|
||||||
# with errno 98: Address already in use' in Koji environment), and test 1801
|
# with errno 98: Address already in use' in Koji environment), and test 1801
|
||||||
# <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
|
# <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
|
||||||
@ -218,7 +211,19 @@ printf "702\n703\n716\n" >> tests/data/DISABLED
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
# adapt test 323 for updated OpenSSL
|
# adapt test 323 for updated OpenSSL
|
||||||
sed -e 's/^35$/35,52/' -i tests/data/test323
|
sed -e 's|^35$|35,52|' -i tests/data/test323
|
||||||
|
|
||||||
|
# use localhost6 instead of ip6-localhost in the curl test-suite
|
||||||
|
(
|
||||||
|
# avoid glob expansion in the trace output of `bash -x`
|
||||||
|
{ set +x; } 2>/dev/null
|
||||||
|
cmd="sed -e 's|ip6-localhost|localhost6|' -i tests/data/test[0-9]*"
|
||||||
|
printf "+ %s\n" "$cmd" >&2
|
||||||
|
eval "$cmd"
|
||||||
|
)
|
||||||
|
|
||||||
|
# regenerate the configure script and Makefile.in files
|
||||||
|
autoreconf -fiv
|
||||||
|
|
||||||
%build
|
%build
|
||||||
mkdir build-{full,minimal}
|
mkdir build-{full,minimal}
|
||||||
|
Loading…
Reference in New Issue
Block a user