cups/cups-1.1.15-initscript.patch
2006-03-17 12:10:57 +00:00

42 lines
2.1 KiB
Diff

--- cups-1.2svn-r5238/Makefile.noinit 2006-03-07 09:37:02.000000000 +0000
+++ cups-1.2svn-r5238/Makefile 2006-03-07 09:42:51.000000000 +0000
@@ -1,4 +1,4 @@
-#
+
# "$Id: cups-1.1.15-initscript.patch,v 1.4 2006/03/17 12:10:57 twaugh Exp $"
#
# Top-level Makefile for the Common UNIX Printing System (CUPS).
@@ -80,32 +80,6 @@
echo Installing cups-config script...
$(INSTALL_DIR) -m 755 $(BINDIR)
$(INSTALL_SCRIPT) cups-config $(BINDIR)/cups-config
- echo Installing startup script...
- if test "x$(INITDIR)" != "x"; then \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(INITDIR)/init.d; \
- $(INSTALL_SCRIPT) init/cups.sh $(BUILDROOT)$(INITDIR)/init.d/cups; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(INITDIR)/rc0.d; \
- $(INSTALL_SCRIPT) init/cups.sh $(BUILDROOT)$(INITDIR)/rc0.d/K00cups; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(INITDIR)/rc2.d; \
- $(INSTALL_SCRIPT) init/cups.sh $(BUILDROOT)$(INITDIR)/rc2.d/S99cups; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(INITDIR)/rc3.d; \
- $(INSTALL_SCRIPT) init/cups.sh $(BUILDROOT)$(INITDIR)/rc3.d/S99cups; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(INITDIR)/rc5.d; \
- $(INSTALL_SCRIPT) init/cups.sh $(BUILDROOT)$(INITDIR)/rc5.d/S99cups; \
- fi
- if test "x$(INITDIR)" = "x" -a "x$(INITDDIR)" != "x"; then \
- $(INSTALL_DIR) $(BUILDROOT)$(INITDDIR); \
- if test "$(INITDDIR)" = "/System/Library/StartupItems/PrintingServices"; then \
- $(INSTALL_SCRIPT) init/PrintingServices $(BUILDROOT)$(INITDDIR)/PrintingServices; \
- $(INSTALL_DATA) init/StartupParameters.plist $(BUILDROOT)$(INITDDIR)/StartupParameters.plist; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(INITDDIR)/Resources/English.lproj; \
- $(INSTALL_DATA) init/Localizable.strings $(BUILDROOT)$(INITDDIR)/Resources/English.lproj/Localizable.strings; \
- elif test "$(INITDDIR)" = "/System/Library/LaunchDaemons"; then \
- $(INSTALL_DATA) init/org.cups.cupsd.plist $(BUILDROOT)$(DEFAULT_LAUNCHD_CONF); \
- else \
- $(INSTALL_SCRIPT) init/cups.sh $(BUILDROOT)$(INITDDIR)/cups; \
- fi \
- fi
if test "x$(DBUSDIR)" != "x"; then \
echo Installing cups.conf in $(DBUSDIR)...;\
$(INSTALL_DIR) -m 755 $(BUILDROOT)$(DBUSDIR); \