1960160 - PreserveJobHistory/JobFiles aren't applied after the first cupsd restart right after successful print
Resolves: rhbz#1960160
This commit is contained in:
parent
d365a00f17
commit
fbff9405cb
16
cups-cleanfiles.patch
Normal file
16
cups-cleanfiles.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff --git a/scheduler/main.c b/scheduler/main.c
|
||||
index e1fa357..53ca94a 100644
|
||||
--- a/scheduler/main.c
|
||||
+++ b/scheduler/main.c
|
||||
@@ -1760,6 +1760,11 @@ select_timeout(int fds) /* I - Number of descriptors returned */
|
||||
/*
|
||||
* Check for any job activity...
|
||||
*/
|
||||
+ if (JobHistoryUpdate && timeout > JobHistoryUpdate)
|
||||
+ {
|
||||
+ timeout = JobHistoryUpdate;
|
||||
+ why = "update job history";
|
||||
+ }
|
||||
|
||||
for (job = (cupsd_job_t *)cupsArrayFirst(ActiveJobs);
|
||||
job;
|
15
cups.spec
15
cups.spec
@ -17,7 +17,7 @@ Summary: CUPS printing system
|
||||
Name: cups
|
||||
Epoch: 1
|
||||
Version: 2.3.3%{OP_VER}
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
License: ASL 2.0
|
||||
Url: http://www.cups.org/
|
||||
# Apple stopped uploading the new versions into github, use OpenPrinting fork
|
||||
@ -73,6 +73,9 @@ Patch100: cups-lspp.patch
|
||||
#### UPSTREAM PATCHES (starts with 1000) ####
|
||||
# 1949053 - CUPS doesn't start if sssd starts after cupsd
|
||||
Patch15: cups-nssuserlookup-target.patch
|
||||
# 1960160 - PreserveJobHistory/JobFiles aren't applied after
|
||||
# the first cupsd restart right after successful print
|
||||
Patch16: cups-cleanfiles.patch
|
||||
|
||||
##### Patches removed because IMHO they aren't no longer needed
|
||||
##### but still I'll leave them in git in case their removal
|
||||
@ -271,12 +274,15 @@ to CUPS daemon. This solution will substitute printer drivers and raw queues in
|
||||
%patch12 -p1 -b .failover
|
||||
# Added IEEE 1284 Device ID for a Dymo device (bug #747866).
|
||||
%patch13 -p1 -b .dymo-deviceid
|
||||
|
||||
# UPSTREAM PATCHES
|
||||
# add [Job N] to logs
|
||||
%patch14 -p1 -b .logs
|
||||
# 1949053 - CUPS doesn't start if sssd starts after cupsd
|
||||
%patch15 -p1 -b .nsslookup
|
||||
|
||||
# UPSTREAM PATCHES
|
||||
# 1960160 - PreserveJobHistory/JobFiles aren't applied after
|
||||
# the first cupsd restart right after successful print
|
||||
%patch16 -p1 -b .cleanfiles
|
||||
|
||||
|
||||
%if %{lspp}
|
||||
@ -674,6 +680,9 @@ rm -f %{cups_serverbin}/backend/smb
|
||||
%{_mandir}/man7/ippeveps.7.gz
|
||||
|
||||
%changelog
|
||||
* Thu May 13 2021 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.3.3op2-6
|
||||
- 1960160 - PreserveJobHistory/JobFiles aren't applied after the first cupsd restart right after successful print
|
||||
|
||||
* Mon Apr 26 2021 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.3.3op2-5
|
||||
- 1949053 - CUPS doesn't start if sssd starts after cupsd
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user