- 1.2.12. No longer need adminutil or str2408 patches.
This commit is contained in:
parent
169494cf98
commit
f55d748d4d
@ -21,3 +21,4 @@ cups-1.2.8-source.tar.bz2
|
|||||||
cups-1.2.9-source.tar.bz2
|
cups-1.2.9-source.tar.bz2
|
||||||
cups-1.2.10-source.tar.bz2
|
cups-1.2.10-source.tar.bz2
|
||||||
cups-1.2.11-source.tar.bz2
|
cups-1.2.11-source.tar.bz2
|
||||||
|
cups-1.2.12-source.tar.bz2
|
||||||
|
@ -1,44 +0,0 @@
|
|||||||
--- cups-1.2.10/cups/adminutil.c.adminutil 2007-05-21 16:39:00.000000000 +0100
|
|
||||||
+++ cups-1.2.10/cups/adminutil.c 2007-05-21 16:45:31.000000000 +0100
|
|
||||||
@@ -1260,14 +1260,21 @@
|
|
||||||
{
|
|
||||||
if (!wrote_browsing)
|
|
||||||
{
|
|
||||||
+ int new_remote_printers = (remote_printers > 0 ||
|
|
||||||
+ (remote_printers == -1 &&
|
|
||||||
+ old_remote_printers > 0));
|
|
||||||
+ int new_share_printers = (share_printers > 0 ||
|
|
||||||
+ (share_printers == -1 &&
|
|
||||||
+ old_share_printers > 0));
|
|
||||||
+
|
|
||||||
wrote_browsing = 1;
|
|
||||||
|
|
||||||
- if (remote_printers > 0 || share_printers > 0)
|
|
||||||
+ if (new_remote_printers | new_share_printers)
|
|
||||||
{
|
|
||||||
- if (remote_printers > 0 && share_printers > 0)
|
|
||||||
+ if (new_remote_printers && new_share_printers)
|
|
||||||
cupsFilePuts(temp,
|
|
||||||
"# Enable printer sharing and shared printers.\n");
|
|
||||||
- else if (remote_printers > 0)
|
|
||||||
+ else if (new_remote_printers)
|
|
||||||
cupsFilePuts(temp,
|
|
||||||
"# Show shared printers on the local network.\n");
|
|
||||||
else
|
|
||||||
@@ -1277,14 +1284,14 @@
|
|
||||||
cupsFilePuts(temp, "Browsing On\n");
|
|
||||||
cupsFilePuts(temp, "BrowseOrder allow,deny\n");
|
|
||||||
|
|
||||||
- if (remote_printers > 0)
|
|
||||||
+ if (new_remote_printers)
|
|
||||||
{
|
|
||||||
cupsFilePuts(temp, "# (Change '@LOCAL' to 'ALL' if using "
|
|
||||||
"directed broadcasts from another subnet.)\n");
|
|
||||||
cupsFilePuts(temp, "BrowseAllow @LOCAL\n");
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (share_printers > 0)
|
|
||||||
+ if (new_share_printers)
|
|
||||||
cupsFilePuts(temp, "BrowseAddress @LOCAL\n");
|
|
||||||
}
|
|
||||||
else
|
|
@ -1,5 +1,5 @@
|
|||||||
--- cups-1.2.8/conf/cupsd.conf.in.directed-broadcast 2006-04-23 22:46:38.000000000 +0100
|
--- cups-1.2.12/conf/cupsd.conf.in.directed-broadcast 2006-04-23 22:46:38.000000000 +0100
|
||||||
+++ cups-1.2.8/conf/cupsd.conf.in 2007-02-14 17:44:51.000000000 +0000
|
+++ cups-1.2.12/conf/cupsd.conf.in 2007-07-13 10:02:06.000000000 +0100
|
||||||
@@ -20,6 +20,7 @@
|
@@ -20,6 +20,7 @@
|
||||||
# Show shared printers on the local network.
|
# Show shared printers on the local network.
|
||||||
Browsing On
|
Browsing On
|
||||||
@ -8,17 +8,18 @@
|
|||||||
BrowseAllow @LOCAL
|
BrowseAllow @LOCAL
|
||||||
|
|
||||||
# Default authentication type, when authentication is required...
|
# Default authentication type, when authentication is required...
|
||||||
--- cups-1.2.8/cups/adminutil.c.directed-broadcast 2007-02-11 16:59:33.000000000 +0000
|
--- cups-1.2.12/cups/adminutil.c.directed-broadcast 2007-07-06 23:39:54.000000000 +0100
|
||||||
+++ cups-1.2.8/cups/adminutil.c 2007-02-14 17:47:04.000000000 +0000
|
+++ cups-1.2.12/cups/adminutil.c 2007-07-13 10:03:15.000000000 +0100
|
||||||
@@ -1278,7 +1278,11 @@
|
@@ -1288,7 +1288,12 @@
|
||||||
cupsFilePuts(temp, "BrowseOrder allow,deny\n");
|
cupsFilePuts(temp, "BrowseOrder allow,deny\n");
|
||||||
|
|
||||||
if (remote_printers > 0)
|
if (new_remote_printers)
|
||||||
+ {
|
+ {
|
||||||
+ cupsFilePuts(temp, "# (Change '@LOCAL' to 'ALL' if using "
|
+ cupsFilePuts(temp,
|
||||||
|
+ "# (Change '@LOCAL' to 'ALL' if using "
|
||||||
+ "directed broadcasts from another subnet.)\n");
|
+ "directed broadcasts from another subnet.)\n");
|
||||||
cupsFilePuts(temp, "BrowseAllow @LOCAL\n");
|
cupsFilePuts(temp, "BrowseAllow @LOCAL\n");
|
||||||
+ }
|
+ }
|
||||||
|
|
||||||
if (share_printers > 0)
|
if (new_share_printers)
|
||||||
cupsFilePuts(temp, "BrowseAddress @LOCAL\n");
|
cupsFilePuts(temp, "BrowseAddress @LOCAL\n");
|
||||||
|
@ -1,51 +0,0 @@
|
|||||||
--- cups-1.2.11/cups/ppd.c.str2408 2007-04-05 00:43:50.000000000 +0100
|
|
||||||
+++ cups-1.2.11/cups/ppd.c 2007-06-29 09:36:12.000000000 +0100
|
|
||||||
@@ -1013,11 +1013,15 @@
|
|
||||||
|
|
||||||
if ((option = ppdFindOption(ppd, keyword + 6)) == NULL)
|
|
||||||
{
|
|
||||||
+ int groupidx; /* Index for current group */
|
|
||||||
ppd_group_t *gtemp; /* Temporary group */
|
|
||||||
|
|
||||||
|
|
||||||
DEBUG_printf(("%s option not found for %s...\n", keyword + 6, keyword));
|
|
||||||
|
|
||||||
+ if (group)
|
|
||||||
+ groupidx = group - ppd->groups; /* Save index for current group */
|
|
||||||
+
|
|
||||||
if ((gtemp = ppd_get_group(ppd, "General", _("General"), cg,
|
|
||||||
encoding)) == NULL)
|
|
||||||
{
|
|
||||||
@@ -1026,6 +1030,9 @@
|
|
||||||
goto error;
|
|
||||||
}
|
|
||||||
|
|
||||||
+ if (group)
|
|
||||||
+ group = ppd->groups + groupidx; /* Restore group pointer */
|
|
||||||
+
|
|
||||||
if ((option = ppd_get_option(gtemp, keyword + 6)) == NULL)
|
|
||||||
{
|
|
||||||
DEBUG_printf(("Unable to get %s option!\n", keyword + 6));
|
|
||||||
@@ -1079,8 +1086,12 @@
|
|
||||||
|
|
||||||
if ((option = ppdFindOption(ppd, "PageRegion")) == NULL)
|
|
||||||
{
|
|
||||||
+ int groupidx; /* Index to current group */
|
|
||||||
ppd_group_t *gtemp; /* Temporary group */
|
|
||||||
|
|
||||||
+ if (group)
|
|
||||||
+ groupidx = group - ppd->groups; /* Save index for current group */
|
|
||||||
+
|
|
||||||
if ((gtemp = ppd_get_group(ppd, "General", _("General"), cg,
|
|
||||||
encoding)) == NULL)
|
|
||||||
{
|
|
||||||
@@ -1089,6 +1100,9 @@
|
|
||||||
goto error;
|
|
||||||
}
|
|
||||||
|
|
||||||
+ if (group)
|
|
||||||
+ group = ppd->groups + groupidx; /* Restore group pointer */
|
|
||||||
+
|
|
||||||
option = ppd_get_option(gtemp, "PageRegion");
|
|
||||||
}
|
|
||||||
|
|
11
cups.spec
11
cups.spec
@ -5,8 +5,8 @@
|
|||||||
|
|
||||||
Summary: Common Unix Printing System
|
Summary: Common Unix Printing System
|
||||||
Name: cups
|
Name: cups
|
||||||
Version: 1.2.11
|
Version: 1.2.12
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: ftp://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
Source: ftp://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
||||||
@ -46,8 +46,6 @@ Patch21: cups-driverd-timeout.patch
|
|||||||
Patch22: cups-af_unix-auth.patch
|
Patch22: cups-af_unix-auth.patch
|
||||||
Patch24: cups-str2109.patch
|
Patch24: cups-str2109.patch
|
||||||
Patch25: cups-usb-paperout.patch
|
Patch25: cups-usb-paperout.patch
|
||||||
Patch26: cups-adminutil.patch
|
|
||||||
Patch27: cups-str2408.patch
|
|
||||||
Patch100: cups-lspp.patch
|
Patch100: cups-lspp.patch
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Url: http://www.cups.org/
|
Url: http://www.cups.org/
|
||||||
@ -156,8 +154,6 @@ lpd emulation.
|
|||||||
%patch22 -p1 -b .af_unix-auth
|
%patch22 -p1 -b .af_unix-auth
|
||||||
%patch24 -p1 -b .str2109
|
%patch24 -p1 -b .str2109
|
||||||
%patch25 -p1 -b .usb-paperout
|
%patch25 -p1 -b .usb-paperout
|
||||||
%patch26 -p1 -b .adminutil
|
|
||||||
%patch27 -p1 -b .str2408
|
|
||||||
|
|
||||||
%if %lspp
|
%if %lspp
|
||||||
%patch100 -p1 -b .lspp
|
%patch100 -p1 -b .lspp
|
||||||
@ -445,6 +441,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{cups_serverbin}/daemon/cups-lpd
|
%{cups_serverbin}/daemon/cups-lpd
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 13 2007 Tim Waugh <twaugh@redhat.com> 1:1.2.12-1
|
||||||
|
- 1.2.12. No longer need adminutil or str2408 patches.
|
||||||
|
|
||||||
* Mon Jul 9 2007 Tim Waugh <twaugh@redhat.com>
|
* Mon Jul 9 2007 Tim Waugh <twaugh@redhat.com>
|
||||||
- Another small improvement for the textonly filter (bug #244979).
|
- Another small improvement for the textonly filter (bug #244979).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user