From f14552855c8d9958d9d7999a109aec8739b4fa0c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jarom=C3=ADr=20Kon=C4=8Dick=C3=BD?=
Date: Wed, 21 Aug 2013 16:33:08 +0200
Subject: [PATCH] Add SyncOnClose option (bug #984883).
---
cups-synconclose.patch | 134 +++++++++++++++++++++++++++++++++++++++++
cups.spec | 8 ++-
2 files changed, 141 insertions(+), 1 deletion(-)
create mode 100644 cups-synconclose.patch
diff --git a/cups-synconclose.patch b/cups-synconclose.patch
new file mode 100644
index 0000000..6962e91
--- /dev/null
+++ b/cups-synconclose.patch
@@ -0,0 +1,134 @@
+Index: conf/cups-files.conf.in
+===================================================================
+--- conf/cups-files.conf.in (revision 11192)
++++ conf/cups-files.conf.in (working copy)
+@@ -8,6 +8,9 @@
+ # List of events that are considered fatal errors for the scheduler...
+ #FatalErrors @CUPS_FATAL_ERRORS@
+
++# Do we call fsync() after writing configuration or status files?
++#SyncOnClose No
++
+ # Default user and group for filters/backends/helper programs; this cannot be
+ # any user or group that resolves to ID 0 for security reasons...
+ #User @CUPS_USER@
+Index: doc/help/ref-cups-files-conf.html.in
+===================================================================
+--- doc/help/ref-cups-files-conf.html.in (revision 11192)
++++ doc/help/ref-cups-files-conf.html.in (working copy)
+@@ -429,6 +429,31 @@
+ default server directory is /etc/cups.
+
+
++
++
++Examples
++
++
++SyncOnClose No
++SyncOnClose Yes
++
++
++Description
++
++The SyncOnClose
directive determines whether the scheduler
++flushes changes to configuration and state files to disk. The default is
++No
which relies on the operating system to schedule a suitable
++time to write changes to disk.
++
++Note:
++
++Setting SyncOnClose
to Yes
makes the scheduler use the fsync(2)
system call to write all changes to disk, however the drive or network file system server may still delay writing data to disk. Do not depend on this functionality to prevent data loss in the event of unexpected hardware failure.
++
++Enabling SyncOnClose
may also cause the scheduler to periodically become unresponsive while it waits for changes to be written.
++
++
++
++
+
+
+ Examples
+Index: man/cups-files.conf.man.in
+===================================================================
+--- man/cups-files.conf.man.in (revision 11192)
++++ man/cups-files.conf.man.in (working copy)
+@@ -122,6 +122,12 @@
+ .br
+ Specifies the directory where the server configuration files can be found.
+ .TP 5
++SyncOnClose Yes
++.TP 5
++SyncOnClose No
++Specifies whether the scheduler calls \fIfsync(2)\fR after writing configuration
++or state files. The default is No.
++.TP 5
+ SystemGroup group-name [group-name ...]
+ .br
+ Specifies the group(s) to use for System class authentication.
+Index: scheduler/conf.c
+===================================================================
+--- scheduler/conf.c (revision 11192)
++++ scheduler/conf.c (working copy)
+@@ -174,6 +174,7 @@
+ { "ServerRoot", &ServerRoot, CUPSD_VARTYPE_PATHNAME },
+ { "SMBConfigFile", &SMBConfigFile, CUPSD_VARTYPE_STRING },
+ { "StateDir", &StateDir, CUPSD_VARTYPE_STRING },
++ { "SyncOnClose", &SyncOnClose, CUPSD_VARTYPE_BOOLEAN },
+ #ifdef HAVE_AUTHORIZATION_H
+ { "SystemGroupAuthKey", &SystemGroupAuthKey, CUPSD_VARTYPE_STRING },
+ #endif /* HAVE_AUTHORIZATION_H */
+@@ -734,6 +735,7 @@
+ ReloadTimeout = DEFAULT_KEEPALIVE;
+ RootCertDuration = 300;
+ StrictConformance = FALSE;
++ SyncOnClose = FALSE;
+ Timeout = DEFAULT_TIMEOUT;
+ WebInterface = CUPS_DEFAULT_WEBIF;
+
+Index: scheduler/conf.h
+===================================================================
+--- scheduler/conf.h (revision 11192)
++++ scheduler/conf.h (working copy)
+@@ -172,6 +172,8 @@
+ /* Which errors are fatal? */
+ StrictConformance VALUE(FALSE),
+ /* Require strict IPP conformance? */
++ SyncOnClose VALUE(FALSE),
++ /* Call fsync() when closing files? */
+ LogFilePerm VALUE(0644);
+ /* Permissions for log files */
+ VAR cupsd_loglevel_t LogLevel VALUE(CUPSD_LOG_WARN);
+Index: scheduler/file.c
+===================================================================
+--- scheduler/file.c (revision 11192)
++++ scheduler/file.c (working copy)
+@@ -109,6 +109,29 @@
+
+
+ /*
++ * Synchronize changes to disk if SyncOnClose is enabled.
++ */
++
++ if (SyncOnClose)
++ {
++ if (cupsFileFlush(fp))
++ {
++ cupsdLogMessage(CUPSD_LOG_ERROR, "Unable to write changes to \"%s\": %s",
++ filename, strerror(errno));
++ cupsFileClose(fp);
++ return (-1);
++ }
++
++ if (fsync(cupsFileNumber(fp)))
++ {
++ cupsdLogMessage(CUPSD_LOG_ERROR, "Unable to sync changes to \"%s\": %s",
++ filename, strerror(errno));
++ cupsFileClose(fp);
++ return (-1);
++ }
++ }
++
++ /*
+ * First close the file...
+ */
+
diff --git a/cups.spec b/cups.spec
index 9c6b5cc..93d5e25 100644
--- a/cups.spec
+++ b/cups.spec
@@ -11,7 +11,7 @@ Summary: CUPS printing system
Name: cups
Epoch: 1
Version: 1.6.3
-Release: 7%{?dist}
+Release: 8%{?dist}
License: GPLv2
Group: System Environment/Daemons
Url: http://www.cups.org/
@@ -66,6 +66,7 @@ Patch35: cups-gz-crc.patch
Patch36: cups-ipp-multifile.patch
Patch37: cups-full-relro.patch
Patch38: cups-web-devices-timeout.patch
+Patch39: cups-synconclose.patch
Patch100: cups-lspp.patch
@@ -257,6 +258,8 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
%patch37 -p1 -b .full-relro
# Increase web interface get-devices timeout to 10s (bug #996664).
%patch38 -p1 -b .web-devices-timeout
+# Add SyncOnClose option (bug #984883).
+%patch39 -p0 -b .synconclose
%if %lspp
# LSPP support.
@@ -643,6 +646,9 @@ rm -f %{cups_serverbin}/backend/smb
%{_mandir}/man5/ipptoolfile.5.gz
%changelog
+* Wed Aug 21 2013 Jaromír Končický - 1:1.6.3-8
+- Add SyncOnClose option (bug #984883).
+
* Fri Aug 16 2013 Tim Waugh - 1:1.6.3-7
- Increase web interface get-devices timeout to 10s (bug #996664).