Resolves: rhbz#1077239
This commit is contained in:
parent
66abbacc23
commit
ea58b56951
@ -1,12 +0,0 @@
|
|||||||
diff -up cups-1.7.1/cups/request.c.str4386 cups-1.7.1/cups/request.c
|
|
||||||
--- cups-1.7.1/cups/request.c.str4386 2013-07-23 13:33:52.000000000 +0100
|
|
||||||
+++ cups-1.7.1/cups/request.c 2014-03-06 10:58:39.018807898 +0000
|
|
||||||
@@ -261,7 +261,7 @@ cupsDoIORequest(http_t *http, /* I -
|
|
||||||
* Get the server's response...
|
|
||||||
*/
|
|
||||||
|
|
||||||
- if (status != HTTP_STATUS_ERROR)
|
|
||||||
+ if (status <= HTTP_STATUS_CONTINUE)
|
|
||||||
{
|
|
||||||
response = cupsGetResponse(http, resource);
|
|
||||||
status = httpGetStatus(http);
|
|
13
cups.spec
13
cups.spec
@ -11,7 +11,7 @@ Summary: CUPS printing system
|
|||||||
Name: cups
|
Name: cups
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 1.7.1
|
Version: 1.7.1
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Url: http://www.cups.org/
|
Url: http://www.cups.org/
|
||||||
@ -70,8 +70,7 @@ Patch42: cups-synconclose.patch
|
|||||||
Patch43: cups-avahi-browse.patch
|
Patch43: cups-avahi-browse.patch
|
||||||
Patch44: cups-str4380.patch
|
Patch44: cups-str4380.patch
|
||||||
Patch45: cups-str4366.patch
|
Patch45: cups-str4366.patch
|
||||||
Patch46: cups-str4386.patch
|
Patch46: cups-str4332.patch
|
||||||
Patch47: cups-str4332.patch
|
|
||||||
|
|
||||||
Patch100: cups-lspp.patch
|
Patch100: cups-lspp.patch
|
||||||
|
|
||||||
@ -272,10 +271,8 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
|||||||
%patch44 -p1 -b .str4380
|
%patch44 -p1 -b .str4380
|
||||||
# Prevent feedback loop when fetching error_log over HTTP (STR #4366).
|
# Prevent feedback loop when fetching error_log over HTTP (STR #4366).
|
||||||
%patch45 -p1 -b .str4366
|
%patch45 -p1 -b .str4366
|
||||||
# libcups: avoid race condition when sending IPP requests (STR #4386).
|
|
||||||
%patch46 -p1 -b .str4386
|
|
||||||
# Track local default in cupsEnumDests() (STR #4332).
|
# Track local default in cupsEnumDests() (STR #4332).
|
||||||
%patch47 -p1 -b .str4332
|
%patch46 -p1 -b .str4332
|
||||||
|
|
||||||
%if %lspp
|
%if %lspp
|
||||||
# LSPP support.
|
# LSPP support.
|
||||||
@ -656,6 +653,10 @@ rm -f %{cups_serverbin}/backend/smb
|
|||||||
%{_mandir}/man5/ipptoolfile.5.gz
|
%{_mandir}/man5/ipptoolfile.5.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 18 2014 Tim Waugh <twaugh@redhat.com> - 1:1.7.1-8
|
||||||
|
- Removed patch for STR #4386 as it does not work and causes problems
|
||||||
|
instead (bug #1077239).
|
||||||
|
|
||||||
* Mon Mar 10 2014 Jiri Popelka <jpopelka@redhat.com> - 1:1.7.1-7
|
* Mon Mar 10 2014 Jiri Popelka <jpopelka@redhat.com> - 1:1.7.1-7
|
||||||
- BuildRequires: pkgconfig(foo) instead of foo-devel
|
- BuildRequires: pkgconfig(foo) instead of foo-devel
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user