parent
4bf29a75e6
commit
e747b4b365
32
cups-filter-debug.patch
Normal file
32
cups-filter-debug.patch
Normal file
@ -0,0 +1,32 @@
|
||||
diff -up cups-1.4rc1/scheduler/job.c.filter-debug cups-1.4rc1/scheduler/job.c
|
||||
--- cups-1.4rc1/scheduler/job.c.filter-debug 2009-06-23 18:10:57.125572911 +0100
|
||||
+++ cups-1.4rc1/scheduler/job.c 2009-06-23 18:11:31.495572481 +0100
|
||||
@@ -544,10 +544,28 @@ cupsdContinueJob(cupsd_job_t *job) /* I
|
||||
|
||||
if (!filters)
|
||||
{
|
||||
+ mime_filter_t *current;
|
||||
+
|
||||
cupsdLogJob(job, CUPSD_LOG_ERROR,
|
||||
"Unable to convert file %d to printable format!",
|
||||
job->current_file);
|
||||
|
||||
+ cupsdLogJob(job, CUPSD_LOG_ERROR,
|
||||
+ "Required: %s/%s -> %s/%s",
|
||||
+ job->filetypes[job->current_file]->super,
|
||||
+ job->filetypes[job->current_file]->type,
|
||||
+ job->printer->filetype->super,
|
||||
+ job->printer->filetype->type);
|
||||
+
|
||||
+ for (current = (mime_filter_t *)cupsArrayFirst(MimeDatabase->srcs);
|
||||
+ current;
|
||||
+ current = (mime_filter_t *)cupsArrayNext(MimeDatabase->srcs))
|
||||
+ cupsdLogJob(job, CUPSD_LOG_ERROR,
|
||||
+ "Available: %s/%s -> %s/%s (%s)",
|
||||
+ current->src->super, current->src->type,
|
||||
+ current->dst->super, current->dst->type,
|
||||
+ current->filter);
|
||||
+
|
||||
abort_message = "Aborting job because it cannot be printed.";
|
||||
abort_state = IPP_JOB_ABORTED;
|
||||
|
36
cups-str3231.patch
Normal file
36
cups-str3231.patch
Normal file
@ -0,0 +1,36 @@
|
||||
diff -up cups-1.4rc1/cups/request.c.str3231 cups-1.4rc1/cups/request.c
|
||||
--- cups-1.4rc1/cups/request.c.str3231 2009-06-29 10:07:23.568486428 +0100
|
||||
+++ cups-1.4rc1/cups/request.c 2009-06-29 10:07:44.867219805 +0100
|
||||
@@ -266,9 +266,9 @@ cupsDoIORequest(http_t *http, /* I -
|
||||
|
||||
DEBUG_printf(("2cupsDoIORequest: status=%d", status));
|
||||
|
||||
- if (status == HTTP_FORBIDDEN || status == HTTP_ERROR ||
|
||||
- status >= HTTP_SERVER_ERROR)
|
||||
+ if (status == HTTP_FORBIDDEN || status >= HTTP_SERVER_ERROR)
|
||||
{
|
||||
+ httpFlush(http);
|
||||
_cupsSetHTTPError(status);
|
||||
break;
|
||||
}
|
||||
diff -up cups-1.4rc1/cups/http.c.length cups-1.4rc1/cups/http.c
|
||||
--- cups-1.4rc1/cups/http.c.length 2009-07-01 12:00:16.591298309 +0100
|
||||
+++ cups-1.4rc1/cups/http.c 2009-07-01 12:00:43.494298468 +0100
|
||||
@@ -3143,6 +3145,8 @@ http_upgrade(http_t *http) /* I - Conne
|
||||
|
||||
DEBUG_printf(("7http_upgrade(%p)", http));
|
||||
|
||||
+ httpFlush(http);
|
||||
+
|
||||
/*
|
||||
* Copy the HTTP data to a local variable so we can do the OPTIONS
|
||||
* request without interfering with the existing request data...
|
||||
@@ -3170,8 +3174,6 @@ http_upgrade(http_t *http) /* I - Conne
|
||||
while (httpUpdate(http) == HTTP_CONTINUE);
|
||||
}
|
||||
|
||||
- httpFlush(http);
|
||||
-
|
||||
/*
|
||||
* Restore the HTTP request data...
|
||||
*/
|
16
cups.spec
16
cups.spec
@ -7,7 +7,7 @@
|
||||
Summary: Common Unix Printing System
|
||||
Name: cups
|
||||
Version: 1.4
|
||||
Release: 0.%{pre}.4%{?dist}
|
||||
Release: 0.%{pre}.6%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Daemons
|
||||
Source: ftp://ftp.easysw.com/pub/cups/test//cups-%{version}%{?pre}%{?svn}-source.tar.bz2
|
||||
@ -45,7 +45,9 @@ Patch21: cups-usb-paperout.patch
|
||||
Patch22: cups-build.patch
|
||||
Patch23: cups-res_init.patch
|
||||
Patch24: cups-str3229.patch
|
||||
Patch26: cups-avahi.patch
|
||||
Patch25: cups-filter-debug.patch
|
||||
Patch26: cups-str3231.patch
|
||||
Patch27: cups-avahi.patch
|
||||
Patch100: cups-lspp.patch
|
||||
Epoch: 1
|
||||
Url: http://www.cups.org/
|
||||
@ -186,7 +188,9 @@ module.
|
||||
%patch22 -p1 -b .build
|
||||
%patch23 -p1 -b .res_init
|
||||
%patch24 -p1 -b .str3229
|
||||
#%patch26 -p1 -b .avahi
|
||||
%patch25 -p1 -b .filter-debug
|
||||
%patch26 -p1 -b .str3231
|
||||
#%patch27 -p1 -b .avahi
|
||||
|
||||
%if %lspp
|
||||
%patch100 -p1 -b .lspp
|
||||
@ -470,6 +474,12 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/php/modules/*.so
|
||||
|
||||
%changelog
|
||||
* Wed Jul 1 2009 Tim Waugh <twaugh@redhat.com> 1:1.4-0.rc1.6
|
||||
- Fixed lpadmin for remote 1.3.x servers (bug #506977, STR #3231).
|
||||
|
||||
* Tue Jun 23 2009 Tim Waugh <twaugh@redhat.com> 1:1.4-0.rc1.5
|
||||
- Added more debugging output when constructing filter chain.
|
||||
|
||||
* Thu Jun 18 2009 Tim Waugh <twaugh@redhat.com> 1:1.4-0.rc1.4
|
||||
- More complete fix for STR #3229 (bug #506461).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user