1.4.8
This commit is contained in:
parent
39d7e8f15b
commit
ccb8206c51
1
.gitignore
vendored
1
.gitignore
vendored
@ -46,3 +46,4 @@ cups-1.4.4-source.tar.bz2
|
|||||||
/cups-1.4.5-source.tar.bz2
|
/cups-1.4.5-source.tar.bz2
|
||||||
/cups-1.4.6-source.tar.bz2
|
/cups-1.4.6-source.tar.bz2
|
||||||
/cups-1.4.7-source.tar.bz2
|
/cups-1.4.7-source.tar.bz2
|
||||||
|
/cups-1.4.8-source.tar.bz2
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up cups-1.4.7/backend/snmp-supplies.c.snmp-quirks cups-1.4.7/backend/snmp-supplies.c
|
diff -up cups-1.4.8/backend/snmp-supplies.c.snmp-quirks cups-1.4.8/backend/snmp-supplies.c
|
||||||
--- cups-1.4.7/backend/snmp-supplies.c.snmp-quirks 2011-03-10 04:50:59.000000000 +0100
|
--- cups-1.4.8/backend/snmp-supplies.c.snmp-quirks 2011-07-06 22:27:31.000000000 +0200
|
||||||
+++ cups-1.4.7/backend/snmp-supplies.c 2011-06-28 11:11:57.944155996 +0200
|
+++ cups-1.4.8/backend/snmp-supplies.c 2011-07-26 11:02:14.709121584 +0200
|
||||||
@@ -49,6 +49,13 @@
|
@@ -49,6 +49,13 @@
|
||||||
|
|
||||||
|
|
||||||
@ -59,10 +59,10 @@ diff -up cups-1.4.7/backend/snmp-supplies.c.snmp-quirks cups-1.4.7/backend/snmp-
|
|||||||
+ if (quirks & QUIRK_CAPACITY)
|
+ if (quirks & QUIRK_CAPACITY)
|
||||||
+ supplies[i].max_capacity = 100;
|
+ supplies[i].max_capacity = 100;
|
||||||
+
|
+
|
||||||
|
if (supplies[i].max_capacity > 0)
|
||||||
percent = 100 * supplies[i].level / supplies[i].max_capacity;
|
percent = 100 * supplies[i].level / supplies[i].max_capacity;
|
||||||
|
else
|
||||||
if (percent <= 10)
|
@@ -409,6 +435,7 @@ backend_init_supplies(
|
||||||
@@ -406,6 +432,7 @@ backend_init_supplies(
|
|
||||||
http_addr_t *addr) /* I - Printer address */
|
http_addr_t *addr) /* I - Printer address */
|
||||||
{
|
{
|
||||||
int i, /* Looping var */
|
int i, /* Looping var */
|
||||||
@ -70,7 +70,7 @@ diff -up cups-1.4.7/backend/snmp-supplies.c.snmp-quirks cups-1.4.7/backend/snmp-
|
|||||||
type; /* Current marker type */
|
type; /* Current marker type */
|
||||||
cups_file_t *cachefile; /* Cache file */
|
cups_file_t *cachefile; /* Cache file */
|
||||||
const char *cachedir; /* CUPS_CACHEDIR value */
|
const char *cachedir; /* CUPS_CACHEDIR value */
|
||||||
@@ -467,6 +494,7 @@ backend_init_supplies(
|
@@ -470,6 +497,7 @@ backend_init_supplies(
|
||||||
current_state = -1;
|
current_state = -1;
|
||||||
num_supplies = -1;
|
num_supplies = -1;
|
||||||
charset = -1;
|
charset = -1;
|
||||||
@ -78,7 +78,7 @@ diff -up cups-1.4.7/backend/snmp-supplies.c.snmp-quirks cups-1.4.7/backend/snmp-
|
|||||||
|
|
||||||
memset(supplies, 0, sizeof(supplies));
|
memset(supplies, 0, sizeof(supplies));
|
||||||
|
|
||||||
@@ -482,6 +510,34 @@ backend_init_supplies(
|
@@ -485,6 +513,34 @@ backend_init_supplies(
|
||||||
return;
|
return;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -1,15 +0,0 @@
|
|||||||
diff -up cups-1.4.7/backend/snmp-supplies.c.str3875 cups-1.4.7/backend/snmp-supplies.c
|
|
||||||
--- cups-1.4.7/backend/snmp-supplies.c.str3875 2011-07-07 16:44:41.000000000 +0200
|
|
||||||
+++ cups-1.4.7/backend/snmp-supplies.c 2011-07-07 16:48:19.201008765 +0200
|
|
||||||
@@ -259,7 +259,10 @@ backendSNMPSupplies(
|
|
||||||
if (quirks & QUIRK_CAPACITY)
|
|
||||||
supplies[i].max_capacity = 100;
|
|
||||||
|
|
||||||
- percent = 100 * supplies[i].level / supplies[i].max_capacity;
|
|
||||||
+ if (supplies[i].max_capacity > 0)
|
|
||||||
+ percent = 100 * supplies[i].level / supplies[i].max_capacity;
|
|
||||||
+ else
|
|
||||||
+ percent = 50;
|
|
||||||
|
|
||||||
if (percent <= 10)
|
|
||||||
{
|
|
@ -1,46 +0,0 @@
|
|||||||
diff -up cups-1.4.7/scheduler/job.c.str3880 cups-1.4.7/scheduler/job.c
|
|
||||||
--- cups-1.4.7/scheduler/job.c.str3880 2011-07-20 13:19:38.280543190 +0100
|
|
||||||
+++ cups-1.4.7/scheduler/job.c 2011-07-20 13:20:01.691126073 +0100
|
|
||||||
@@ -291,7 +291,7 @@ cupsdCheckJobs(void)
|
|
||||||
|
|
||||||
if (job->kill_time && job->kill_time <= curtime)
|
|
||||||
{
|
|
||||||
- cupsdLogMessage(CUPSD_LOG_ERROR, "[Job %d] Stopping unresponsive job!",
|
|
||||||
+ cupsdLogMessage(CUPSD_LOG_ERROR, "[Job %d] Stopping unresponsive job!",
|
|
||||||
job->id);
|
|
||||||
|
|
||||||
stop_job(job, CUPSD_JOB_FORCE);
|
|
||||||
@@ -1338,14 +1338,19 @@ cupsdDeleteJob(cupsd_job_t *job, /
|
|
||||||
free(job->compressions);
|
|
||||||
free(job->filetypes);
|
|
||||||
|
|
||||||
- while (job->num_files > 0)
|
|
||||||
+ if (action == CUPSD_JOB_PURGE)
|
|
||||||
{
|
|
||||||
- snprintf(filename, sizeof(filename), "%s/d%05d-%03d", RequestRoot,
|
|
||||||
- job->id, job->num_files);
|
|
||||||
- unlink(filename);
|
|
||||||
+ while (job->num_files > 0)
|
|
||||||
+ {
|
|
||||||
+ snprintf(filename, sizeof(filename), "%s/d%05d-%03d", RequestRoot,
|
|
||||||
+ job->id, job->num_files);
|
|
||||||
+ unlink(filename);
|
|
||||||
|
|
||||||
- job->num_files --;
|
|
||||||
+ job->num_files --;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
+ else
|
|
||||||
+ job->num_files = 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
if (job->history)
|
|
||||||
@@ -3224,7 +3229,7 @@ get_options(cupsd_job_t *job, /* I - Jo
|
|
||||||
IPP_TAG_ZERO)) != NULL &&
|
|
||||||
(attr->value_tag == IPP_TAG_KEYWORD ||
|
|
||||||
attr->value_tag == IPP_TAG_NAME) &&
|
|
||||||
- (ppd = _pwgGetOutputBin(pwg, attr->values[0].string.text)) != NULL)
|
|
||||||
+ (ppd = _pwgGetOutputBin(pwg, attr->values[0].string.text)) != NULL)
|
|
||||||
{
|
|
||||||
/*
|
|
||||||
* Map output-bin to OutputBin option...
|
|
17
cups.spec
17
cups.spec
@ -7,8 +7,8 @@
|
|||||||
|
|
||||||
Summary: Common Unix Printing System
|
Summary: Common Unix Printing System
|
||||||
Name: cups
|
Name: cups
|
||||||
Version: 1.4.7
|
Version: 1.4.8
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
||||||
@ -65,9 +65,7 @@ Patch30: cups-hp-deviceid-oid.patch
|
|||||||
Patch31: cups-dnssd-deviceid.patch
|
Patch31: cups-dnssd-deviceid.patch
|
||||||
Patch32: cups-ricoh-deviceid-oid.patch
|
Patch32: cups-ricoh-deviceid-oid.patch
|
||||||
Patch33: cups-texttops-rotate-page.patch
|
Patch33: cups-texttops-rotate-page.patch
|
||||||
Patch34: cups-str3875.patch
|
Patch34: cups-polld-busy-loop.patch
|
||||||
Patch35: cups-polld-busy-loop.patch
|
|
||||||
Patch36: cups-str3880.patch
|
|
||||||
|
|
||||||
Patch100: cups-lspp.patch
|
Patch100: cups-lspp.patch
|
||||||
|
|
||||||
@ -266,12 +264,8 @@ module.
|
|||||||
# This fixes page-label orientation when texttops is used in the
|
# This fixes page-label orientation when texttops is used in the
|
||||||
# filter chain (bug #572338).
|
# filter chain (bug #572338).
|
||||||
%patch33 -p1 -b .texttops-rotate-page
|
%patch33 -p1 -b .texttops-rotate-page
|
||||||
# Fix SNMP supply level crasher (STR #3875, bug #719057).
|
|
||||||
%patch34 -p1 -b .str3875
|
|
||||||
# Avoid busy loop in cups-polld (bug #720921).
|
# Avoid busy loop in cups-polld (bug #720921).
|
||||||
%patch35 -p1 -b .polld-busy-loop
|
%patch34 -p1 -b .polld-busy-loop
|
||||||
# Don't delete job data files when restarted (STR #3880).
|
|
||||||
%patch36 -p1 -b .str3880
|
|
||||||
|
|
||||||
%if %lspp
|
%if %lspp
|
||||||
# LSPP support.
|
# LSPP support.
|
||||||
@ -580,6 +574,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{php_extdir}/phpcups.so
|
%{php_extdir}/phpcups.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 26 2011 Jiri Popelka <jpopelka@redhat.com> 1:1.4.8-1
|
||||||
|
- 1.4.8
|
||||||
|
|
||||||
* Wed Jul 20 2011 Tim Waugh <twaugh@redhat.com> 1:1.4.7-8
|
* Wed Jul 20 2011 Tim Waugh <twaugh@redhat.com> 1:1.4.7-8
|
||||||
- Don't delete job data files when restarted (STR #3880).
|
- Don't delete job data files when restarted (STR #3880).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user